• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Oam files imported into Captivate

Explorer ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

My oam file works fine if it is just placed on the page in Captivate, I can see the animation when previewed in html5.  But what I want it to do is, use an Advaced Action to show when called with button variable.  Now, it does show when called with the vaibley but it does not show the animation. It's like it's at the end of the animation.    The only script I have in the oan is a stop action at then end.
Any suggestions?

Thanks!

Views

153

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

I don't understand your question, sorry. If you want to interact between the OAM and Captivate you need to use JavaScript, but apparently you only have STOP at the end, no interaction possible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Hi, thanks for your reply.  I don't what it interact dirctly with the oam.  It's just an animation that I imported into Captivate.
Within Captivate I have a advanced action set on a button, so when the button is selected it shows the animation.  Now that all works, except when the animation (oam) shows, there's no animation. It's like its at the end of it's frames. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Animations, notwithstanding the type, are bit special. They will play when they appear on the timeline. If they start on the first frame of a slide, even if you have Pause for the On Enter event, they'll play.

Can you show a screenshot of the Timeline and the advanced action? Maybe the animation is at its end when the 'Show' command is triggered? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

screenShot.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

The animation is the web2

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

...and thanks again for helping me with this.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Before answering, would like to check out that what I suspect to work is indeed functional (thinking about micro-navigation). Please be patient...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 15, 2020 Apr 15, 2020

Copy link to clipboard

Copied

Micro-navigation, intresting

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 16, 2020 Apr 16, 2020

Copy link to clipboard

Copied

LATEST

Sorry for the delay, had first to finish accountancy (which I hate).

 

Moreover I needed to create an OAM, because those I had were either looping, or had interactive objects themselves. 

 

My intuition was confirmed, it works with micro-navigation. You need to re-enter the slide, when clicking the button to show the animation. Navigation to the first frame of the present slide is not helping, it needs to be a re-enter. I will write out the setup in a blog post and keep you informed. Want to check if the workflow is also valid for a non-looping animated GIF.   Even though the animation is hidden, it will play and that is the reason why you only do see the last frame, unless you are very quickly clicking.

Want to read about micro-navigation while waiting?

http://blog.lilybiri.com/micro-navigation-introduction

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines