• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Option scrip on execute advanced actions its not work :S

New Here ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

Good afternoon.

I am writing on this blog because I have not been able to solve this problem, not even with the help of Adobe consultants.

I have created variables with the necessary names and numbers and I have also created several advanced actions, but when I try to execute the advanced actions on a slide or element, the Scripts dropdown menu is blocked and I cannot choose any of my advanced actions.

Sebastian24014450086u_0-1649795321037.png

 

Views

82

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

Can you show a screenshot of the Advanced Actions dialog box, and open the dropdown list top right?

Moreover check the exact version number you are using under Help, About Captivate.

Did you try to clean the Preferences, which could help if Captivate has corrupted.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

Hi Lilybiri

 

Thanks for writing

to answer this question "Did you try cleaning the Preferences, which might help if Captivate has been corrupted?"
i cleared the program cache, created a new project and put the slides back in, renamed actions, variables and even
elements, removing spaces and underscores.
I don't know if there may be another way to clean that information.

 

Asset 1.png

Asset 2.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

I am still on 11.5, you are on 11.8 but nothing essential has changed.

That advanced action seems to be very complicated, probably could be streamlined much better, but that is off topic. 

Apparently you didn't clean the Preferences yet. Close Captivate, find the subfolder 'utils' under the installation folder and run the CleanPreferences... file which is appropriate for your OS. I don't know if you are on Windows or Mac. Your version is needed for the most recent iOS and if you are using a M1 chip on a Mac, but also if you are on Win11.

Try clearning the Preferences first. Clearing the cache is OK but didn't solve your problems. Copy/paste to a new project could solve corruption in the file, but you need to find the corrupted slide/object/action in that case.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

cleanpreferences not limited, the problem is still reflected

 

This same problem has already been reflected in 2 different projects, which have been carried out from scratch

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Do you see this problem if you just create a new blank project, then create one VERY simple Conditional Advanced Action (e.g. with the condition as IF 1 is equal to 1 and the action set to Continue)?

 

If the answer is yes, even such a simple project with a very simple Advanced Action still fails, then I would suggest you need to reinstall Captivate.

 

If the simple project works fine, then start ramping up the complexity until you can replicate the failure.

 

However, I also agree with Lilybiri. Your Conditional Advanced Action seems overly complex and that is also a likely cause of issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

LATEST

Sorry not to have answered last night because I was in dreamland.

If CleanPreferences didn't solve the problem, would suggest to check out if you can reproduce the problem with a simple project using a very simple advanced action. If yes, only reinstallation could solve the issue.

Know that too complicated or too many advanced actions/variables can cause Captivate to choke. Lot of the consultancy jobs I took on resulted in simplifying and streamlining those. From that unique screenshot I already warned you about complicated advanced actions: first decision shows a forced view with many variables, and without using either multistate objects or using grouping for the Hide/Show workflow. See:

http://blog.lilybiri.com/tip-3-show-slash-hide-or-multistate-object-advanced-slash-shared-actions

I have no idea about the other decisions, nor about having the correct sequence. If you want help with those advanced actions, please post a FULL screenshot of the Preview action window, which you access using this button:

PreviewButton.PNG

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines