• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Question pool issues

New Here ,
Sep 13, 2017 Sep 13, 2017

Copy link to clipboard

Copied

Captivate 2017 10.0.0.192

Windows 10

Blank project/non-responsive

Hello,

I have a 15 question quiz that is built from three question pools of 10 questions each (pool depth of two, so each contributes five questions to the quiz). The pools run in order, 07, 08, and 09 (questions aren't shuffled between these).

Regardless of what I try, the first pool on the list in the question pool manager has an error shield and 15 "Random Questions using this pool" associated with it. Note the differences between the information provided for 07_SectQuiz and 08_SectQuiz in these two screenshots:

message_02.PNGmessage_03.PNG

As a result of this, upon publishing I receive the following message:

message_01.PNG

  • If I click "Yes" and publish, the program works just fine until it reaches then end of the questions associated with 07, then the published program just freezes.

  • If I click "No" and "invoke the Question pools Manager" (sic), there do not appear to be any "corrective actions" I can take.

I tried reloading the original 07 GIFT file into a new pool and then deleting the offending 07_SectQuiz pool. No love. Instead, immediately, 08_SectQuiz moved into the error position.

Of course, I'm on a deadline, but cannot deliver this draft as is. Please advise as to the action I should take to correct this issue.

Thank you!

Views

335

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 13, 2017 Sep 13, 2017

Each of your Random Question Slides must be associated with a specific Question Pool.

Your screen shots seem to show that two of the Question Pools have no associated Random Question slides.

Check each Random Question Slide and make sure only 5 are associated with each pool.

Likes

Translate

Translate
Community Expert ,
Sep 13, 2017 Sep 13, 2017

Copy link to clipboard

Copied

Each of your Random Question Slides must be associated with a specific Question Pool.

Your screen shots seem to show that two of the Question Pools have no associated Random Question slides.

Check each Random Question Slide and make sure only 5 are associated with each pool.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2017 Sep 14, 2017

Copy link to clipboard

Copied

Yes, that was the issue!

I had imported the question slides from the previous quiz set, and didn't realize this step was needed. =P

An easy fix, and I thank you for your prompt and spot-on response.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

Hi Rod, I have the exact same problem, but I don't understand HOW I can check each Random Question Slide to make sure that only a certain number is associated with the respective pool. Is there a way to do this in the question pool manager? I went to insert question slide, clicked on random question at the bottom and chose the correct pool. I did that three times now and the random questions add up everytime I do it. I now have 26 random question in a question pool of 15...

 

Also, I don't know how to get to the question pool view where you can see previews of the question pool question in the timeline. 

I'm getting desperate...

Thanks in advance, Nina

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

Open the panel 'Question Pool' to see the questions in the pool (from Window menu). I create a workspace in the Expert UI where the question pool is added to the bottom docking station. That same docking station has also the Timeline, but for a question slide the Timeline is not showing a lot of information since all objects are embedded except eventually added custom objects.

When you insert a Random slide, the grey placeholder clearly mentions which pool will be used for this random slide. It would be nice to have that information also in the Advanced Interaction panel, but that is not the case.

 

More about Question Pools in:

http://blog.lilybiri.com/random-questions-dos-and-donts

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

LATEST

Hi Lilybiri, you are my Captivate hero and keeper of my sanity! Thank you, I've found the panel (hallelujah) and deleted all the superflous questions by deleting the grey placeholders....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines