• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

SCORM video (1920 x 1080) used to play perfectly in LMS - after editing, playback is too big

New Here ,
Apr 12, 2023 Apr 12, 2023

Copy link to clipboard

Copied

Last year, I recorded a simulation in Captivate. The resulting project was 1920 x 1080.  I published the video using SCORM 1.2 and posted it to our LMS, and it played perfectly.

 

This year, I made a copy of the original and edited the file:

  • Edited some of the audio
  • Added captions to all the slides
  • Added javascript to the first slide to surpress the "x" on the caption boxes
  • Added Play/Pause/CC buttons (inserted images, applied "Use as Button", added Advanced Actions) 

 

When I preview the project, it looks great, but when I publish it, I see issues

  • If I publish as MP4, the last slide (image only) is missing from the MP4. The audio is there, but not the last slide image.
  • If I publish as SCORM zip file and post the recording to our LMS, when it plays, the video is oversized (too big to fit in the browser window), so the outer edges are cut off.

 

The original video did not have these issues. I'm not sure what went wrong during editing, but I need the video to publish and play properly in both MP4 and SCORM zip. Any help would be greatly appreciated.

 

Views

638

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2023 Apr 12, 2023

Copy link to clipboard

Copied

Sorry, but I am a bit confused.

I see a mix of passive video and interactive output mentioned. A passive video (MP4) cannot have any interactive objects like the buttons with attached advanced actions which you mention. Moreover it can never transfer information to a LMS, which means it can not be a SCORM output at all.

Can you please clarify what you want exactly: a passive video or a SCORM output which can transfer information to a LMS because Reporting has been set up and interaction data will be exchanged. 

As for the size of HTML5 output, which is the only way you can create a SCORM compliant output, I hope you did activate the option 'Scalable HTML'? Such a feature doesn't exist for MP4 output.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2023 Apr 12, 2023

Copy link to clipboard

Copied

To clarify - I actually need BOTH formats.

1) The HTML (SCORM) format is the one I am posting to our LMS. The buttons work, but the resolution is too big. I have to manually adjust my browser zoom settings to 50% in order to see the entire video.

2) The MP4 (static) format is used for sharing the video externally (which we occasionally need to do). When I publish in this format, I temporarily remove the action buttons from the slides, because I know they will not work. The resolution looks good in this format, but the final slide is not rendering. It's missing from the final MP4 output. I can still hear the audio, but I can't see the final slide image.

So, different issues depending on which output I choose, but both formats have issues. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2023 Apr 12, 2023

Copy link to clipboard

Copied

Did you read my recommendation/question to publish with Scalable HTML activated? I suspect the answer is no or the course would adapt to the available space in the browser.

When playing in a LMS the chosen width/height ratio is bit weird. If you want to fill the browser window and the screen is set to that resolution the UI of the LMS takes up space and the tutorial will never fit because there is space taken up both horizontally and vertically by the LMS itself. 

What is wrong with the last slide in the MP4 can be due to a lot of causes, without having more details about what exactly is in that last slide and/or maybe even which actions are used on that slide, it is difficult to answer. What exactly is on that slide?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2023 Apr 12, 2023

Copy link to clipboard

Copied

Thanks so much. Yes, I did previously try enabling the 'Scalable HTML' option, but that setting did not fix the issue for me. However, GOOD NEWS!!! I finally resolved BOTH issues with one setting change.

I just republished BOTH versions and they are now BOTH displaying correctly. The only change I made was that BEFORE publishing the video, I changed the Project "View" (i.e., the zoom setting in the *.cptx file) from 50% to 66%. I then republished the video while viewing the project at 66% zoom. Not sure why that matters, but that's the only setting I changed, and doing that resolved the issues in both published formats.

1) Regarding the HTML version - It's now playing correctly in our LMS. When I launch the video, I can see the entire image in my browser window.

2) Regarding the MP4 version - The final slide is now visible in the MP4 output.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

That is really very weird. The view setting in Captivate just acts during developing, I mostly use CTRL-0 (Best fit) except when focus is on details for design reasons. Sorry, don't be insulted but that cannot be the reason for the problems you had, and as Moderator I need to take out that your marking as correct answer. We don't want to confuse readers of this thread looking for a real answer.

I really wished to know what happened when you first published, it may have been a once-in-a-time bug. 

Happy that it has been solved by republishing, my bad that I didn't even suggest because I am doing that automatically when I have an unexpected publish result. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

I do appreciate your skepticism. It doesn't make sense to me either. But, to be fair, I DID republish this project MANY times (using various settings), and nothing worked, UNTIL I changed the zoom setting in the project file. I got the idea by opening the original project and comparing all the settings to the new project. But, the only difference I could see was that project Zoom setting, so I made that ONE change (AND ONLY THAT CHANGE), and then when I republished the new project, it finally worked.  

While I agree this may not be the official "Correct Solution" you want to share with others - it does seem to be the solution that worked for me.

 

Also, FWIW, the "Best Fit" zoom option  has never worked well for me. When I choose "Best Fit," the slide fills the center pane, so that I cannot see any of the scrap area. I took a certification class last year, and when the instructor demoed the "Best Fit" option, it looked very different that what I was seeing on my machine. I had to manually adjust the zoom to 66% to make mine look the same as the instructor's interface.

 

Not sure if this matters, but I'm using a laptop which is connected to two monitors via a docking station, and I know that can affect the display. My desktop "Display Resolution" setting on my main monitor is set to 1920 x 1080, but the "Scale and layout" setting is set to 125% (which can also impact the display in some applications).

 

As a test, I reopened the project today, and adjusted the project zoom back to 50%, then republished the project in both formats (HTML/zip and MP4) - both videos played correctly, so I was not able to reproduce the error. 

 

I did all of my initial publishing (failed attempts) in a single day. My final test (the one that worked) was completed the next morning, after exiting Captivate and rebooting my machine. So maybe closing Captivate and/or or rebooting also had an impact on the published outcome. Who knows? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

Something seems to be wrong with your system. Is HD the recommended resolution for your monitor? Normally it shouldn't need 125% as display resolution but 100% should be recommended. Maybe it is a small monitor and you increased the display resolution for that reason. So far I have never seen such a problem with Best fit. I often change between resolutions. My laptop's recommended one is 3840x2160 and at 225% but for Video Demo and Software simulation I set it back to HD at 100%. In any case Best fit works fine. Do you use a graphics card?  I never use a dual monitor setup. My Surface Pro has a smaller screen and other settings, but never a problem neither.

I am not only skeptical, I am sure that changing the View percentage cannot have any impact on the publish result. That it seemed to work is due to other factors, just a coincidence. It may be due to the restart and reboot. A tip: clean the Preferences and clear the Cache regularly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

Yes, "1920 x 1080 (Recommended)" is what I see under "Display resolution" settings for my monitors. When the Scaling is set to 100%, the image is crystal clear, but all the text and icons are super tiny. I purposely like to set the Scaling to 125%, because it makes the text and icons bigger (with barely discernable degrade in clarity), which is much easier on my eyes. I don't get as tired during the day.

I'm not sure about a graphics card. The laptop was issued to me by my firm, but I don't think they would have added anything special, since we don't do any graphics-heavy work.

I use two monitors, because I'm a trainer, and when I host virtual trainings, I use one screen to present (e.g., share a presentation or demo software), and the second screen to view my training outline and meeting tools (e.g., chat window, participant list, participant video image, etc.). 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

Thanks for the tip on cleaning the Preferences and clearing the Cache regularly. I did clear my Cache at some point while working on this project. I'm not sure how to "clean the Preferences" - if you could elaborate on that.

Also, I didn't mean to imply anything negative by using the word "skeptical." I DO get what you are saying - the fact that my published videos suddenly worked properly after changing that Zoom setting is just a coincidence.

 

Next time I have similar issues, I'll try rebooting, and see if that works.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

I didn't see this as 'negative' but to me there is a difference between skeptical (which I am often) and being sure. That is what I tried to explain.

To clean the preferences you find the subfolder 'utils' under the installation folder and run the CleanPreferences... file appropriate for your OS, while Captivate is closed. More information in my blog post:

https://blog.lilybiri.com/tips-for-troubleshooting

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

LATEST

Oh, okay. Thanks for the extra info in your blog post. Now that you explained it, yes, I DID actually do both of these things a couple of days ago, while I was troubleshooting the issues I posted above:

1) I cleared cache (with all projects closed)

2) I cleaned preferences - Found the utils folder and clicked "CleanPreferencesWin.bat" (the one for Windows)

These 2 steps did not resolve my issues, but maybe it was a combination of all three -- clearing cache, cleaning preferences, and rebooting my machine -- that did the trick.

Thanks for all your feedback and suggestions!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Help resources