• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Slides Continue on Failure - How to fix?

Community Beginner ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Newbie to Captivate here. I'm using quiz questions. I want the user to have to try again until they get the correct answer, but when I test it, the slide always advances to the next question after one failure. I'm using customized feedback, and my questions were imported via CSV.

 

SLIDE:

chantes61660841_0-1649391946097.png

 

QUIZ PANEL:

chantes61660841_1-1649391987447.png

 QUIZ Preferences:

chantes61660841_2-1649392034859.png

What do I have wrong? Thanks for any help anyone can provide!

 

Views

128

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

P.S. I've tried both "infinite attempts" and setting a number of attempts such as 4 (e.g, a more than adequate number). Same thing happens.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

Not sure but there is some contradiction between the Quiz Properties for this slide and what I see on the slide. You do have 3 feedback messages on the slide (cannot read the Failure message nor the Retry message because of lack of contrast between text and background), but in  Quiz Properties you didn't check the Retry message and set the Failure message to None. Why? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

Thank you for your help, Lilybiri! 

 

My three feedback messages are individual feedback messages for each response and the standard "You must answer the question before continuing". The reason that I unckecked Retry and set it to no failure messages was because I wanted it to display the individualized messages specific to the question instead of the standard messages included on the Master slide. I just reinabled them both, and it doesn't seem to change anything.

 

In response to another question, you mentioned that removing or changing things on the Master slide could cause problems. I was experimenting with everything, so it's quite possible I did something wrong on the Master. Is there a way to reset the Master slide for just that one type of question?

 

Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

Hmm... Actually, I don't think my changes to the Master are the problem. I just opened a brand new project and imported the same questions into it, and I'm having the same issue. It continues to the next slide after each failure.

 

chantes61660841_0-1649442921920.png

 

chantes61660841_1-1649442958248.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

That is very weird. If you would look at my blog, you'd see that I have lot of posts about quizzing and quiz tweaking. 

Since it also happens with a new project, it is worthwhile to Clean the Preferences, which would reset an eventually corrupted application. 

Which theme do you use? The last screenshot seems to show that you used the default theme Blue Veracity. It could be corrupted as well. You can restore that theme, by replacing its present version in Public Documents\Adobe\eLearning Assets\Layouts\11_5 (check the date) with the original theme which you can find in the Library\Layouts under the installation folder of Captivate.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

Okay, I'll try that and look for your blog.

 

I've narrowed it down. It's only a problem on slides imported with customized feedback for each answer choice, which all of my questions had. The same problem occurs with the sample csv file included with Captivate. In that file, only the first question has customized feedback, and that slide progresses on failure with attempts set to infinite. All of the other questions (with no customized feedback) work as expected (not progressing until the correct response is chosen).

 

I wonder if anyone else would be willing to try importing the sample CSV into Captivate 2019, and tell me if they can replicate the issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

Never mind, I figured it out! When the questions are imported with the unique feedback, the advanced answer option is automatically set to Action: Continue. It has to be changed to No Action for every single incorrect answer with unique feedback.

 

chantes61660841_0-1649451486674.png

 

 

If anyone knows a way to change that default, or a way to change it in bulk (to avoid changing it manually for every single wrong answer), I'd be grateful! But otherwise, problem solved. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

You didn't customize the normal feedback but you used the Advanced Answer functionality! That is the first time I understand what you did... Terminology is a problem too often in this forum.  If I had understood this from the start, it would have been solved a while ago., you posted that screenshot too late. 

Advanced answer functionality is only available for MCQ with one correct answer. There is no default setup for that specific type. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

I don't understand the tone of your last reply at all.  But as I said multiple times, I was very grateful for your help. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

LATEST

I just regretted that I was not able to give you the correct help immediately because I ignored that you used Advanced Answer functionality. What is wrong about that?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines