• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

swf compilation failed

Community Beginner ,
Nov 04, 2015 Nov 04, 2015

Copy link to clipboard

Copied

Hello and thank you .

How to fix this "Swf compilation failed. Note: Please verify any of the actionscript keywords is used as user variable name." in captivate 8. PC.

Views

6.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Nov 18, 2015 Nov 18, 2015

Hello and thank you all for your interest in helping. I appreciate it.
I was able to fix this with the help of Sankaram. Many thanks.

This is what worked for me:
-- Close captivate and delete the preferences and re-launch

Deleting Preferences

  1. Go to the Utils folder in captivate installation folder C:\Program Files\Adobe Captivate 8 x64\Utils\ 
    2. Then  Double click “CleanPreferencesWin”
    3. Re-launch
    4. Create a blank project and press F12.

I hope this works for you too.

Votes

Translate

Translate
Contributor ,
Nov 04, 2015 Nov 04, 2015

Copy link to clipboard

Copied

I had this issue yesterday, and to be honest, when I restarted my computer, the error message didn't come back, and it didn't come back all day today. I know this isn't a real answer, but I thought I'd let ya know!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2015 Nov 04, 2015

Copy link to clipboard

Copied

This can be caused by several things:

  • Some object on one of the slides that is corrupted.
  • You have inadvertently used a reserved ActionScript keyword as the name of an object, user variable, or advanced action.

If none of the above turns out to be causing it, you could always try:

  • Clearing out your browser cache.
  • Resetting your Preferences folder

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 04, 2015 Nov 04, 2015

Copy link to clipboard

Copied

Hi,

Check this link if you still face the issue

SWF compilation failed error

Thanks,

Rahinie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2015 Nov 04, 2015

Copy link to clipboard

Copied

Rahinie,

That link is very useful for troubleshooting this issue.  But most people wouldn't have a clue which specific words are AS3 methods or variables.If Adobe's documentation does have these listed somewhere, I suggest that the page you linked should also have a link to that other page listing the keywords so that Captivate authors can check their object names against it.  Otherwise they have no way to debug this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Nov 05, 2015 Nov 05, 2015

Copy link to clipboard

Copied

It also specifies Captivate 6, are there different solutions for later versions?

Products Affected

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 05, 2015 Nov 05, 2015

Copy link to clipboard

Copied

Trust me, this issue affects all versions of Captivate.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2015 Nov 05, 2015

Copy link to clipboard

Copied

Thank you all for trying to help.

Captiviate had been working for me great for at least 2 years until this, 2 days ago.

I did the Use32BitJVMForPublish = 1 thing and it seems to work. however there is a file, a quiz, that keeps bothering.

Has anyone contacted adobe ever?

As they say in Spain... grassy-ass!  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2015 Nov 17, 2015

Copy link to clipboard

Copied

To give you an example for a potential cause for this error, we ran into this issue today and found the cause for our particular project:

It was caused by a web page link applied to text that contained straight double quotes – instead of curly/comma like double quotes.

The text phrase that was linked to a web page read:

Getting "Buy In" from your project team

And the whole phrase was linked to a Youtube video.

Once we changed the straight double quotes (that were copied from a Word document) to curly double quotes, the compilation error disappeared.

Please note: Using the straight double quotes in just text (with no web link associated) did NOT cause any compilation issue for us.

The issue only occurred when the text with the straight double quotes was associated with a web link.

Our issue would basically refer to what is called Solution 2: Remove invalid characters in text fields of the project in the above mentioned link SWF compilation failed error.

I guess meaning that straight double quotes become invalid characters if they are used with text that is linked to a web page or similar.

TIP: How to track down the slide that causes the issue

If the cause of the issue is on only one slide, it worked for us to track down this issue by using the Preview > Next 5 slides.

The Preview will cause the compilation error if the slide with the cause is in these 5 slides.

Important: The compilation error will not show in the Preview if the slide is hidden. This will also help you narrow down and identify the trouble-maker.

Hope this helps.

Cheers from Brisbane,

Tash

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2015 Nov 18, 2015

Copy link to clipboard

Copied

Hello and thank you all for your interest in helping. I appreciate it.
I was able to fix this with the help of Sankaram. Many thanks.

This is what worked for me:
-- Close captivate and delete the preferences and re-launch

Deleting Preferences

  1. Go to the Utils folder in captivate installation folder C:\Program Files\Adobe Captivate 8 x64\Utils\ 
    2. Then  Double click “CleanPreferencesWin”
    3. Re-launch
    4. Create a blank project and press F12.

I hope this works for you too.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Well, this problem is still around. I have version 11.5.1. I restarted my computer, which did not work but would have been nice. I deleted the preferences, lost all my preferences and the problem still exists. I also searched for quotes of any kind in any text box. I tried previewing 5 slides at a time but the error comes up from slide 1 all the way through.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Are you actually still publishing to SWF?  Try HTML5 to see if that works better.  (SWF is not recommended anymore.)

 

Take a copy of your project and try hiding groups of slides before test republishing to see if you can isolate any particular slides that stop the publishing from successfully completing.

 

If your project has become corrupted and that is what is causing this issue, try copying alls slides over to a new project shell of the same size.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Are you talking about a non-responsive (blank) project? In that case you can only use the Preview method 'Preview HTML in Browser' (F11). The other preview methods use a temporary SWF which cannot be played if you don't have the Flash Player plugin installed. That may also lead to that error.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Hello,

I am getting the swf compilation failed when I attempt to preview a slide or entire project unless it is in HTML I've already reset Captivate to factory settings, which didn't help. This even happens on a new blank project. 

Can you help with this? 

Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

If this is a non-responsive project, the only valid Preview method is F11, Preview HTML in Browser. All the other Preview methods use a temporary SWF outpu and you probably have no longer the Flash Player installed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Thank you for the quick response. It seems I'm the only one on my work team



Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Sorry, I have deleted too much of your reply (but did read it), because you added your coordinates (automatic signature) in a public forum, you don't want spammers I believe.

With Preview HTML in Browser you will see the complete project in your default browser. 

For a responsive project all Preview methods are functional, will open in localhost but this bug (which I logged several times) only exists for non-responsive projects. 

My workaround to get quicker to a specific slide or slides is to activate temporarily the TOC with full navigation possibilities. You may insert it as overlay, but it will allow you to navigate to those slides you want to see.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

LATEST

Thank you so much!
*Suzanne 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Didn't work. This is time I don't have today to troubleshoot this buggy software. ughhh. Shouldn't have to do this. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

These kinds of issues are not unusual and, having beein on this forum answering questions for many years I can tell you that the issue isn't necessarily due to a bug in the software.  It's more often something the user has to address.

 

If you want more help, you'll need to give us more information.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Rod, there's no information to give. This kind of response is why I prefer Articulate products. Adobe Captivate is old and glitchy.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Well if you don't want to provide us with any way to help you, then I don't see any way we can blame Captivate for this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

Pray tell what the solution is guru. I already tried everything in this forum post.

 captivate error.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

There can be several reasons for this issue, but the first thing everyone will tell you is that still publishing for SWF is not recommended because all support for that format will be ending in just over a month.  December 31st is officially when Flash SWF dies for good and your end users will likely have no success trying to play this content in their browsers.

 

However, assuming this fact is of no interest to you, which of the following suggested approaches have you already tried without success?

  1. Reset your Preferences and republish.
  2. Take a copy of your project and hide groups of slides before republishing to see if there is corruption in one or more slides or objects on those slides.
  3. With your copied project, make sure you have not used any reserved keywords as names of User Variables or Advanced Actions.  If you have, change the names of the Advanced Actions and replace the Variables with different ones that have appropriate prefixes.  (You cannot change the name of a User Variable after it is created.)
  4. Copy small groups of slides (e.g. 10-20 at a time) from the problem project into a new blank project shell and try republishing each time.
  5. If all previous attempts failed, reinstall Captivate (also resetting Preferences afterward.)

Work your way through that list and if NONE of them work, get back to me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

I got this message just trying to Preview a project, so not actually Publishing but presumably must use the same settings. Checked through all my slides and removed the ":" colon in 3 slides as wondered if that could be the issue, then it worked ok!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Help resources