• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Text to Speech & Closed Captioning Property Changes?

New Here ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

Hi,

Is there any way to change the text to speech properites? I need Captivate to read read "slash S" in stead of "per second" when i type "/S"? I also need the Closed Captions to display "/S".

 

I am also trying to find a way that captivate will read "20160" as "two - zero - one - zix - zero" instead of "twenty thousand one hundred sixty" I need the closed captions to display "20160" while it is reading what I want it to read. 

 

I have been googling but haven't figured out if it is posible to change how Captivate reads the text to speech.

 

I have tried different combinations, but the closed captioning and the text to speech always wants me to regenerate the audio/closed captions when I update one and not the other.

 

Any advice would be great! Thank you!

 

Views

56

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

This is not difficult to do.  But you need to create your TTS audio and not change it after that, otherwise the CC text gets wiped out.

 

Just write the Slide Notes the way you want Captivate to say it (e.g. two zero one six zero).   Generate the text from those slide notes. 

 

When you have the TTS sounding the way you want it, THEN change the slide note text to how you want it to look (e.g. 20160) and do your Closed Caption timing.

 

I have tested this at my end in a blank project and it works perfectly.  TTS first, THEN CC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

Thanks, There is no way to change it throughout the software, change the default on how Captivate reads?

 

I am going to have to do this over and over and over again. Then i'm going to have to somehow note it so if others come in behind me and make updates they don't wipe out the edits.

 

Also, I have tried doing it the way you suggested and it always ends up generating new audio when I go to update the closed captioning. It seems like Captivate is going out of its way to convert "/ S" to "per second" instead of just reading it as it is written. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

I am also confused because on it's own, captivate will read "/S' as "slash S", but when I put it iwth other things such as "BNF-7020-DD-01/S" Captivate will read "BNF-seventy twenty - DD - o one per second". I need it to say "slash S" all the time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

Nevermind. I figuredo out a solution for my problem that won't drasticly change how the closed captioning displays based on the text to speech and everything can be generated. Nothing is left in complete.. If I add a single space between the 1 and the / then Captivate will read it correctly. "BNF-7020-DD-01 /S" is how i type it and it works for some reason. It would still be nice if we could turn off whatever conversions captivate is doing when we are working on projects. I don't necessarilly need it to read per second. If I were to add a space after the slash and before the S, then Captivate goes back to reading "per second". This is overly complicated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

LATEST

Feel free to log an enhancement request with Adobe, but don't hold your breath.  Your situation is one that very few Captivate developers encounter.  No authoring tool does everything one wants.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines