• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

xapi course freezes when selecting quiz answer

New Here ,
Aug 18, 2022 Aug 18, 2022

Copy link to clipboard

Copied

Hello,

I have recently made the switch to XAPI, i have setup my LRS ect. and i've used the comformance suite to test this and all is good.

 

My quiz does not use the standard setup in captivate, i use advanced actions to set the buttons to green when correct and upload variables to determine quiz outcomes, when someone presses a button in my quiz theres about 4-5 advanced actions that are run.

 

Now my issue is when someone clicks this quiz in my LMS it's sending about 60 requests per click on each button to my LRS which results in a delay of about 4-5 seconds between each slide, i've tried to untick "send data on every slide" this does nothing. 

 

Wondering if anyone has come across this issue before? I assume this is happening because each time it updates one of these advanced action variables it's setting a new state? which makes tincan send about 5-6 statements to the LRS to update the record but because i'm setting about 6 actions its piling up the requests.

Views

13

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation