Highlighted

2019 function changes? publish warning on external file, and auto-play

Explorer ,
Jul 22, 2019

Copy link to clipboard

Copied

There are two changes I've noticed in my first few days of using version 2019, and I want to make sure they're actual changes and not just settings I'm missing.

The first is that I used to get a warning during publishing if I included any use of "Open URL or File" in the project to open an external file. When I published something I know should be giving me that warning, I'm not getting it in 2019. I have found that to be extremely helpful in the past. Has that warning been removed? 

The other thing is that I now can't get a project to play in browser starting with my title screen. I have to load a "play" button screen first. In v2017, that only happens when I have auto-play turned off.  I know there's some official mention of it being a browser problem, but in my experience I am still only seeing the issue when I publish from 2019, so it seems like the issue is with Captivate, not the browser's ability to recognize that command. Is anyone else experiencing that?

Thanks
Jeff

Views

73

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

2019 function changes? publish warning on external file, and auto-play

Explorer ,
Jul 22, 2019

Copy link to clipboard

Copied

There are two changes I've noticed in my first few days of using version 2019, and I want to make sure they're actual changes and not just settings I'm missing.

The first is that I used to get a warning during publishing if I included any use of "Open URL or File" in the project to open an external file. When I published something I know should be giving me that warning, I'm not getting it in 2019. I have found that to be extremely helpful in the past. Has that warning been removed? 

The other thing is that I now can't get a project to play in browser starting with my title screen. I have to load a "play" button screen first. In v2017, that only happens when I have auto-play turned off.  I know there's some official mention of it being a browser problem, but in my experience I am still only seeing the issue when I publish from 2019, so it seems like the issue is with Captivate, not the browser's ability to recognize that command. Is anyone else experiencing that?

Thanks
Jeff

Views

74

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 22, 2019 0
Adobe Community Professional ,
Jul 22, 2019

Copy link to clipboard

Copied

You haven't set something incorrectly.

Previously when you would use the Open URL or File action you were required to manually copy the file into your published folder or ZIP file. As long as Captivate can find the file in question it will copy the file over to your published folder or zip for you. No need to intervene unless Captivate cannot find the file (perhaps if the file was deleted or moved).

Due to complaints from users all over the world, browser makers have turned off the ability to autoplay multimedia automatically. This was in response to annoying advertising videos taking the focus of your regular browsing to yak at you without your permission. You can still autoplay SWF content but for publishing HTML5, AutoPlay will no longer work. Here is a tutorial to make the giant play-button on your first slide a little more palatable.

Adobe Captivate - Get Rid of Blank Project Startup - YouTube

Paul Wilson, CTDP | https://captivateteacher.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 22, 2019 1
Explorer ,
Jul 23, 2019

Copy link to clipboard

Copied

Thanks, Paul! 

Good to know I'm not just missing the settings.

That's awesome that it now captures the files when it can, but I will say that I wish the warning were still there in those instances where it can't find the file (as in my case, due to folder moves [server transfers, too]). It's a little scary to publish without that backup check. I'm working with someone else's project, and while I do my best to check every interaction, it's always possible I'll miss something. In fact, the more I think about it, the more nervous I am.

That's a great video! Thanks. I'll definitely be using that technique. I have to go back and double-check, but I'm 99% sure that when I tested this in v2017 a few weeks ago it still honored the auto-play on/off in HTML5 in both IE and Chrome on my machine. I accept the assertions that the browser behavior changed, but it's not jiving with my experience. I also realize I'm beating a dead horse and trying to lead it to water, but this kind of inconsistency between experience and explanation is the stuff that gets my OCD going.

Anyway... thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2019 0