Highlighted

API Error with Captivate 2019

New Here ,
Sep 05, 2018

Copy link to clipboard

Copied

Hi All -

I am trying to publish a Captivate course that was built in Captivate 2017.  We needed to make some updates, and now need to publish it in Captivate 2019 (I just downloaded a free trial). I did not change any publish settings from what was previously used.  The course needs to be published to an LMS, and we typically use SCORM 1.2.  The course does not include a quiz, which if I recall has posed an issue in the past.  It is set to track completion based on slides seen rather than a score.  Any thoughts on what I'm missing?  The courses that we published last year with the same settings in Captivate 2017 worked perfectly.  Now when I publish I get an API error and I'm not sure what else to check. I'm also not having any luck finding tutorials specific to 2019 yet, only 2017.  Any help would be appreciated!

Views

281

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

API Error with Captivate 2019

New Here ,
Sep 05, 2018

Copy link to clipboard

Copied

Hi All -

I am trying to publish a Captivate course that was built in Captivate 2017.  We needed to make some updates, and now need to publish it in Captivate 2019 (I just downloaded a free trial). I did not change any publish settings from what was previously used.  The course needs to be published to an LMS, and we typically use SCORM 1.2.  The course does not include a quiz, which if I recall has posed an issue in the past.  It is set to track completion based on slides seen rather than a score.  Any thoughts on what I'm missing?  The courses that we published last year with the same settings in Captivate 2017 worked perfectly.  Now when I publish I get an API error and I'm not sure what else to check. I'm also not having any luck finding tutorials specific to 2019 yet, only 2017.  Any help would be appreciated!

Views

282

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 05, 2018

Copy link to clipboard

Copied

What is the API error?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 05, 2018

Copy link to clipboard

Copied

Thanks for the reply!  

When I upload the zipped file through our LMS (successfactors), I get the error in the bottom screenshot.  Usually this means something is missing, but I'm not 100% sure what it means in this case.

When I upload directly to our server and link it to our LMS, I get the error in the second screenshot.  When I press ok, the slides seem to work and I can get through the course, though it does not mark complete when I reach the end of the course (as the error message seems to indicate will be the case.)

I've tried unchecking the Enable Reporting for this project box, just for kicks, but receive the same messages.

Any insight you can share would be appreciated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 05, 2018

Copy link to clipboard

Copied

Well it will give you that error if you re not running in an LMS, but you can still play the content.

Was this course loaded into the LMS exactly the same way? Was SCORM turned on in the LMS?

It's saying that it can't find the API to communicate with the LMS database.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 05, 2018

Copy link to clipboard

Copied

Unfortunately yes and yes.  I went back to the original 2017 file before I made any changes and tried to republish it, and it's giving me the same messages.

90% of our courses are published to SCORM and are working correctly, and I double checked the object settings on this particular piece of content in the LMS and it's SCORM 1.2.

I'm sure I'm missing something obvious, I just don't know what.

Thank you for your input, though!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 05, 2018

Copy link to clipboard

Copied

Upload the same SCORM zip file to SCORM Cloud and see if you get the same error.

As Dave at TLC mentioned, this error message usually indicates the SCORM is unable to find a SCORM API to connect to, and the reason for that is normally that the developer is trying to run the SCORM locally without an actual LMS for it to talk to.  But in your case the screenshot shows that you ARE running this SCORM in an HTTPS web environment.  So if you can verify that SCORM Cloud doesn't show this API error then it means the problem is with your LMS not the SCORM itself.  It's possible something has changed on the LMS to cause this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 04, 2018

Copy link to clipboard

Copied

I am a SuccessFactors LMS System Administrator. Any chance you host your SCORM courses on an internal server and upgraded the cross-domain proxlet on the SCORM server recently? We've had the same issues (Check the SF Community for my post about issues with the proxlet). Due to a VERY delayed response from SF support, we moved all of our SCORM courses to iContent and the issues resolved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Captivate User Guide
New Group