Highlighted

Audio embedded in smartshape doesn't play when shape is revealed for the first time

New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

I've built a captivate slide where my user clicks a smartshape button to reveal another smartshape that contains text and audio. They can then click the next smartshape to reveal the next bit of text, and so on. It's a bit like a timeline interaction, except they're reviewing step 1, 2, 3, 4, & 5.

 

When they click the Step 1 smartshape, the text smartshape shows but audio doesn't play. It plays for the others. And the weird thing is that if they go back and click on Step 1 at any time after the initial click, the audio will play with the text box (I have the advanced action set so that, once they've selected all the steps in order, they can click around however they want & text smartshapes are hidden and shown as they go).

 

This is happening on another slide too, but on that one I don't force the user to click the shapes in any particular order. No matter what shape is revealed first, the audio doesn't play. But it will play on subsequent clicks. Any ideas?

 

I'm using Captivate 2019, version 11.5.1 & I am using the Rhapsody template.

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Visited state is an InBuilt state, was added some versions ago.

The functionality of Play Audio has not changed since that command was added, but that was not 10 years ago neither.

 

Have written too many blogs since version 11 and 11.5 appeared.

Can you mark at least one answer as correct to close the htread?

TOPICS
Advanced actions, Audio and video

Views

320

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Audio embedded in smartshape doesn't play when shape is revealed for the first time

New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

I've built a captivate slide where my user clicks a smartshape button to reveal another smartshape that contains text and audio. They can then click the next smartshape to reveal the next bit of text, and so on. It's a bit like a timeline interaction, except they're reviewing step 1, 2, 3, 4, & 5.

 

When they click the Step 1 smartshape, the text smartshape shows but audio doesn't play. It plays for the others. And the weird thing is that if they go back and click on Step 1 at any time after the initial click, the audio will play with the text box (I have the advanced action set so that, once they've selected all the steps in order, they can click around however they want & text smartshapes are hidden and shown as they go).

 

This is happening on another slide too, but on that one I don't force the user to click the shapes in any particular order. No matter what shape is revealed first, the audio doesn't play. But it will play on subsequent clicks. Any ideas?

 

I'm using Captivate 2019, version 11.5.1 & I am using the Rhapsody template.

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Visited state is an InBuilt state, was added some versions ago.

The functionality of Play Audio has not changed since that command was added, but that was not 10 years ago neither.

 

Have written too many blogs since version 11 and 11.5 appeared.

Can you mark at least one answer as correct to close the htread?

TOPICS
Advanced actions, Audio and video

Views

321

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 29, 2020 0
Most Valuable Participant ,
Apr 29, 2020

Copy link to clipboard

Copied

Rhapsody is not a template, it is a project. Its Theme  has some flaws, several slides have a Pause command on Exit which could lead to problems. Did you check that on the slide(s) you used? What is the Exit action on the slide before the slide you are talking about?

Woudl also like to see a screenshot. Audio files need to be loaded On Enter for each slide. You talk about a lot of audio clips, have no idea how big those files are. You attached them as Object audio, and I suppose that the first shape button appears at the first frame. That could also lead to a problem like you describe: audio has not loaded yet the first time. For slide audio the solution is easy, leave a small gap before the audio timeline. For object audio that is not so easy, because it is supposed to start playig when the object appears. Or do you use Play audio? In that case you could use a Delay command with a very short delay before playing that first audio, to make sure that it has been loaded completely.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2020 0
New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

Thank you for your prompt response!

The screenshot of the slide is here:

Capture.PNG

I was a bit worried that it might be related to Rhapsody since this isn't an issue I've had before - I usually start with a blank template. There are no Exit commands - I've always found them to be problematic so I rely on Enter only.

The advanced actions seem simple enough (to me):

Capture.PNG

The conditions are probably unnecessary, but I like to make sure the smartshapes change color after they've been clicked. I've had them revert to normal in the past but that could've just been an old version of Captivate:

Capture.PNG

The recording size is 1112kb - it's only 131kb in my audio file (not in captivate) so that's something to figure out. I'm trying to keep the file sizes down throughout this project.

And as far as Play audio - I've always struggled with that command so I've gotten used to adding audio to shapes and text boxes. I'll experiment with that command a bit too.

Thank you for your suggestions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2020 0
Most Valuable Participant ,
Apr 30, 2020

Copy link to clipboard

Copied

Missing the Timeline, forgot to specify I needed that screenshot.

OK, I see a 'too' complicated advanced action. It would be easier if you posted the Preview window which you may ignore but allows to see multiple decisions at once. It is the first button of the top right control bar (looks like an arrow). More info about this advanced actions dialog box in:

http://blog.lilybiri.com/advanced-actions-dialog-box-in-captivate-2017

 

That can also slow down, or there may be a logical bug.  Which event is used to trigger this action? I really would like to see more of that action, which can be done with that Preview window.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 0
New Here ,
Apr 30, 2020

Copy link to clipboard

Copied

Oooh. That is COOL! (I read your blog but must have missed that one).

Capture.PNG

I went back to look at this, and I'm not sure why I added the conditions - the smartshapes will stay in Visited while they're on the slide so I've gotten rid of them. And Play Audio seems to have solved the audio issue for me - I guess Adobe has upgraded a few things in the last 10 years. 

Capture.PNG

I really can't thank you enough for you help on this. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 0
Most Valuable Participant ,
Apr 30, 2020

Copy link to clipboard

Copied

Visited state is an InBuilt state, was added some versions ago.

The functionality of Play Audio has not changed since that command was added, but that was not 10 years ago neither.

 

Have written too many blogs since version 11 and 11.5 appeared.

Can you mark at least one answer as correct to close the htread?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 1
New Here ,
Apr 30, 2020

Copy link to clipboard

Copied

I'm not sure why I did the state changes - I used to do responsive projects and would use smartshape buttons to go back and forth between slides instead of dealing with states so it may just be a bad habit.

Thanks again for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 0
Lilybiri LATEST
Most Valuable Participant ,
Apr 30, 2020

Copy link to clipboard

Copied

Certainly for responsive projects, sttates are a blessing.  Moving between slides is IMO the 'old' mehtod which  was used in older versions. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 0