Audio in hotspots plays automatically in 360 slide

New Here ,
Oct 29, 2020

Copy link to clipboard

Copied

Hi All,

New user to Captivate here and mainly interested in working with 360 images and VR.

I am trying to create a 360 slide with a number of hotspots that play audio when clicked. I have been able to do this fine (actually very easily so enjoying captivate so far) however when the 360 slide first appears any audio ascoiated with hotspots plays automatically all at the same time. The hotspots subsequently work as expected and play the appropraiate audio when clicked. 

So if I have three hotspots that trigger audio I get all 3 audio clips playing at once when the slide first appears. I cannot for the life of me solve this. I have tried a number of new projects and also one of the template projects included and get the same behaviour.

 

Using Windows 10 and updated to the most recent version of Captivate today.11.5.5.553

Thanks in advance

Stephen

TOPICS
Audio and video, Getting started, Virtual reality

Views

59

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Oct 30, 2020

Copy link to clipboard

Copied

Can you please explain in detail the workflow to 'trigger the audio' which you have used?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Advocate ,
Oct 30, 2020

Copy link to clipboard

Copied

Hi Stephen

You have two methods to add audio to a hotspot in VR360. A) through the Action called Play Audio or B) in the Options segment of the Properties panel by using Add Audio .... As far as I remember, the method B) plays the audio as soon as the Hotspot appears while with method A) the audio plays first when the hotspot is clicked respectively gazed.

Did you use method B) ?

Klaus

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Oct 31, 2020

Copy link to clipboard

Copied

My question was the same as Klaus. Let me add some more clarification and post links to two blogs.

 

Hotspots are really interactive objects pausing the timeline.  If you don't scatter them on the timeline (see blog about Timeline for 360° slides) those interactive objects are all in the same frame, the first frame of the slide. If you use Options to add Object audio to such a hotspot, the rule is that object audio plays when the object appears. In this case, if the hotspots are all in the first frame, all audio will play at the same time.

 

If you use the command Play Audio from the (limited) command or actions list for hotspots you are using the option 'Play Audio' which exists also in normal slides. In that situation the audio clip will be launched when the button is pressed (Success event). In a VR slide that is the same. An advantage of this command is: if you launch another clip with the same command (by pressing another hotspot trigger) and the first clip is not yet ended, the first clip will be stopped immediately in favor of the new clip.

More about audio and timeline:

https://elearning.adobe.com/2018/06/pausing-timeline-audio-clips/

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 01, 2020

Copy link to clipboard

Copied

Thanks for the replies.

This is my workflow.

I add a hotspot.

With the hotspot selected on the properties menu under "On click" I select

 "play audio" and leave all other options untouched.

 

When I use the same workflow for video hotspots they beahave as I would expect, that is, the hotspots all appear and only play the video when I click on them. Audio Hoptspots do the same but they also play when the slide first appears.

 

I am not sure why I would have to move the hotspots to different frames if they are all set to "on click" or perhaps I am missing something. In any case whilst experimenting I did move the hotspots to differnt frames on the timeline and when the slide appears the audio hotspots do not, the video hotspots appear (because I left them in the first frame)

Thanks

Stephen

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
stephen_liseo AUTHOR LATEST
New Here ,
Nov 01, 2020

Copy link to clipboard

Copied

OK I seem to have figured this one out.

I was recoding the audio using the record function in Captivate. If you have a hotspot selecteded when you record audio then that recording is attached to the hotspot in the options for the hotspot. I was then adding the audio to the "on click" function.

All good now

thanks for the replies

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more