Highlighted

Blank Project with VR Slide Publishes and Hotspots Don't Work in Rescalable HTML5

Explorer ,
Jun 05, 2019

Copy link to clipboard

Copied

Hi All:

I have been waiting for Adobe support to get back to me, but a client is waiting....

ABOUT MY PROJECT - I created a blank Captivate file. I added to that file a VR slide. Within that slide I have multiple Hotspots, most only to show Display Text. Two to navigate to a different (not VR) slide.

PROBLEM - No hotspot works upon publish.

SYMPTOMS :

  1. Previewing HTML5 in Browser results in functioning Hotspots as expected / intended. It is only upon publishing and reviewing in the same browser as the preview worked in... that the hotspots no longer function.
  2. This brokenness is apparent in:
    1. Windows 10 Captivate (64 bit)
      1. Chrome
      2. IE
      3. Firefox
      4. Edge
    2. Windows 8 Captivate (32 Bit)
      1. Chrome
      2. IE
    3. MacOS Mojave (64 Bit)
      1. Safari
      2. Chrome
      3. Firefox
  3. The Adobe support person accessed my Captivate file and recreated the same issue on her machine
  4. The Adobe support person created a brand new file and created a single slide with a single hotspot and recreated the issue.
    1. I have done the same with multiple computers
  5. And finally, frustratingly, the issue persists regardless of the version of Captivate 2019 - I have a different computer with the older (version 1 2019)) of Captivate and the issue is there too.

I am finding it difficult to believe I am the only stupid SOB who has attempted to do this before, but, be that as it may - I am really hoping the smart people here can help a guy out.

You may view a video of the issue here (totally silent video) - Adobe Captivate Text Display Hotspot Is Broken on Vimeo

Hi, 

We have fixed this issue in captivate 2019 update 2.

Please update your captivate and let us know.

Regards,

Aditya

Captivate engineering

TOPICS
Advanced

Views

411

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Blank Project with VR Slide Publishes and Hotspots Don't Work in Rescalable HTML5

Explorer ,
Jun 05, 2019

Copy link to clipboard

Copied

Hi All:

I have been waiting for Adobe support to get back to me, but a client is waiting....

ABOUT MY PROJECT - I created a blank Captivate file. I added to that file a VR slide. Within that slide I have multiple Hotspots, most only to show Display Text. Two to navigate to a different (not VR) slide.

PROBLEM - No hotspot works upon publish.

SYMPTOMS :

  1. Previewing HTML5 in Browser results in functioning Hotspots as expected / intended. It is only upon publishing and reviewing in the same browser as the preview worked in... that the hotspots no longer function.
  2. This brokenness is apparent in:
    1. Windows 10 Captivate (64 bit)
      1. Chrome
      2. IE
      3. Firefox
      4. Edge
    2. Windows 8 Captivate (32 Bit)
      1. Chrome
      2. IE
    3. MacOS Mojave (64 Bit)
      1. Safari
      2. Chrome
      3. Firefox
  3. The Adobe support person accessed my Captivate file and recreated the same issue on her machine
  4. The Adobe support person created a brand new file and created a single slide with a single hotspot and recreated the issue.
    1. I have done the same with multiple computers
  5. And finally, frustratingly, the issue persists regardless of the version of Captivate 2019 - I have a different computer with the older (version 1 2019)) of Captivate and the issue is there too.

I am finding it difficult to believe I am the only stupid SOB who has attempted to do this before, but, be that as it may - I am really hoping the smart people here can help a guy out.

You may view a video of the issue here (totally silent video) - Adobe Captivate Text Display Hotspot Is Broken on Vimeo

Hi, 

We have fixed this issue in captivate 2019 update 2.

Please update your captivate and let us know.

Regards,

Aditya

Captivate engineering

TOPICS
Advanced

Views

412

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 05, 2019 1
Adobe Community Professional ,
Jun 05, 2019

Copy link to clipboard

Copied

Have you tried uploading the published output to a web server or LMS and viewing it from there?  Your issue might simply turn out to be some security restriction when being viewed locally.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2019 0
Explorer ,
Jun 05, 2019

Copy link to clipboard

Copied

I am willing towager if you do the same ting - Create a new blank project. Add a single 360 slide. Add a hotspot with Display Text... then PREVIEW in HTML5 Broswer - it will work.... but upon publish, it will not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2019 0
Most Valuable Participant ,
Jun 05, 2019

Copy link to clipboard

Copied

Here is a very simple example. There is no poster image nor play icon on the static screen, click in the center to start (like all HTML5 output Autoplay is disabled):

Training Room

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2019 1
Explorer ,
Jun 06, 2019

Copy link to clipboard

Copied

Interesting that your output works for me and my own does not... unless I turn OFF the HTML Scaling option. I will post the workaround to my issue shortly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 06, 2019 0
Explorer ,
Jun 05, 2019

Copy link to clipboard

Copied

Hi There - DAMN - I forgot to add that - YES, I did. I uploaded it to both web server as-well-as to SCORM Cloud.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2019 0
Explorer ,
Jun 06, 2019

Copy link to clipboard

Copied

SOLVED - Sort of.

Quick solution is - do not publish with Scalable HTML content checked.

After much frustrating revise / publish / gnash teeth / revise again....

Issue - When publishing with Scalable HTML content "checked", many folks are experiencing no result on clicking. the reason? Companies that make Browsers (in their collaborative and consumer-focused nature.. haha) use different "maths" to decide where 0,0 is... so, Adobe has not in the first version or this recent version of 2019, decided to account for all browsers, and instead relies on us to figure out that you cannot publish a blank project with a VR slide in it with SCALABLE HTML CONTENT CHECKED.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 06, 2019 1
Most Valuable Participant ,
Jun 06, 2019

Copy link to clipboard

Copied

I just edited the title of your thread. How could we kinow that you were publishing to Rescalable HTML5? Something I would never do with a VR project or a project having 360° slides, but that ismy logical mind of course.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 06, 2019 0
Explorer ,
Jun 19, 2019

Copy link to clipboard

Copied

Forgive my terseness but the Captain Hindsight approach in your reply isn't adding positive value to this conversation. At least not for me. It's come across to me as if you're attempting to shame me for not knowing what "the basics of logic". You can't.

Let me ask you a question - Why would you NOT publish an HTML5 360VR course designed for mobile devices in Scalable HMTL5?

I am not boasting here, just giving you a frame of reference as to where my (il)logic stems from.... [potentiallyBoastfulComment] As a past desktop app developer, a mobile app developer, and with web design / develop chops I do not advertise [/potentiallyBoastfulComment] ...  the only reason I would create content for mobile devices that was not scalable was if the content were responsive or not intended to fit on one screen (scrolling, as an example). So, please help me understand your logic. That's a sincere question. Because I can't grasp why you would not want to take full advantage of screen real estate and what logic leads to that decision.

I am not sure why you have the ability edit my title, but the fact you exercised that capability... AND did so without asking questions first is irregularly arrogant and unfortunately fits with how I am reading the arrogant tone of your reply. 


I know you didn't ask, but I'll share... Scalable was not on the title for the insanely obvious reason that I didn't know it was the issue... that was the entire question... what is causing this? Why in Gods name would I include every nuance to the title of my question? Should I have added all the browsers and OS information in the title too? What about ALL of my publish settings besides the Scalable content? Should I have added that to the title also or face being shamed by trolls for not being clear? Did you see my copy in the body? I was trying to be as thorough as feasible, but obviously no one wants to read a novel so I did not include every aspect about my project - and - as a Civil Engineer, you know full well why I couldn't post the file...


Even knowing that scalable is the root cause, I would not add it to the title... Actually it's not the root cause... unchecking scalable content is the workaround to shortcuts taken by Adobe.... the root cause is Adobe Captivate developers not accounting for 0,0 registration on all browsers.... THAT is the REAL issue. That's why the hotspots are not where you expect them to be)… As a past app developer, that's why I even bothered to uncheck the box at all. I then discovered Adobe didn't do what I was doing in 2011... accounting for how browsers assign objects 0,0 point.


Why wouldn't I add it to the title?

There are Google studies I base my YouTube video titles, as well as forum titles off of. The studies are around how people search the web for a variety of intents. in my case, it was eye-opening to discover how people search for answers to technical issues.

Essentially they're designed so the person who does not know how to word what they are needing an answer to can find it. You know, the people who don't know what they don't know yet... By adding scalable info into the title, you are effectively making sure that the people who don't know anything about that have a stronger likelihood of passing it buy as not relevant to their search. Look it up.

And in case you want to defend the bug's existence, don't. I spoke with Adobe Tech Support and developers who acknowledge it is a miss/bug and I believe have plans to fix it, if they haven't fixed it already.

Don't worry, I will leave the title here as is, as I suspect most people like me have discovered the Forums here to be less than helpful - but I will post a video with the workaround with a title that will make sense to those who are struggling to find the answer like I was.

And now you know, in spite of not asking the questions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2019 1
Adobe Employee ,
Jun 19, 2019

Copy link to clipboard

Copied

Hi, 

We have fixed this issue in captivate 2019 update 2.

Please update your captivate and let us know.

Regards,

Aditya

Captivate engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2019 1
Explorer ,
Jun 19, 2019

Copy link to clipboard

Copied

I love you! Thank you so much!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2019 0
Adobe Employee ,
Jun 19, 2019

Copy link to clipboard

Copied

But we recommend not to use blank project with scalable html5 content with 360 slide on mobile devices... Where zooming in 360 slide may not be an option and may have difficulty on clicking on hotspots.

Recommended would be to use responsive project .. where you can have all your blank project slides and make them behave as scalable html5 without use of fluid boxes and 360 slides work just perfect.

Regards,

Aditya

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2019 1
Explorer ,
Jun 19, 2019

Copy link to clipboard

Copied

Thanks. I think my first test was a 360 project but I couldn’t add any other slide type.  On a responsive project I don’t think the option was there for 360 slides but my memory could be faulty there.

In any case - as a media developer with a strong bend towards eLearning and ID work - my hat is off to you all for a major release with some long sought after features. Well done y’all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2019 0