Branching stopped working

Community Beginner ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

Hello,

I had successfully created some branching scenarios and everything was working fine. Then inevitably changes to the course were requested. I was making updates to the course. I published and tested in the LMS. I noticed that one of the branching scenarios wasn't working but in captivate it's linked to the right slides.

I have cleared the cache. I have duplicated the slide and deleted the old one in hopes that it would get rid of the error. I have re-linked the slide to the slide it needs to go to. Nothing works. It doesn't work  in any preview mode. And now more branching scenarios are failing upon subsequent previews. The changes I made (if it matters) were to add quiz questions and some survey questions.  All the linear navigation works up until my branching scenarios (for now at least)

Please help.

Views

266

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

I've also duplicated the project. Closed out of captivate completely and restarted my computer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

It looks like a problem linked with the Quiz settings. Do you allow Backwards navigation? Did you change the option for 'Required'? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Thanks for your reply. I'm attaching a screenshot of the quiz settings. I have a quiz section and then branching scenarios that are scored. My next thought is to make the quiz section knowledge checks. The branching worked fine until I added the quiz questions. I'm really stumped. I remember someone asking a similar and I think you said it had something to do with the quiz scope? But I'm just guessing at this point. As always, thanks for your help!

QuizSettings.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Can you set the Required field back to 'Optional', please? I suspect your choice is causing te problem. There are other ways to request Passing, which will not conlfict with Branch aware.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Hi Lilybiri,

That seem to work on the first pass and then I uploaded it to scorm cloud and I get a "not responding due to long running script" issue. It seems to stop on a certain slide. And I've copied and pasted the slide and deleted the old one which worked for me in the past but alas it's not working now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Hmmm.... bit weird. Hope your project is ot getting corrupted.  Branch aware which you selected means that many quizzing system variables are not fixed at the start of the project, but will be adapted on runtime based on the slides and questions visited by the learner. Do you have advanced actions and user variables in the project?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Yes Lilybiri,

I had set up the scenarios to track some data using SCORM2004 and also to make sure users had to take a certain path such as they couldn't advance unless they answered a set of specific questions. It all worked fine with no problems until I added the quiz questions and that's what seems to have done the damage. I tried just deleting the quiz questions but (I think) it will now not let me take out the quiz results slide even thought it wasn't there initially. I don't remember it being there.

I had saved a lot of my zip files and the issue is not there in an older version before I added the quiz. Unfortunately, I've been saving over the same captivate file. And didn't make a different version. Hard lesson to learn.

What would you advise?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

I don't know if you have a lot of advanced actions in the project? If there is a suspicion of corruption, copy/pasting slides to a new project which uses the same theme could be a solution. You should have to work by bunches of slides, to detect eventual corrupt slides/objects.

As for the Score slides: they will remain but can be hidden. Once a score slide has been created, you cannot delete it but the hidden slides are not in the published project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

LATEST

Thank you so much for all your help and your expertise! I will go that route and copy and paste the slides to find the corrupted object.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines