Highlighted

Button Actions Help needed

Community Beginner ,
Jun 24, 2020

Copy link to clipboard

Copied

I have created a CBT with a "download" button that works fine to open the file that I have directed it to. There is also a button on the same screen to "continue" the course after the download has completed. This works well in the Preview, but when I load to LMS I can either click the Download button, or i can click the Continue Button. If I click the download button and get the doc that is linked to it, the screen freezes and the Contine button does not work. If I only click the continue button, it will go to the next screen, but then I won't get the attached document. I am not an expert on Captivate. Is there a way to make this work?

TOPICS
Advanced actions

Views

80

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Button Actions Help needed

Community Beginner ,
Jun 24, 2020

Copy link to clipboard

Copied

I have created a CBT with a "download" button that works fine to open the file that I have directed it to. There is also a button on the same screen to "continue" the course after the download has completed. This works well in the Preview, but when I load to LMS I can either click the Download button, or i can click the Continue Button. If I click the download button and get the doc that is linked to it, the screen freezes and the Contine button does not work. If I only click the continue button, it will go to the next screen, but then I won't get the attached document. I am not an expert on Captivate. Is there a way to make this work?

TOPICS
Advanced actions

Views

81

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 24, 2020 0
Most Valuable Participant ,
Jun 24, 2020

Copy link to clipboard

Copied

Can you show a screenshot of the Timeline? Do both buttons have pausing points?

Which Preview did you try? If this is a non-responsive project only Preview HTM5 in Browser should be used.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0
Community Beginner ,
Jun 24, 2020

Copy link to clipboard

Copied

Itis non-responsive. I tried in the regular Preview, not the HTM5

 
 

Timeline.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0
Community Beginner ,
Jun 24, 2020

Copy link to clipboard

Copied

I just tried in in the HTML5 preview and it did work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0
Most Valuable Participant ,
Jun 24, 2020

Copy link to clipboard

Copied

That is already fine if it is working with that Preview. The buttons have pausing point at the same frame.  I have no idea why it is blocking in the LMS. Can you test once in SCORM Cloud to see if it results in the same problem? If it is OK there as well, the issue is with the LMS.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0
Community Beginner ,
Jun 24, 2020

Copy link to clipboard

Copied

I did as you suggested, when I click on the download button it takes me to my documents where I can save it. Then I get this message... message.PNG I relaunched and it took me back to just before clicking the downlad button. Clicking the Continue button works then but not sure if it works one right after the other without having to relaunch the preview.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0
Community Beginner ,
Jun 24, 2020

Copy link to clipboard

Copied

I clicked onthe results link and got this. results.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0
Adobe Community Professional ,
Jun 24, 2020

Copy link to clipboard

Copied

It looks to me like clicking the link to download the document is breaking the API connection with your LMS.  It thinks you have exited the session.  This is one of the dangers of linking out to other documents or websites when you are in the middle of a user session on an LMS.  Some LMSs handle the issue better than others.

 

Make sure when you set up the Open URL or File action for this document that you select the option to open in a NEW window, not the CURRENT one.  Sometimes that protects the API connection with the LMS.

 

Feel free to test your module on SCORM Cloud to see if you experience the same issue there.  If you do,  even after trying my suggestion, then you may have to abandon the strategy of getting the users to download the file in the middle of the session.  Find a way for them to download the file BEFORE they begin the session instead.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0
Community Beginner ,
Jun 25, 2020

Copy link to clipboard

Copied

Can you tell me who to set up the "Open URL or File" in a new window? I don't see that option. Also, I notice that there is a grayed out checkbox that says "Continue playing the project". Could that have anything to do with it? See screenshot.captivate screen.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2020 0
Most Valuable Participant ,
Jun 25, 2020

Copy link to clipboard

Copied

Click the button next to the URL, it is a downward arrow. There you can change the window.... Default is 'Current' and that is the reason why Continue is dimmed. If you change to New windows, it becomes available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2020 0
Community Beginner ,
Jun 25, 2020

Copy link to clipboard

Copied

THAT WORKED!!!!! Thank you for your help!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2020 0
Lilybiri LATEST
Most Valuable Participant ,
Jun 25, 2020

Copy link to clipboard

Copied

You're welcome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2020 0