Highlighted

Button audio stops when a second button audio is pressed.

Community Beginner ,
Jul 06, 2018

Copy link to clipboard

Copied

Hello Captivate Forum -

I'm running into an issue with audio attached to buttons. Here's my scenario,I have several audio buttons on a slide. The buttons work fine upon first click. Press a button and the audio file plays. However, if the same audio button or another audio button is pressed before the previous audio is finished, the audio only plays for a brief moment before it cuts out. The best guess I can come up with is that when the second button is pressed it only allows the audio to play for what the remaining time on the first buttons audio was. Has anyone experienced this before?

I'm running Captivate 9. My buttons are set up as "On Success: Play Audio"

I've tried attaching the audio to the "On Success Caption" as well with the same result.

Here's a real old thread that relates to the problem: Re: I have five buttons with audio attached to each button. When I publish in html5 and test the but...

Any help is appreciated.

Mike

Views

304

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Button audio stops when a second button audio is pressed.

Community Beginner ,
Jul 06, 2018

Copy link to clipboard

Copied

Hello Captivate Forum -

I'm running into an issue with audio attached to buttons. Here's my scenario,I have several audio buttons on a slide. The buttons work fine upon first click. Press a button and the audio file plays. However, if the same audio button or another audio button is pressed before the previous audio is finished, the audio only plays for a brief moment before it cuts out. The best guess I can come up with is that when the second button is pressed it only allows the audio to play for what the remaining time on the first buttons audio was. Has anyone experienced this before?

I'm running Captivate 9. My buttons are set up as "On Success: Play Audio"

I've tried attaching the audio to the "On Success Caption" as well with the same result.

Here's a real old thread that relates to the problem: Re: I have five buttons with audio attached to each button. When I publish in html5 and test the but...

Any help is appreciated.

Mike

Views

305

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Jul 06, 2018

Copy link to clipboard

Copied

How do you play the audio, you talk about an audio button, but doesn't explain that. Is it by using the Play Audio command? Is it by showing a hidden audio object?

Those buttons have pausing points. Are they all at the same moment (maybe post a screenshot of the timeline)? If you use the simple command 'Play Audio' for your so-called audio buttons, did you uncheck the option 'Continue Playing the project'? Which version are you using? Asking this because before CP9 you couldn't even use a simple action without releasing the playhead.

Pausing and Audio is a complicated mariiage. Have a look at this interactive movie and you'll understand what I mean:

Audio and Pausing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 06, 2018

Copy link to clipboard

Copied

As a suggestion, instead of just having these buttons execute the single action Play Audio, instead use an Advanced Action that allows multiple action lines to be executed via a single button click.  Before the Play Audio action, add the other complementary action called Stop Triggered Audio.

What I am hoping will happen here is that the Stop Triggered Audio will clear the way for the Play Audio action that comes immediately after it.

The Stop Triggered Audio action will stop ALL audio files currently playing that were triggered via an Action or Advanced Action.  If there are no audio files playing, it won't find any to stop.  But if there are audio files playing at that moment, then they will be terminated.

I haven't tested this.  It's just a suggestion for you to try.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jul 06, 2018

Copy link to clipboard

Copied

Sorry, Rod, but Play Audio when repeated automatically executes Stop Triggered Audio for the still playibg clip started with Play Audio. Only when you want one audio clip playing to stop, do you need to use Stop Triggered audio.

Of course, never hurts to try.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 06, 2018

Copy link to clipboard

Copied

AudioIssueCaptivate.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 06, 2018

Copy link to clipboard

Copied

Hi All -

Thanks for looking into this problem. I've attached a screen shot of a rough looking design where the audio problem happens.

Basically my button workflow is this: Interactions > Button > (change the style of button to image button) Actions > On Success (attach audio file)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Jul 06, 2018

Copy link to clipboard

Copied

Do you use Play Audio? Apparently it is Yes. Is it a simple action? Is Continue Playing the project unchecked?

The three buttons have no pausing point, only the Next button is pausing at 1,5seconds. Play audio is never paused by a pausing point.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

Hello Captivators -

Sorry to bring up this again, but I am experiencing the same issue. After clicking one or more buttons set to play audio, the audio file will be cut short and stop playing. 

This time I've attached the CPTX file. If anybody would take a look at this, you will see what I am describing above. 

CPTX file

I have been adding more audio to my projects so if anyone could tell me whats going on I will be forever grateful . Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Nov 12, 2018

Copy link to clipboard

Copied

I never download a cptx file from a public forum.


Will repeat my questions; how is the audio played? Is it object audio, or do you use the Play Audio command? Post the action triggered by that button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

I can understand why you wouldn't want to open a random CPTX file.
Thanks

My buttons are set to On Success: Play Audio and I have Continue Movie at the end of audio NOT selected.

These buttons are on a slide with a drag and drop interaction, but they react the same on a standard slide.

Here are some pics for clarity,

Example 1.JPGExample 2.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Nov 12, 2018

Copy link to clipboard

Copied

Let us do MezzoForte.....(I am a professional musician).

 

Your shape buttons do not pause at all. Since it is a D&D slide you will have a pausing point (from the Submit button) at 1.5secs.  It is not visible on the Timeline, but you can see it in the Timing Properties. Why is that slide so long?

 

Typical for audio clip starting with 'Play Audio' is that only one clip can play at the same time. If you trigger another audio clip with 'Play Audio', the first clip will automatically be stopped. What did you exactly want to happen?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 12, 2018

Copy link to clipboard

Copied

Thanks for the reply.


Here is what happens:

I will select the shape button and the audio will play. If I select a second shape button, the second audio will start but it will abruptly stop before it is finished.  It seems like it is somehow synced to the time that was remaining from the first triggered audio.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Lilybiri LATEST
Most Valuable Participant ,
Nov 12, 2018

Copy link to clipboard

Copied

That is not my experience, should have to test it out. Why is that slide so long? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Captivate User Guide
New Group