Highlighted

Captivate 2019 AICC Not Triggering LMS Completion

New Here ,
Aug 07, 2020

Copy link to clipboard

Copied

I created two courses with no quiz that isn't triggering completion in the LMS.

The publishing settings I was told to use are:

1. AICC Other Standard LMSs

2. Incomplete/Complete

3. Slide Views 100% and # of slides (I tried both)

4. Interaction data selected

5. LMS Initialization Text: Loading

6. Then find this file under your published project and change it in a note pad and zip the file again. 

AICCFunctions.js

Find and replace the following line of text:  JL Note: Simply remove the highlighted portion of the string.

strAICCData += "[Core_Lesson]\r\n";

remove the \r\n see below

strAICCData += "[Core_Lesson]";

 

I also published the course without the change in script.

 

Please help!

TOPICS
Advanced, Quizzing and LMS

Views

38

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Captivate 2019 AICC Not Triggering LMS Completion

New Here ,
Aug 07, 2020

Copy link to clipboard

Copied

I created two courses with no quiz that isn't triggering completion in the LMS.

The publishing settings I was told to use are:

1. AICC Other Standard LMSs

2. Incomplete/Complete

3. Slide Views 100% and # of slides (I tried both)

4. Interaction data selected

5. LMS Initialization Text: Loading

6. Then find this file under your published project and change it in a note pad and zip the file again. 

AICCFunctions.js

Find and replace the following line of text:  JL Note: Simply remove the highlighted portion of the string.

strAICCData += "[Core_Lesson]\r\n";

remove the \r\n see below

strAICCData += "[Core_Lesson]";

 

I also published the course without the change in script.

 

Please help!

TOPICS
Advanced, Quizzing and LMS

Views

39

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 07, 2020 0
Adobe Community Professional ,
Aug 07, 2020

Copy link to clipboard

Copied

Test your project in SCORM Cloud to check whether this is actually an issue with your own LMS.

 

Can I also ask WHY you are using AICC and not SCORM?  Also, why are you changing the JS file to a TXT file?  What is the purpose?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2020 0
New Here ,
Aug 14, 2020

Copy link to clipboard

Copied

Rod,

Thanks for your reply. I work with Michele on this issue. We have an older version of the LMS that only works with AICC settings. I've tried SCORM version but we get the API error with LMS (not sure what exactly is), even after going through the error, it doesn't mark the completion. The courses created in Articulate, runs with the tricks above, but the Captivate courses don't mark the completion. We added a quiz and changed the settings to mark the completion with passing score, but no luck. I've been checking the course in SCORM Cloud and they pass there. So I think Captivate is missing a string for AICC coding that doesn't work with our LMS. I just don't know what needs to be tweaked 😞 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2020 0
RodWard LATEST
Adobe Community Professional ,
Aug 14, 2020

Copy link to clipboard

Copied

I know of nothing by default that is 'missing' from the AICC output in Captivate. If the AICC course from Captivate works fine in SCORM Cloud then I would have to say that the issue is definitely a failure of your LMS, not the Captivate course. 

 

Captivate coourses are exported using LMS interaction drivers that are licensed from Rustici software who also supply the same drivers to many LMSs in the industry.  (The LMS vendors usually find they can never do a better job of the drivers if they get their own programmers to create them.)

 

Hopefully your LMS vendor will have on their team a 'technical person' who knows the inner workings of their own creation well enough to look at the call logs from your module and give you a technical explanation of why the module is not working with their LMS when it is perfectly capable of working with other LMSs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2020 0