Captivate HTML 5 problem that only occurs on iOS or Iphones and Ipad

New Here ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

I have the following problem. I have successfully exported a Captivate application that is on an FTP server. It works fine on Windows and Android devices but not on iOS devices. As soon as the application is to be launched on an iOS device, a black screen follows with a play button, but it does not respond when pressed. On an older iPhone, the application could be executed, but the font was completely different and the interactive 360° views (VR) could not be started. Also, the buttons that were created with SVG do not work on the older iPhone.
What is the reason for this and what can I do to make it work on all devices?

 

The application can currently be "viewed" at: https://www.thm.de/hit21/

My system is currently running Captivate 2019 version 11.5.5.553.

I am grateful for any suggestion and solution.

[captivate id="98289"]

Views

66

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

I have same kind of issue with the iPhone and IPad but it is related to the Slide videos on some slides in the project. On iPhone and iPad when I reach the slide with the video, I see video loading and see a play button with full black screen. On iPhone and iPad if I tap on the play button nothing happens but if I tap on anywhere on the screen away from the play button video starts working. (Check your case by tapping on away from play button). Videos are working on android, mac and windows systems.

 

I found that this happens if Mobile Gestures are turned off when publishing the protect (Windows>Mobile Pallete).

If I turn the mobile gestures on, then the play button is working. But It brings in another issue that the screen can't be scrolled up/down if the content is overflowing screen size.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

Thanks Rstish5D5E for the answer and for your advice. With your tips I seem to have managed to solve the problem.
I did this to avoid the above problem:
1. I took out the YouTube video that starts at the beginning. This made it possible that iOS devices could at least start the application. However, on iOS devices still did not go the buttons to navigate.
2. in the release settings I have then additionally activated the gesture control. Now the buttons also work on iOS devices.

Translated with www.DeepL.com/Translator (free version)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines