Highlighted

Captivate Learning Interactions do not display correctly

Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

I have several interactions that preview fine in Captivate preview, but either are the wrong size or just move to the upper left in HTML5. It does not matter what I do, I cannot seem to modify the location or size of the interaction in the published output. 

 

Has anyone run into this?

Views

30

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Captivate Learning Interactions do not display correctly

Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

I have several interactions that preview fine in Captivate preview, but either are the wrong size or just move to the upper left in HTML5. It does not matter what I do, I cannot seem to modify the location or size of the interaction in the published output. 

 

Has anyone run into this?

Views

31

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

P.S. This happens in Captivate 9 & 2017 (latest versions).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Mar 29, 2020

Copy link to clipboard

Copied

Very vague question, difficult to answer.

Which exact version number of CP2017 do you use? Are you talking about a non-responsive or a responsive project? If it is a non-responsive project, which Preview method did you use? Only F11, Preview HTML in browser will show approximately what the final published output will be. The other Preview methods use a temporary SWF output. Which browser did you use to preview?

 

Which learning interaction did you use? Some of them will only be fully functional after publishing and uploading to a webserver.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

Since I'm using a stock interaction in a blank one page course, not even changing colors or text, I'd imagine that if you have never seen the problem occur, you won't have an answer. It's not that I did anything wrong, just that it doesn't work correctly out of the box. However, to answer your questions:

  • Captivate 9.0.2.437 (this is the version the client is requesting, however it happens in 2017 10.0.1.299 as well)
  • Blank, non-responsive project. One page. Blank except for the interaction.
  • Preview in Captivate (F11) shows the interaction correctly. Previwing using "HTML5 in Browser) displays the interaction incorrectly. Also, when publishec and posted to a web server, also displays incorrectly. See attached image.
  • Many interactions, specifically I have seen it with the Pyramid Stack, Accordian, and Process Circle. Sometimes deleting the interaction and completely recreating from scratch fixes it. Sometimes not. I cannot get Pyramid Stack to work under and circumstance.
  • Browsers tested (in HTML5 preview as well as publshed output are Edge, Chrome, and Firefox.

How it looks in CaptivateHow it looks in CaptivateHow it looks when previewed or published in HTML5How it looks when previewed or published in HTML5

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Mar 29, 2020

Copy link to clipboard

Copied

Very confused now because F11 is exactly the same as Preview HTML in browser. But will leave you to someone else. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

Sorry, misspoke, F10 preview works. F11 shows incorrectly. But, again, probably not somehting that anyone besides Adobe can solve, unless it's a known issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Captivate User Guide
New Group