Highlighted

Captivate Preview won't show in browser

New Here ,
Dec 01, 2017

Copy link to clipboard

Copied

I'm trying to preview a responsive project in Captivate and when I hit Preview > Project, it takes me to my browser where it just loads indefinitely. No clue what's happening. I'm using Captivate 2017 and have never used it before.

TOPICS
Project upgrade, Quizzing and LMS

Views

3.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Captivate Preview won't show in browser

New Here ,
Dec 01, 2017

Copy link to clipboard

Copied

I'm trying to preview a responsive project in Captivate and when I hit Preview > Project, it takes me to my browser where it just loads indefinitely. No clue what's happening. I'm using Captivate 2017 and have never used it before.

TOPICS
Project upgrade, Quizzing and LMS

Views

3.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 01, 2017 0
Adobe Community Professional ,
Dec 01, 2017

Copy link to clipboard

Copied

If you are currently using a Windows browser, try using Chrome instead.

But the best way to preview HTML5 responsive projects is from within a web server environment.  If you cannot do that using a localhost web server on your computer, you may need to upload to a web server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0
New Here ,
Dec 01, 2017

Copy link to clipboard

Copied

I'm on a Mac (High Sierra, 2016 Macbook Pro) and using Chrome. I tried the link in Chrome and also Safari and it won't work in either.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0
Adobe Community Professional ,
Dec 01, 2017

Copy link to clipboard

Copied

Have you tried the suggestion to upload to a web server?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0
New Here ,
Dec 01, 2017

Copy link to clipboard

Copied

How do you upload it to a web server?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0
Adobe Community Professional ,
Dec 01, 2017

Copy link to clipboard

Copied

It would seem you are not familiar with that concept, which would also suggest perhaps you do not have access to a web server either.

Change of plan.  Set your project as a SCORM 1.2 (in Quiz > Reporting) and publish out with the Zip option selected so that you end up with a zipped SCORM Package.  Then upload that to SCORM Cloud online LMS.  That is also a web server.  Even though you're not interested in testing for compatibility with an LMS, it gives you the opportunity to see if your REAL issue here is from trying to play HTML5 content locally where your browser security is preventing something from working.  Playing the HTML5 content from a web server normally eliminates that type of browser security and will show whether the issue is due to some other problem.

Increasingly strict browser security is becoming a major reason why Captivate's published content gets reported here as not working.  The problem isn't really Captivate in many cases.  It's the fact that you are trying to play HTML5 in an environment for which it is not designed to work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2017 0
New Here ,
Dec 02, 2017

Copy link to clipboard

Copied

What is SCORM Cloud? Also, when I go to save it I can only save it as .cptx.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2017 0
New Here ,
Dec 02, 2017

Copy link to clipboard

Copied

Update, if it might help: I hit preview in SCORM cloud and it popped up as a 404 Error and then "Failed to preview in SCORM cloud"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2017 0
Adobe Community Professional ,
Dec 02, 2017

Copy link to clipboard

Copied

I recommended you publish out to a SCORM zip file and then UPLOAD to SCORM Cloud.  That's not the same as the Preview in SCORM Cloud option that you see from within Captivate.  Your current issue could well be due to some problem on your local system that is blocking the published output from working.  So what I was trying to find out (by my recommendation) is whether or not the issue is indeed local to your system or something wrong with the Captivate output itself.

So can you please try out my original suggestion?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2017 0
Explorer ,
Jun 01, 2018

Copy link to clipboard

Copied

Hi Ron,  I woulld like to preview my project before uploading it to my server.  But the load icon just spins and spins.  See the image.  Why does this occur?

Thanks.

Browser_Never-Loads.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Most Valuable Participant ,
Jun 01, 2018

Copy link to clipboard

Copied

Rod is in Australia... probably not awake now.

That often happens to me as well, for HTML output, not sure about the cause.


Sometimes it helps switching to another browser. Usually I use Chrome, but often Edge is working better. If none is working, I just upload to a server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Explorer ,
Jun 01, 2018

Copy link to clipboard

Copied

Thank you.  Yes, Rod is from downunder, and I hope he gets good rest.  He has great insight, like you into Cp.  I do upload to a server, but this adds time to the process.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Most Valuable Participant ,
Jun 01, 2018

Copy link to clipboard

Copied

Did you try switching to another browser?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Adobe Community Professional ,
Jun 01, 2018

Copy link to clipboard

Copied

Lilybiri's suggestion is the one I would have made first.  Try a different browser.  I find Chrome better for local previewing of HTML5 content than IE or Edge.  The issue seems to be related to browser security.

For a true idea of what the end output will do or look like though, you REALLY need to run HTML5 output in a web server.  I set up a local Apache server on my development PC for this purpose.  Then you can usually use any HTML5-compliant browser.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Explorer ,
Jun 01, 2018

Copy link to clipboard

Copied

Rod,  as a CP Extra user,  I remember watch a video of Tristan setting up a local Apache server for testing projects.  Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Adobe Community Professional ,
Jun 01, 2018

Copy link to clipboard

Copied

Correct.  In my case I usually install the server via a XAMPP package installer so that I can have PHP as well as MySQL installed and working at the same time.  Then I can easily install a Moodle server for LMS testing of content.  SCORM Cloud is a better LMS alternative to use if you need to test for SCORM 2004 or xAPI.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Most Valuable Participant ,
Jun 02, 2018

Copy link to clipboard

Copied

Hi Rod, was smiling because for me it is often Chrome which doesn't show the project, whereas Edge will be functional. Not IE.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2018 0
New Here ,
Aug 29, 2018

Copy link to clipboard

Copied

Chrome is my default browser and when I try to view preview from Captivate, nothing happens. I thought there was a way in Captivate to indicate what browser to use for preview. But, I can;t find it. Please help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2018 0
Most Valuable Participant ,
Aug 29, 2018

Copy link to clipboard

Copied

Preview in Browser (F12) will show SWF. Preview in the browser chosen as

Default browser. You can always copy the URL to another browser. F11 will

act the same way but for HTML output.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2018 0
Explorer ,
Dec 02, 2017

Copy link to clipboard

Copied

Try "Preview from this slide" on the first slide you have.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2017 0
Adobe Community Professional ,
Jun 02, 2018

Copy link to clipboard

Copied

I know there was an issue with the first release of Captivate 2017 with High Sierra. Did you apply the patch or the latest update? Im a windows guy but many mac isers had this problem.

Paul Wilson, CTDP | https://captivateteacher.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 02, 2018 0
Explorer ,
Jun 19, 2018

Copy link to clipboard

Copied

This happens to me also.  Indefinite loading in Chrome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2018 0
New Here ,
Jun 23, 2018

Copy link to clipboard

Copied

Hello,

I have been struggling with my browser not being able to preview my responsive project for weeks until I came across a post suggesting the issue may be connecting to the skin editor.

I made the following changes and now the preview works in my google chrome browser on a mac.

Step 1: Go to Project (in the top menu) > Skin Editor

Step 2: Untick Show Playback Control

Preview your project

Hope this works for you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2018 3
New Here ,
Dec 08, 2019

Copy link to clipboard

Copied

thank you! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2019 0