Highlighted

Captivate project freezing and stuck animations

Explorer ,
Jan 04, 2019

Copy link to clipboard

Copied

Hi. I've created a project in HTML5 where the slides keeps freezing randomly. They should play correctly with Audio on Enter and animations. When I Preview the project on Captivate using F8 , it works well. But when I preview or Publish in HTML5, it keeps freezing on some slides and some animations doesnt play and appear, getting me stucked on slides.

- There is a lot of animation on slides.

- I'm using SCORM 1.2.

- There is On Enter actions and audios linked to object slides.

- I've already tried to hide some slides to find the bug, but whatever slide I hide, the bug appears somewhere else.

- I'm using some SVG files.

Can anybody help me?

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

I would move the pausing point of that interactive object, not totally to the end of the slide but close to it. The time of 0,5sec is very low, depending on the type of effect and the object it is applied to.

Views

530

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Captivate project freezing and stuck animations

Explorer ,
Jan 04, 2019

Copy link to clipboard

Copied

Hi. I've created a project in HTML5 where the slides keeps freezing randomly. They should play correctly with Audio on Enter and animations. When I Preview the project on Captivate using F8 , it works well. But when I preview or Publish in HTML5, it keeps freezing on some slides and some animations doesnt play and appear, getting me stucked on slides.

- There is a lot of animation on slides.

- I'm using SCORM 1.2.

- There is On Enter actions and audios linked to object slides.

- I've already tried to hide some slides to find the bug, but whatever slide I hide, the bug appears somewhere else.

- I'm using some SVG files.

Can anybody help me?

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

I would move the pausing point of that interactive object, not totally to the end of the slide but close to it. The time of 0,5sec is very low, depending on the type of effect and the object it is applied to.

Views

531

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 04, 2019 0
Most Valuable Participant ,
Jan 04, 2019

Copy link to clipboard

Copied

If this is a non-responsive project F8 is using a temporary SWF file.

To check the possible behavior in HTML5 output you need to use Preview HTML5 in BRowser (F11). How is that looking?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 1
Explorer ,
Jan 04, 2019

Copy link to clipboard

Copied

Its a non responsive project. Its not working well on F11 as well. On F8 is perfect. On HTML5 tracker it doesnt show that anything is wrong. Could it be the object animations?

Example of one slide that is not working / playing correctly:

Capturar.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Most Valuable Participant ,
Jan 04, 2019

Copy link to clipboard

Copied

HTML tracker only indicates objects that are not supported. HTML5 output is much more sensitive to many settings than the more robust SWF output which is used in all Preview methods except F11.

I see that you have a pausing point at 1,5 seconds. Since the effects timelines are not visible, I am just guessing: are you sure that all effects have been finished before that pausing point?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Explorer ,
Jan 04, 2019

Copy link to clipboard

Copied

The effects are triggered on 0 seconds and they have 0,5s duration. They are working properly on SWF preview. I was testing now and one of the slides always worked, has freezed in the middle of an animation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Most Valuable Participant ,
Jan 04, 2019

Copy link to clipboard

Copied

I would move the pausing point of that interactive object, not totally to the end of the slide but close to it. The time of 0,5sec is very low, depending on the type of effect and the object it is applied to.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Explorer ,
Jan 04, 2019

Copy link to clipboard

Copied

Alright. I will try that. Also, I've enabled the Captivate playbar and I could notice that on the problematic slides, the slides are pausing randomly at the begining (3-4s). Some of these slides have a pausing point only on 30s.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Most Valuable Participant ,
Jan 04, 2019

Copy link to clipboard

Copied

Do you have audio on those slides? 30sec is a long time, I only can think of long audio clips for needing that. Audio has to be generated when entering the slide and audio clips have a big size.

Sorry, I am just trying to find some causes. The real result can only be viewed after publishing and uploading to a webserver, but F11 not working well could be a prediction of problems.  

You should never use very short durations for motion effects.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Explorer ,
Jan 04, 2019

Copy link to clipboard

Copied

Yes, most of slides has audio. I've increased the effects duration and removed some and now all slides are working. I suppose that these animations were the problem with the HTML5 output. The slides were pausing randomly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Most Valuable Participant ,
Jan 04, 2019

Copy link to clipboard

Copied

Probably because the effect duration was too short, as I mentioned above. I do use a lot of effects, what you tell never happened to me but I never decrease the duration too much compared with the default duration.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0
Explorer ,
Jan 04, 2019

Copy link to clipboard

Copied

Thanks for your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2019 0