Highlighted

Captivate VR to Daydream in Lenovo Mirage?

Community Beginner ,
Feb 19, 2020

Copy link to clipboard

Copied

Is this posssible, and if so, how?

 

I've followed the instructions and published to the web, but when I view the project in Mirage/Daydream, I can only see it as I would see it on the desktop, and clicking 'View VR' results in the split screen within a web browser window, not the full immersive experience.

 

Anyone got any clues?

Correct answer by stevep4 | Community Beginner

I found the answer to my problems - Google Chrome (in the Mirage) had updated to version 80 that had WebXR enabled by default and WebVR disabled. Changing this so that WebXR is disabled and WebVR enabled (via chrome://flags) resulted in success.

 

I assume Captivate will change its publishing settings at some point to allow for the newer WebXR.

 

Topics

Virtual reality

Views

282

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Captivate VR to Daydream in Lenovo Mirage?

Community Beginner ,
Feb 19, 2020

Copy link to clipboard

Copied

Is this posssible, and if so, how?

 

I've followed the instructions and published to the web, but when I view the project in Mirage/Daydream, I can only see it as I would see it on the desktop, and clicking 'View VR' results in the split screen within a web browser window, not the full immersive experience.

 

Anyone got any clues?

Correct answer by stevep4 | Community Beginner

I found the answer to my problems - Google Chrome (in the Mirage) had updated to version 80 that had WebXR enabled by default and WebVR disabled. Changing this so that WebXR is disabled and WebVR enabled (via chrome://flags) resulted in success.

 

I assume Captivate will change its publishing settings at some point to allow for the newer WebXR.

 

Topics

Virtual reality

Views

283

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Mar 01, 2020

Copy link to clipboard

Copied

I found the answer to my problems - Google Chrome (in the Mirage) had updated to version 80 that had WebXR enabled by default and WebVR disabled. Changing this so that WebXR is disabled and WebVR enabled (via chrome://flags) resulted in success.

 

I assume Captivate will change its publishing settings at some point to allow for the newer WebXR.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Mar 02, 2020

Copy link to clipboard

Copied

Thank so much for sharing this valuable information!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
stevep4 LATEST
Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

Hi Lilybri,

There is no longer an option in the current Chrome to use WebVR instead of the new standard WebXR. This means the Captivate output can no longer be viewed in a headset with Chrome. Version 11.5.1 does not appear to have addressed this issue by updating the javascript output.

Do you know if a fix is intended for this, or where I could get more assistance?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Captivate User Guide
New Group