Highlighted

Chrome 83 completion issues on Totara/Moodle with SCORM

Participant ,
Jun 04, 2020

Copy link to clipboard

Copied

Hi all,

 

We've had a number of issues recently with SCORM pacakges not marking as complete when completed on our Totara LMS. (Totara is based on Moodle, and this issue seems common amongst others who use Moodle).

 

For reference, we are using Captivate 2019 11.5.0.476

 

I posted on the Moodle forum and I was alerted to this support page which outlines the causes for issues with Chrome 80 and Chrome 83: https://apps.support.sap.com/sap/support/knowledge/public/en/2876002

 

It seems the key issue relates to Chrome blocking Synchronous API requests.

 

All of our SCORM packages report data to the LMS on the page being exited, but it seems like this is no longer supported by Chrome. Our only solution so far has been to switch on the setting to send data on every slide, but we are concerned about the effect on performance/pressure on the server. It also will require a lot of production work as we manage hundreds of SCORM packages.

 

I know that Adobe have previously released a Hotfix for the related (?) issue with Chrome 80 but only for xAPI.

 

Does anyone know if there will be a hotflix for SCORM 1.2 and SCORM 2004? Is anybody aware of any workarounds? Is anybody else experiencing this?

 

Thank you for your help in advance! Happy to provide further details if needed.

 

Mike

TOPICS
Advanced, Quizzing and LMS

Views

701

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Chrome 83 completion issues on Totara/Moodle with SCORM

Participant ,
Jun 04, 2020

Copy link to clipboard

Copied

Hi all,

 

We've had a number of issues recently with SCORM pacakges not marking as complete when completed on our Totara LMS. (Totara is based on Moodle, and this issue seems common amongst others who use Moodle).

 

For reference, we are using Captivate 2019 11.5.0.476

 

I posted on the Moodle forum and I was alerted to this support page which outlines the causes for issues with Chrome 80 and Chrome 83: https://apps.support.sap.com/sap/support/knowledge/public/en/2876002

 

It seems the key issue relates to Chrome blocking Synchronous API requests.

 

All of our SCORM packages report data to the LMS on the page being exited, but it seems like this is no longer supported by Chrome. Our only solution so far has been to switch on the setting to send data on every slide, but we are concerned about the effect on performance/pressure on the server. It also will require a lot of production work as we manage hundreds of SCORM packages.

 

I know that Adobe have previously released a Hotfix for the related (?) issue with Chrome 80 but only for xAPI.

 

Does anyone know if there will be a hotflix for SCORM 1.2 and SCORM 2004? Is anybody aware of any workarounds? Is anybody else experiencing this?

 

Thank you for your help in advance! Happy to provide further details if needed.

 

Mike

TOPICS
Advanced, Quizzing and LMS

Views

702

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 04, 2020 0
Most Valuable Participant ,
Jun 04, 2020

Copy link to clipboard

Copied

Cannot help you with the LMS issue, but PLEASE install the bug update so that you are on 11.5.1.499. It may not be linked with the present issues, but solves some bugs in the first release of 11.5.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 1
Participant ,
Jun 04, 2020

Copy link to clipboard

Copied

Thank you for the suggestion lilybiri! I have now updated but unfortunately still the same issue. Thank you still for responding.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 0
Adobe Community Professional ,
Jun 04, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2020 0
Participant ,
Jun 05, 2020

Copy link to clipboard

Copied

Hi Rod,

 

Thank you for the suggestion. How would this apply to mocules where the completion criteria is 100% slide views? Also, I want the learner's position to be bookmarked whenever they exit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 0
Adobe Community Professional ,
Jun 05, 2020

Copy link to clipboard

Copied

I would not use 100% page views but instead work out exactly how many pages the learner MUST view as a minimum (not counting the final page that comes AFTER the Quiz Review slide) and then specify that number as the exact number of slides the learner needs to view as completion criteria.

 

Using 100% page views almost always gets you into hot water one way or another because in some courses you simply cannot guarantee that all users will view every single page.

 

Bookmarking is an entirely separate issue and is configured by making sure that Never Send Resume Data is NOT selected in the LMS Advanced dialog.  It should not affect your page view stats.

 

If your management says this approach (specifying page numbers instead of page view percentages) is not acceptable, then I would say (based on many years experience) that they are idiots.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 0
Participant ,
Jun 05, 2020

Copy link to clipboard

Copied

Hi Rod, thank you for the clarification. But as I understand it, the resume data is not being sent on exit. If i check the attempt details after an attempt on Firefox, all of the suspend data is logged, but this is not the case on Chrome. So the current situation makes bookmarking impossible, the only way we can have kind of data (whether relating to bookmarks or completion) is to send resule data on every slide.

 

I have tested your suggestion: I have created a three-slide project with the completion requirement being to view two slides. It does not mark as completed, nor does it bookmark on chrome, but on firefox it works as expected. We have not have issues previously with making 100% of slide views the criteria, but I do take your point about it being more reliable to specficy a number of slides that is less than the total.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 0
Adobe Community Professional ,
Jun 05, 2020

Copy link to clipboard

Copied

Can you check your Quiz > Reporting settings to see which Template you are using on that screen.  One of the templates that ships with Captivate is called SendTrackingDataAtEnd.  If that template happens to have been selected, then it means Captivate is NOT sending at least some data to the LMS regularly throughout the user's interaction with the module. 

QuizReportingTemplateSendTrackingData.png

 

This template is a feature that was designed to reduce load on the LMS server by just sending the data on the very last slide.  However, the downside of this template with Chrome 80 implementations is that your data may never reach the LMS.

 

So which template are you using?

 

And while you are looking at the Quiz Reporting dialog, check to see whether Interaction Data checkbox is also selected.  Ideally it should be, but if your organisation was previously trying to reduce load on their server they may also have turned this off.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 05, 2020 0
Participant ,
Jun 07, 2020

Copy link to clipboard

Copied

Hi Rod,

 

I have the "Default" template selected and interaction data checkbox ticked. This has worked for years with no issues. I'm fairly confident that Chrome blocking synchronous API requests is at the root of the issue, and while there is a brower-side solution to this, I need a Captivate-side solution that doesn't put too much strain on our server. At present we have now moved most SCORMs over to Send Data on Every Slide and are monitoring what effect this has.

 

Thank you for your help and advice!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2020 0
Adobe Community Professional ,
Jun 07, 2020

Copy link to clipboard

Copied

Well since this issue is going to definitely have a huge impact on e-learning courses around the world I feel fairly sure that there would be several Captivate team developers working on resolving it as soon as possible.

 

My concern here is that Adobe doesn't usually issue patches for versions that are more than a couple of versions back.  So, resolving this issue alone would likely require all Captivate developers on any version prior to Cp 2017 or 2019 to update in order to gain the benefit of the update.  With a new version of Captivate due anytime now, Cp 2017 is unlikely to be viable unless the patch is released very soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2020 1
Participant ,
Jun 07, 2020

Copy link to clipboard

Copied

Hi Rod,

 

Thank you for the insight. Fortunately we are on Cap 2019 and always stay up to date. Do you think that the next version will address the issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2020 0
RodWard LATEST
Adobe Community Professional ,
Jun 08, 2020

Copy link to clipboard

Copied

No idea on what the next version will do.  I'm not involved in any way with that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 08, 2020 1