Highlighted

Course buttons are not working during revisit

New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

Hello,

I have created a course wherein I created custom navigation buttons to move forward & backward.

While visiting the first time course is working perfect, I kept the restart button at the end, when I click on it to revisit the module, it's moving up to 2nd slide after that the navigation buttons are not responding (not taking to resultant slide).

Thanks in advance, your support is much appreciable.

Thanks & Regards

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

You mention that you have created the forward and back buttons at slide level.  If I understand you correctly, does this mean you have added two buttons to each and every slide in your project?  If you have a large project, you may have hundreds of buttons, and sometimes this can cause issues because you then exceed the number of interactive objects that can work without issue in a single project.  (Don't ask me how many that is but I know it falls somewhere over 100.)

You can easily test whether this might in fact be the cause of your issue by just Hiding half the slides in your project to reduce the number of buttons.  Republish and test your project with say just 40 or 50 slides.

If you currently have buttons on all slides, but you have your TOC on the Master Slide, why not just add the two buttons to the Master Slide.  If Master Slide objects are set to be on top, then those two buttons should appear on all slides.  If the actions on the buttons are only to go to the previous slide or go to next slide, then these are generic actions that can be used for buttons on a Master Slide.

Views

198

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Course buttons are not working during revisit

New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

Hello,

I have created a course wherein I created custom navigation buttons to move forward & backward.

While visiting the first time course is working perfect, I kept the restart button at the end, when I click on it to revisit the module, it's moving up to 2nd slide after that the navigation buttons are not responding (not taking to resultant slide).

Thanks in advance, your support is much appreciable.

Thanks & Regards

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

You mention that you have created the forward and back buttons at slide level.  If I understand you correctly, does this mean you have added two buttons to each and every slide in your project?  If you have a large project, you may have hundreds of buttons, and sometimes this can cause issues because you then exceed the number of interactive objects that can work without issue in a single project.  (Don't ask me how many that is but I know it falls somewhere over 100.)

You can easily test whether this might in fact be the cause of your issue by just Hiding half the slides in your project to reduce the number of buttons.  Republish and test your project with say just 40 or 50 slides.

If you currently have buttons on all slides, but you have your TOC on the Master Slide, why not just add the two buttons to the Master Slide.  If Master Slide objects are set to be on top, then those two buttons should appear on all slides.  If the actions on the buttons are only to go to the previous slide or go to next slide, then these are generic actions that can be used for buttons on a Master Slide.

Views

199

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 25, 2019 0
Most Valuable Participant ,
Mar 25, 2019

Copy link to clipboard

Copied

Can you please give some more details?

  • Which version do you use (full number please)?
  • How did you create those buttons: on the master slide, timed for the rest of the project?
  • Which actions are triggered by the buttons?
  • Do you have other interactive objects on the slides besides the navigation buttons?
  • Where are the pausing points of those buttons?
  • Are you publishing to HTML5? If yes and you use a non-responsive project, did you test with F11 Preview HTML in Browser?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

Hi Lilybri,

Thanks for your response!

  • Which version do you use (full number please)?
    • Captivate 2019 (11.0.0.243)
  • How did you create those buttons: on the master slide, timed for the rest of the project?
    • Those (2) buttons are created at slide level.
    • 4.PNG
  • Which actions are triggered by the buttons?
    • 2.PNG
  • Do you have other interactive objects on the slides besides the navigation buttons?
    • No (On master have created TOC)
  • Where are the pausing points of those buttons?
    • @1:30 sec
  • Are you publishing to HTML5? If yes and you use a non-responsive project, did you test with F11 Preview HTML in Browser?
    • Yes, I'm publishing to HTML5, and it's a non-responsive project too. I have tested in HTML in Browser. In this mode also it's not responding in revisiting time.

Thanks a lot for your time and efforts.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
Most Valuable Participant ,
Mar 25, 2019

Copy link to clipboard

Copied

Please update to 11.0.1.266!

Strange that you copy/pasted a button on each slide, why? Not very practical IMO. You should have used Shape buttons on the master slide(s) used for your slides, or have them on the first slide needed, timed for the rest of the project.

Since it is not working with F11, something definitely is wrong in that project. Difficult to guess what is awry. Do you have actions set up which detect if slide is visited for the first time? Do you have a Quiz? If yes, do you allow Backwards movement for the Quiz Preferences?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

Now I have updated to the mentioned version.

Firstly I'm a new bee to Captivate, I learnt captivate from this community and youtube.

I didn't set up any actions to track visited slides, I don't have a quiz in my course.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
Adobe Community Professional ,
Mar 25, 2019

Copy link to clipboard

Copied

You mention that you have created the forward and back buttons at slide level.  If I understand you correctly, does this mean you have added two buttons to each and every slide in your project?  If you have a large project, you may have hundreds of buttons, and sometimes this can cause issues because you then exceed the number of interactive objects that can work without issue in a single project.  (Don't ask me how many that is but I know it falls somewhere over 100.)

You can easily test whether this might in fact be the cause of your issue by just Hiding half the slides in your project to reduce the number of buttons.  Republish and test your project with say just 40 or 50 slides.

If you currently have buttons on all slides, but you have your TOC on the Master Slide, why not just add the two buttons to the Master Slide.  If Master Slide objects are set to be on top, then those two buttons should appear on all slides.  If the actions on the buttons are only to go to the previous slide or go to next slide, then these are generic actions that can be used for buttons on a Master Slide.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 1
Most Valuable Participant ,
Mar 25, 2019

Copy link to clipboard

Copied

Did you read this:

Challenges for Starters - Captivate blog

I doubt that you'll find essential information on the non-curated YouTube videos.

I don't see any reasons why a Next or Previous button wouldn't work when coming back to a slide.  Maybe post the setup of the TOC you are talking about?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
Explorer ,
Mar 25, 2019

Copy link to clipboard

Copied

What if you need to control the button using it's name? Shape buttons on the Master slide can't have names so you can't control them with actions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
Most Valuable Participant ,
Mar 25, 2019

Copy link to clipboard

Copied

I offered the two solutions: either on the master slide if control is not needed often (two different master slides ia a workaround), or timed for the rest of the project. In the last case you have one unique ID for each of the buttons, very easy to hide/show.

You really must read my old blogs about shape buttons.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

Hi Rodward,

Thanks for your details, it helped to resolve the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

Hi Lilybiri,

Thanks for your details, the two different master slide idea helped to design master slide in proper structure.

Great idea.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0
New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

Hi Rchil,

Wonderful question, many times one question might be the answer for another big question.

This situation proved that to me again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 0