Highlighted

CP 2017 and HTML5 Animation

Engaged ,
Jan 22, 2020

Copy link to clipboard

Copied

I made a simple HTML5 Animation.  When I bring it in as an OAM file all I get is a blank whate screen.

I'm new to Animate and haven't inserted HTML 5 animations before so its probably my fault.  

TOPICS
Advanced, Editing

Views

186

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CP 2017 and HTML5 Animation

Engaged ,
Jan 22, 2020

Copy link to clipboard

Copied

I made a simple HTML5 Animation.  When I bring it in as an OAM file all I get is a blank whate screen.

I'm new to Animate and haven't inserted HTML 5 animations before so its probably my fault.  

TOPICS
Advanced, Editing

Views

187

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 22, 2020 0
Advocate ,
Jan 22, 2020

Copy link to clipboard

Copied

Did you add the HTML5 animation as a zipped file or as a straight OAM?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Engaged ,
Jan 22, 2020

Copy link to clipboard

Copied

Straight OAM

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Engaged ,
Jan 22, 2020

Copy link to clipboard

Copied

That seemed to be the only option for bringing it in through media in Captivate.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Adobe Community Professional ,
Jan 22, 2020

Copy link to clipboard

Copied

When you are in Animate with this animation on the timeline, what do you see if you hit Ctrl + Enter to do a test publish?  What should happen is that you see your default web browser open and play the animation.

 

If you also see a blank screen when you do that, then something is wrong in your animation.  If you see it play correctly, then the problem might be with the way you have it set up in Captivate.  Do you have it set to be Not Visible in Output perhaps?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 22, 2020 0
Engaged ,
Jan 23, 2020

Copy link to clipboard

Copied

It plays correctly when I run Test in Animate.  I've published it as OAM and attempted to zip it and import it that way and both bring up a blank square.  These animation are just little movies that play on the screen when you press a button.  The previous developer used .swf.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 23, 2020 0
Engaged ,
Jan 23, 2020

Copy link to clipboard

Copied

I had a developer on another team make a .zip of the animate .fla and they gave me a zip file and it still isn't showing up.  Well I played with the frame and when I stretched it out I found the animation.  Weird.  Now the problem is getting it to play.  I previewed it in HTML5 but it just sat there at the first screen. It didn't play and I don't want it to play automatically I want it to start when the student clicks a button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 23, 2020 0
Adobe Community Professional ,
Jan 23, 2020

Copy link to clipboard

Copied

If you want it to interact with Captivate then you are going to need JavaScript. Captivate will be the window.parent of the animation.

 

I create animation in html and insert those, never use AnimateCC to do them so I'm not sure exactly how you would add the script. 

 

If you want them to click a button to start the animation you can build that in AnimateCC.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 23, 2020 0