Highlighted

Embedded MP4 Causing Upload Problems to LMS

Explorer ,
Aug 31, 2018

Copy link to clipboard

Copied

This one is confounding me and my team.

We've recently encountered a problem where our SCORM project won't upload to our LMS, and we're 99.9% sure that the culprit is an MP4 that we've embedded onto a slide.

I say 99.9% sure because here's what we've encountered...

  • Other Captivate SCORM files that do not include MP4s are uploading to our LMS with no problem.
  • Other MP4 files (for example, ones created in Camtasia) are also uploading to our LMS with no problem.
  • We've done this in the past with Captivate, and it's worked with no problem. It's probably been about 6 months since we tried it, but it worked fine.

I suppose it could be something else, but considering that other Captivate SCORM projects as well as SCORM mp4s are4 working, I'm lead to believe that the MP4 is the issue.

Views

192

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Embedded MP4 Causing Upload Problems to LMS

Explorer ,
Aug 31, 2018

Copy link to clipboard

Copied

This one is confounding me and my team.

We've recently encountered a problem where our SCORM project won't upload to our LMS, and we're 99.9% sure that the culprit is an MP4 that we've embedded onto a slide.

I say 99.9% sure because here's what we've encountered...

  • Other Captivate SCORM files that do not include MP4s are uploading to our LMS with no problem.
  • Other MP4 files (for example, ones created in Camtasia) are also uploading to our LMS with no problem.
  • We've done this in the past with Captivate, and it's worked with no problem. It's probably been about 6 months since we tried it, but it worked fine.

I suppose it could be something else, but considering that other Captivate SCORM projects as well as SCORM mp4s are4 working, I'm lead to believe that the MP4 is the issue.

Views

193

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 31, 2018 0
Most Valuable Participant ,
Aug 31, 2018

Copy link to clipboard

Copied

Can you try to recode the MP4 file with the Adobe Media Encoder which ships with Captivate. Encode to H264.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2018 0
Explorer ,
Sep 04, 2018

Copy link to clipboard

Copied

Yes, we have done this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
Adobe Community Professional ,
Aug 31, 2018

Copy link to clipboard

Copied

Two questions:

  • Does that module successfully upload if you remove the MP4 and then test upload?
  • Is it possible that your LMS has a file upload limit that is being breached because of the size of your MP4? (Check with your LMS Admin about the maximum allowed upload size.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2018 0
Explorer ,
Sep 04, 2018

Copy link to clipboard

Copied

Does that module successfully upload if you remove the MP4 and then test upload?

Yes, it does.

Is it possible that your LMS has a file upload limit that is being breached because of the size of your MP4? (Check with your LMS Admin about the maximum allowed upload size.)

Yes, the LMS does have an upload limit, but the module is nowhere near the limit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
Explorer ,
Sep 04, 2018

Copy link to clipboard

Copied

This is the error message the LMS admin is getting...

Captivate Error Message.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
Adobe Community Professional ,
Sep 05, 2018

Copy link to clipboard

Copied

Try making sure there are no spaces in filenames for your videos and any other assets.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 1
Adobe Community Professional ,
Sep 05, 2018

Copy link to clipboard

Copied

Looks like your LMS is quitting on a warning.

You'll need to unzip the package and find the path to the video, which may have another name and put that path in the resources section of the imsmanifest. The zip it again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2018 0