Embedding video from subscription service into slide - problems!

New Here ,
Nov 25, 2020

Copy link to clipboard

Copied

Hi there - I am new to Captivate so sorry if this is a basic question.  

 

My company has a subscription to an online platform containing video content.  We have permission to embed the videos into our online learning slides, however I can't get the embed link to be accepted at all?

 

Can I only embed if the source is in Vimeo or Youtube?  I can't see how else it will work?  Any other options?


In ActivePresenter software, I used to be able to just add the url and it would work.  

The video URL is:

https://imdex.safetyhub.com/embeddirect/V28F49G7/2246553?videosettings=0-66&hideprogressbar=1

And the embed code is : 

<div style='position: relative;padding-bottom: 56.25%;padding-top: 25px;height: 0;'><iframe frameborder='0' scrolling='no' src='https://imdex.safetyhub.com/embed/V28F49G7/2246553?videosettings=0-66&hideprogressbar=1' allowfullscreen style='max-width: 100%;max-width: 100%;position: absolute;top: 0; left: 0;width: 100%;height: 100%;'></iframe></div>

 

Any help is very much appreciated!


Kind regards,

Naomi

Views

59

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Community Professional , Nov 25, 2020
Paul Wilson CTDP Adobe Community Professional , Nov 25, 2020
The solution is to use a Web Object. Click on the Objects icon on the Captivate toolbar and select Web. This will add a web object to your slide.  Change the web object from Address to Embed code in your properties inspector and paste your embed code in the field below those radio buttons. Make whatever other refinements you find necessary to achieve the appearance you are looking for.

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Nov 25, 2020

Copy link to clipboard

Copied

The solution is to use a Web Object.

  1. Click on the Objects icon on the Captivate toolbar and select Web. This will add a web object to your slide. 
  2. Change the web object from Address to Embed code in your properties inspector and paste your embed code in the field below those radio buttons.
  3. Make whatever other refinements you find necessary to achieve the appearance you are looking for.
Paul Wilson, CTDP

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 27, 2020

Copy link to clipboard

Copied

Many thanks, Paul!

 

So I have given that a go and all appears beautifully until I preview the project in html 😞  Then when it comes to the relevant slide, the whirring / loading icon appears forever, until I click it, then the Play arrow appears.  How do i make it stop whirring so the user doesn't sit there waiting forever or have to click it to access the play button?

 

Many thanks again!

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 27, 2020

Copy link to clipboard

Copied

I noticed when I used the link you provided in the original post that I got the following error message and a request to log in.

2020-11-27_8-43-09.png

 

Could it be that you are previewing it behind a firewall or perhaps outside the range of the IP address? 

Paul Wilson, CTDP

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 27, 2020

Copy link to clipboard

Copied

You may wish to also try embedding the embed code if you used the hyperlink or if you used the embed code just try the link itself.
Paul Wilson, CTDP

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 02, 2020

Copy link to clipboard

Copied

Thanks Paul.  Our systems have been configured to allow this particular content to pass the firewall.  That being said, it appears to be working now anyway??!?! 


Thanks again for your assistance 🙂 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 02, 2020

Copy link to clipboard

Copied

Glad to hear it.
Paul Wilson, CTDP

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more