Highlighted

Event Video Skin Play and Pause only

Explorer ,
Aug 06, 2018

Copy link to clipboard

Copied

Hello again,

Captivate 9, updated.

CPTX file, adding mp4 as an event video to an individual slide.

I'm confused about the skin on an event video. On the stage, after selecting "haloSkin1", the video on the stage displays play, pause and stop button. This is a perfect scenario for me, since we want to avoid learners scrubbing through the video. I also experienced users reporting that scrubbing to the end forced them to wait until the length of the video to expire before the slide auto advances. So when I found this skin with no slide bar, it seemed like a winner.

Anyways, on the stage, I see a skin that seems to fit my needs.

Stage.png

However, when I preview the html5, I do not get the skin that was on the stage. I get additional buttons and an unwanted video slider to scrub the video (no need for audio controls either). I only want play and pause (stop I can also deal with). The skin's playbar also only appears when moused over and appears as an overlay.

html5Player.png

My questions:

Do we have control over what buttons appear in the skin?

Can we force the video skin's play bar to be pinned and not overlayed?

Views

927

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Event Video Skin Play and Pause only

Explorer ,
Aug 06, 2018

Copy link to clipboard

Copied

Hello again,

Captivate 9, updated.

CPTX file, adding mp4 as an event video to an individual slide.

I'm confused about the skin on an event video. On the stage, after selecting "haloSkin1", the video on the stage displays play, pause and stop button. This is a perfect scenario for me, since we want to avoid learners scrubbing through the video. I also experienced users reporting that scrubbing to the end forced them to wait until the length of the video to expire before the slide auto advances. So when I found this skin with no slide bar, it seemed like a winner.

Anyways, on the stage, I see a skin that seems to fit my needs.

Stage.png

However, when I preview the html5, I do not get the skin that was on the stage. I get additional buttons and an unwanted video slider to scrub the video (no need for audio controls either). I only want play and pause (stop I can also deal with). The skin's playbar also only appears when moused over and appears as an overlay.

html5Player.png

My questions:

Do we have control over what buttons appear in the skin?

Can we force the video skin's play bar to be pinned and not overlayed?

Views

928

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 06, 2018 0
Most Valuable Participant ,
Aug 06, 2018

Copy link to clipboard

Copied

You are confusing the event video skin (which on HTML appears when you hover over the bottom of the video) and the Captivate playbar which you show on the second screenshot. That was not the case for SWF output, lot of good features are lost with HTML. Event video plays independently of Captivate's playbar, it has its dedicated control panel. You don't have to extend the slide duration to the length of the video as is the case for synchronized video.

You can always hide the Captivate playbar using a command on the On Enter event of that slide.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2018 0
Explorer ,
Aug 06, 2018

Copy link to clipboard

Copied

I can understand why you would think I was confusing the two, but I am not. I am currently hiding the captivate play bar. The captivate play bar is hidden (only on this slide) to force/require the learner to watch the auto-played video. The contents of screen shot 2 in my initial post was the overlayed skin's play bar appearing when I mouse over the video. Below is another view of the video's skin playbar in the html5 preview with the event video being moused over. As you can see in this new image, the captivate playbar is purposely hidden (only a border with curved corners surrounds the training).

html5Player2.png

To prioritize what I need in addition to what I already have:

  1. The video's skin play bar to show only play/pause as it does on the stage.
  2. No play bar overlay
  3. The play bar appears at all times with no hover required.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2018 0
Explorer ,
Aug 06, 2018

Copy link to clipboard

Copied

I just found this....

Is there a way to change the "Video" playback skin in Captivate 2017?

Pretty sure due to the fact that the video skins are swfs is my problem when viewing or previewing html5. It appears the video skin defaults to one player when published to html5 as a non-responsive course.

Bummer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2018 0
Most Valuable Participant ,
Aug 06, 2018

Copy link to clipboard

Copied

Sorry for my misunderstanding. It defaults indeed to the same playbar every time. I rarely use event video, find synchronized video easier to control. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2018 0
Explorer ,
Aug 06, 2018

Copy link to clipboard

Copied

I'm toying around with Synchronized now. I've used it before, but its now a different scenario. I just really need to not show the training skin's (progress bar) for this slide. I do display for the course, but I don;'t want it on this one video slide. Is there a way to disable it for this one slide or display a different course skin/playback control on one slide?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2018 0
Most Valuable Participant ,
Aug 06, 2018

Copy link to clipboard

Copied

Not really - I always create custom navigation because I rarely have pure linear projects and the playbar is confusing when you have branching.

You can hide the playbar as you did already, add a Next button with a timeline that starts shortly befor the end of the video. That way the user cannot proceed before having watched the video.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2018 0
Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

I took your advice to change this to synched video and adda custom playbar to fit our needs for this slide only. I thought I had it right, but it works in swf preview but not html5.

Here's what I have going on.

  1. This slide on enter executes advanced action with Hide Playbar and Continue.
  2. MP4 Video is now added as a synched video.
  3. Built a custom playbar to replay slide (ultimately the video), a pause/play toggle button, and a next button that appears at the end of the video to advance to the next slide. All built with smart shapes as buttons and each have rollover and down states.

This slide works fine in swf preview but does not work in html5. The entire screen goes white when this slide is reached.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Most Valuable Participant ,
Aug 07, 2018

Copy link to clipboard

Copied

How did you test HTML output?  Contrary to SWF output where the Preview options are pretty accurate, that is not the case of HTML output. You'll only see it really after publishing and uploading to a webserver.

You didn't need an advanced action On Enter. The simple action 'Hide Playbar) with the option 'Continue Playing ...4 checked would have been OK.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

I tested html output after pulishing to scorm 1.2/html5 and posting it to a moodle lms.

I then tested html5 preview in browser and found the same unwanted behavior. Probably not a good practice when I'm ultimately publishing html5, but most of my previewing in captivate is done by F10 next 5 slides in swf preview.

I just changed the on enter as you noted but still have same blank screen for this slide.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Most Valuable Participant ,
Aug 07, 2018

Copy link to clipboard

Copied

Only F11, Preview HTML in Browser will genearte a temporary HTML file, all other Preview methods are using a SWF, essentially unusable for the output you want.

This is weird. Something must be awry. What happens on the slide before the video slide? You don't have a pausing button on the master slide?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

2 things....

1.

Its hard to explain, but the behavior on this video has evolved some since dev started, but to the slide before it is just some narration talking about the video the user is about to watch. Then the narration says to click the play button, which just goes to the next slide where the video auto plays. This worked until the changes I made to make it a synched video and have its own little play bar.

2.

I duplicated the slide and hid one. Then I removed the custom playbar for this slide. The slide then worked using F11. Why would the custom replay, play, pause, and/or next button cause this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Most Valuable Participant ,
Aug 07, 2018

Copy link to clipboard

Copied

Check the timeline: take out the pausing points for all the buttons except for the Next button which appears only at the end of the video. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

So frustrating....

I removed the unneeded pauses from the play, pause and replay buttons, which were near the end of the slide, 1 second before the video finished. I also nudgged the buttons a few senconds after the start of the slide, and even nudged the video a 1/2 second from the start of the slide. No luck. If it could just work like it does in swf.....I'm going to reboot and try again. (Already cleared browser cache.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Most Valuable Participant ,
Aug 07, 2018

Copy link to clipboard

Copied

I didn't ask which browser you used for testing. JSON is enabled on the LMS? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

My primary browser is chrome, but i also reproduce this behavior in IE. (after system reboot)

I am not sure about JSON in LMS, I will do some digging, but I get the same behavior in Captivate's html5 in browser preview (F11).

I considered putting the captivate playbar back and removing the custom playbar, but the next button on this one slide is not acceptable.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Most Valuable Participant ,
Aug 08, 2018

Copy link to clipboard

Copied

I am really at a loss about what is going wrong on that slide, which must indeed be the case. I didn't try this out, but you could experiment with Hide Playbar, Delay Next Command…, Show playbar? However, the Delay command doesn't take into account possible pausing of the video.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2018 0
Explorer ,
Aug 08, 2018

Copy link to clipboard

Copied

Im starting to wonder if I did something wrong with the toggle on my play/pause, or if something wrong would even cause this (it still works in swf as planned, but thought I'd mention it to see if anything jumps out as being wrong)). If I remove the custom playbar, it works but I lose the ability to pause the slide and video.

Anyways, the toggle is worked like this:

Play button is set to be not visible in output

Pause button appears by default with an advanced action to pause the slide, hide the pause button, and show the play button

The play button's adv action is continue, hide play button. show pause button.

The play button and pause button appear in the same location, so they interchange on click.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2018 0
Most Valuable Participant ,
Aug 08, 2018

Copy link to clipboard

Copied

Could you post the preview of the action triggered by that toggle button? Oops, you don't have a toggle button.

I use a toggle button with an extra state for the Play state. The normal state has the Pause icon, the Play state has the Play icon.

The action to be triggered by that button is:

IF cpCmnd Pause is 0

    Change State of Btn to Play

    Pause

ELSE

    Change State of Btn to Normal

    Continue

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2018 0
Explorer ,
Aug 08, 2018

Copy link to clipboard

Copied

That is a nice little action that I will use in the future.

I did get it to work with the configuration I have, and not sure why it is fixed after what I did.

Since the issue was in the custom playbar I created, I decided to start taking the buttons out individually and testing after each removal.

I first removed my replay button. This is using an advanced action:

Expression, cpCmndGotoSlide=cpInfoCurrentSlide -1

Continue

Everything worked fine and I considered just eliminating the replay button so I could move on, but I reinserted the replay button, and it still worked in html5. Not sure why removing it and re-adding it fixed it, but it is working now. Thanks for your help. I guess this was a weird fluke?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2018 0
Lilybiri LATEST
Most Valuable Participant ,
Aug 08, 2018

Copy link to clipboard

Copied

Be careful with the Replay action! It is not always working fine for HTML output, and if you have an On Enter action you cannot even use it because you are not re-entering the slide. Here are some more links:

http://blog.lilybiri.com/replay-slide-button

http://blog.lilybiri.com/easy-timeline-tweaks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2018 0