Highlighted

export shows $$cpQuizInfoPointsscored$$ instead od value behind it

New Here ,
May 02, 2019

Copy link to clipboard

Copied

Hey there,

I'm working on a captivate project with a classic final multiple choice test in the end of the training.

On the results slide will be shown how many questions have been answered correctly using the $$cpQuizInfoPointsscored$$ variable.

No matter on which computer/browser I'm testing the training it shows the correct value behind the variable. Only when testing it in the clients LMS it shows $$cpQuizInfoPointsscored$$ instead of the value behind it (s. screenshot).

Any ideas how that can be and how to fix it?

Thank you for any help, Moritz

Unbenannt.PNG

Topics

Quizzing and LMS

Views

116

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

export shows $$cpQuizInfoPointsscored$$ instead od value behind it

New Here ,
May 02, 2019

Copy link to clipboard

Copied

Hey there,

I'm working on a captivate project with a classic final multiple choice test in the end of the training.

On the results slide will be shown how many questions have been answered correctly using the $$cpQuizInfoPointsscored$$ variable.

No matter on which computer/browser I'm testing the training it shows the correct value behind the variable. Only when testing it in the clients LMS it shows $$cpQuizInfoPointsscored$$ instead of the value behind it (s. screenshot).

Any ideas how that can be and how to fix it?

Thank you for any help, Moritz

Unbenannt.PNG

Topics

Quizzing and LMS

Views

117

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
May 02, 2019

Copy link to clipboard

Copied

You did need the variable cpQuizInfoTotalCorrectAnswers, not the score in points. Understand German, was already wondering why you used the score in that sentence.  But that doesn't explain why you don't see the value of the system variable.


Where is that score slide: after the quiz slides? Can you check Advanced Interaction Dialog panel (F9) to check if all questions are set to be included inthe Quiz Total?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 02, 2019

Copy link to clipboard

Copied

Hi Lilybiri,

thank you for your quick response!

So the score slide is the first slide after the 11 quiz slides.

In the Advanced Actions Dialog panel all quiz slides are included in the quiz.

It seems that on the customer's side only the succesful result is displayed in a wrong way with the $$cpQuizInfoPointsscored$$. The unsuccesful result shows the number of points/correct answers. The two result texts were both states of the same object: Unsuccesful = Normal state, Succesfull = New State 1. On slide entry the variable $$cpQuizInfoPointsscored$$ will be checked. If greater than 7 the state of the text will change to New state 1. Out of those two states I created now two individual texts and on entry no state will be changed but one of the texts will be hidden and the other one shown.

Also I changed all the $$cpQuizInfoPointsscored$$ to $$cpQuizInfoTotalCorrectAnswers$$.

I can't check locally if this is the solution for the problem because I couldnt reproduce it here anyway. But at least I was able to change something and report it to the client.

Thanks a lot!! Moritz

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
May 02, 2019

Copy link to clipboard

Copied

OK.  For debugging, insert the system variable in a text container on the first quiz slide and time it for the rest of the project. Test with Preview HTML in Browser and watch if the variable is correctly updating on each slide. I looked very careful if there were no typos, hope you inserted the variable using hte X button in the Character part?

Do you have a default score slide as well? Or is it hidden?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 02, 2019

Copy link to clipboard

Copied

This is the default score slide.

I put the text box with the variable (using the X-Button) on every quiz slide and it counts every correct answer.

I hope its going to work as it is now...

Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Lilybiri LATEST
Most Valuable Participant ,
May 02, 2019

Copy link to clipboard

Copied

Did you delete the Continue button, which is an embedded object?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Captivate User Guide
New Group