Generating TTS Crashes Captivate 7

Contributor ,
Jan 22, 2014 Jan 22, 2014

Copy link to clipboard

Copied

I'm working with another developer and she is having trouble generating TTS. Every time she tries, Captivate crashes. She has uninstalled and reinstalled Captivate per Adobe's recommendation. Nothing seems to fix the problem.  The thing is, she can send me the cptx file she created, and I can generate the TTS with no trouble at all. This indicates to me that it isn't something in the way she has written and/or copied the slide notes, but rather something with how Captivate is installed.

Has anyone run into this issue? It's a real problem, and it delaying a lot of our projects.

Any help would be appreciated!

Thanks.

Views

2.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 22, 2014 Jan 22, 2014

Copy link to clipboard

Copied

Hello,

Welcome to Adobe Forums.

Are you working on a MAC or Windows computer ?

Make sure you have Captivate 7.0.1 update installed.

Which voice crashes captivate?

Is that specific to a project or with a blank project ?

Thanks,

Vikram

Adobe Support

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 22, 2014 Jan 22, 2014

Copy link to clipboard

Copied

Hi Vikram,

In answer to your questions:

Windows 7

7.0.1 is installed

Bridget and Paul

It's happening in every project.

Any suggestions?

Thanks,

Elizabeth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2014 Jan 22, 2014

Copy link to clipboard

Copied

Since you mention that your other developer has recently reinstalled Captivate and also installed updates it is possible she has not removed the older Preferences folders.

See troubleshooting tip #8 in this list:

http://www.infosemantics.com.au/adobe-captivate-troubleshooting/basic-troubleshooting-techniques

She may also need to clear her project cache.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 23, 2014 Jan 23, 2014

Copy link to clipboard

Copied

Please follow these troubleshooting steps :

1) Make sure Adobe Captivate 7 is closed

2) Go to this location : C:\Users\[user name]\AppData\Roaming\Adobe folder

3) Rename "Adobe Captivate 7.0" to "1234"

4) Launch Adobe Captivate 7

Try to generate TTS again

Thanks,

Vikram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2014 Jan 31, 2014

Copy link to clipboard

Copied

I am having the same problem with Bridget. I can get one slide or two generated into audio and then captivate crashes. I have tried the fix of changing the folder names, reopening Captivate and the problem reappears.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 03, 2014 Feb 03, 2014

Copy link to clipboard

Copied

Hello,

Does it happen on a specific project or with a blank project as well ?

Thanks,

Vikram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2014 Feb 03, 2014

Copy link to clipboard

Copied

Hi Vikram,

I'm the developer in question, so I thought I'd jump and chat with you directly.

I've now tested from a "clean slate." I created a brand new project with virtually nothing in it. I added slide notes and generated TTS first in Anna. That was fine. Then I changed all TTS to Paul and regenerated. Also fine. Then I changed all to Bridget and attempted to regenerated. Captivate crashed.

Also, in existing projects, I cannot generate TTS in Bridget. I can pass the file to another developer, they can generate for me. But if I change the slide notes, I can't regenerate in Bridget. I have to use another voice.

I should also mention that on this particular machine, I do NOT have any older versions of Captivate. The install of 7.0.1 was the very first version of Captivate ever loaded on this PC.

Any thoughts?

Thanks,

Bettina

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2014 Feb 06, 2014

Copy link to clipboard

Copied

YES!  I have also had this problem.  I've spent hours and hours on the phone w- tech support but have not found a solution other than "don't use Bridget".  I do NOT have the same issues with Paul.

We have also tested this on a brand new machine and I can make Bridget fail in about 5 slides.  Here's how:  Open a new project.  Don't bother to even add anything to the slide.  Add  future TTS text in a simple phrase. (I use:  "The quick brown fox.")  Now copy and paste the slide a dozen times.  Then start recording each slide separately.  It will work the first few times, then crash not later than slide 6.

Hope this helps.  Our European learners definitely prefer Bridget's accent, and I'd like a real solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 06, 2014 Feb 06, 2014

Copy link to clipboard

Copied

Are you using a 64bit version of Captivate but have Bridget installed as a 32 bit?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2014 Feb 07, 2014

Copy link to clipboard

Copied

both Captivate7 and Bridget are 32 bit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2014 Feb 07, 2014

Copy link to clipboard

Copied

I had the 32-bit version installed for both.

So here's another strange twist. I was using the same project and making changes to fit my need. I would edit slide text and go to regenerate the audio using Bridget's voice. The first bunch of times, Captivate crashed constantly as we've discussed.

However, a few days later I continued with the project and it worked fine. I have not had any more problems. Nothing changed - no installed updates or anything. After I finished the initial project I tried creating a new project, added three slides with notes, generated the audio, and still no problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2014 Feb 07, 2014

Copy link to clipboard

Copied

LIke the others, I am running a 32-bit O/S, version of Captivate, and Bridget. I can only conclude that 32-bit Bridget is possessed. As my colleague mentioned at the beginning of this thread, when I pass the .cptx to her, she can generate TTS without incident. She's running 64-bit.

As JDMHM states above, I experience crashing when generating Bridget, but then I'll go back later, and can maybe generate TTS for 4 or 5 slide, but then it ALWAYS crashes again. The problem has never miraculously disappeared.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2014 Mar 24, 2014

Copy link to clipboard

Copied

Was there any resolve to this issue?  I am having the same problem with Paul.  I am running Mavericks, patch installed.  How do I find out if I'm running 32-bit or 64-bit?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Mar 24, 2014 Mar 24, 2014

Copy link to clipboard

Copied

Remove any special characters in the script and try.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2014 Mar 25, 2014

Copy link to clipboard

Copied

So I removed the special characters and got farther.  I got to 33% and then error message "Error occurred while generating Text to Speech Audio.  Generated audio may not be correct  for [name of file]".  But to audio seemed ok.  This occurred for about 3-4 slides and then back to an immediate crash as soon as I clicked on the Text to Speech button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 25, 2014 Mar 25, 2014

Copy link to clipboard

Copied

Check these troubleshooting tips (especially #8 about the Preferences folder):

http://www.infosemantics.com.au/adobe-captivate-troubleshooting/basic-troubleshooting-techniques

If none work, check your setup is as recommended:

http://www.infosemantics.com.au/adobe-captivate-troubleshooting/setting-up-your-computer-to-work-wit...

If that's OK.Try reinstalling Captivate and all TTS voices.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2014 Mar 25, 2014

Copy link to clipboard

Copied

Hi Rod, 

Thanks!  First, I did read your first link a few days ago, but I don't have a library folder they discuss to find the preferences folder -

Apple MAC: /Users/[user]/Library/Preferences/Adobe Captivate 6

I have no idea how or where to find a preferences folder.

Second,  I'm using a Mac, so no "run as administrator" option.

I'm so unbelieveably frustrated with Adobe right now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 25, 2014 Mar 25, 2014

Copy link to clipboard

Copied

I can't help you with MAC issues much.  Never touch the stuff.

To reset the Preferences folder though, even on a MAC, try executing the batch file in the Cp install directory under utils folder.  There should be a batch file there called CleanPreferencesMac.  It will know where your Preferences folder is located and will give it a reset.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2014 Mar 25, 2014

Copy link to clipboard

Copied

Well, it looked good for about 3 slides, then crashed again.  I'll try the step above and see if it will work for another 3 slides.  It would be a slow and long road, but I'll be happy if I can get my project completed.  Thanks!

For the step above, I had to show invisible files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 25, 2014 Mar 25, 2014

Copy link to clipboard

Copied

Are you working on projects saved to your hard drive or a network LAN drive?  Is it possible that your user profile is being stored anywhere other than on your local hard drive?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 28, 2014 Nov 28, 2014

Copy link to clipboard

Copied

For what it is still worth:

In Finder, hold alt and click on "Go" in the menubar at the top of your screen (or other way around, it doesn't matter).

You'll see "Library" appear. There's where you should be.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

Back to Captivate after several years away because of all the issues affecting it. Using a fresh install of Captivate 7 and running into the same problem as documented in the post above from January (it's now 3 months later! from the original post of the issue!!).

Captivate 7 crashes straight to the Mac desktop when trying to generate audio with the Paul voice.

It seems to be one thing after another with Captivate and there appears no sense of urgency from Adobe to fix things. This is why I changed over the Storyline. Sure Storyline crashes (but nothing like Captivate) but at least you get the feeling that the developers will try and sort out problems.

I've been using Captivate since version 2 and the real issue is you get major problems that strike seemingly at random losing you hours or days of work. You gradually adopt habits of working with it to avoid problems, like saving all the time, not using animated text etc. etc.

Support is abysmal, usually you have to resort to these forums for help as if Captivate were some open source hack job instead of software which typically my employers have spent several thousands pounds on over the years.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 27, 2014 Mar 27, 2014

Copy link to clipboard

Copied

Feel better now?

Chin up.  It's Friday.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2014 Mar 28, 2014

Copy link to clipboard

Copied

This issue of TTS voices crashing Captivate was flagged back in 2012 (http://forums.adobe.com/message/5778689). As the last message in the thread says "The crash or freeze seems to be the result of adding text that contains extraneous control characters, or any non-ASCII characters. Running any text you want to use for text-to-speech through something like TextWrangler (free) that will "zap" these "Gremlins", will prevent those issues. Of course it would be a lot simpler if the Captivate developers would just acknowledge and then fix the problem."

My Captivate was crashing (and when I say crash I mean sudden quit, no option to save, no freeze) when I typed text into a Text box and then copied and pasted the text into the Notes area prior to converting to TTS with the Paul voice. It seems the ' character was causing the problem, although it could also be some hidden formatting in the Text box doing this was well.

By going the other way round and typing text into the notes area, converting to TTS and then copying the text into the Text box on the screen seems to have avoided the crash.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines