Highlighted

How to change button state in Cap 8

Explorer ,
Jul 01, 2018

Copy link to clipboard

Copied

Hi, All,

I have searched the forum but can't find an answer, so I thought I'd ask here.

I am using Captivate 8 (I know, it's old--but it's what I've got!). I have a piano keyboard image and a smart shape over some keys. If they click on/play the note I want them to play, audio is triggered (that's working great). If they click on/play the note I don't want them to play, a text caption appears telling them to try again (also working great). I have set the shapes to 0% opacity and the line width to zero, so the boxes can't be seen--until the mouse hovers and clicks. This is a problem because the smart shapes covering the incorrect choices were drawn with the polygon tool, and the borders are uneven. Uneven borders are necessary because of the shape of the keys (black keys/white keys are not perfect rectangles), but it looks unprofessional when the mouse hovers on them.

How can I change the settings or properties so that the smart shape does NOT show up when the mouse hovers or clicks on them? Is that possible in Cap. 8?

Thanks,

Kris

Views

97

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to change button state in Cap 8

Explorer ,
Jul 01, 2018

Copy link to clipboard

Copied

Hi, All,

I have searched the forum but can't find an answer, so I thought I'd ask here.

I am using Captivate 8 (I know, it's old--but it's what I've got!). I have a piano keyboard image and a smart shape over some keys. If they click on/play the note I want them to play, audio is triggered (that's working great). If they click on/play the note I don't want them to play, a text caption appears telling them to try again (also working great). I have set the shapes to 0% opacity and the line width to zero, so the boxes can't be seen--until the mouse hovers and clicks. This is a problem because the smart shapes covering the incorrect choices were drawn with the polygon tool, and the borders are uneven. Uneven borders are necessary because of the shape of the keys (black keys/white keys are not perfect rectangles), but it looks unprofessional when the mouse hovers on them.

How can I change the settings or properties so that the smart shape does NOT show up when the mouse hovers or clicks on them? Is that possible in Cap. 8?

Thanks,

Kris

Views

98

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 01, 2018 0
Lilybiri LATEST
Most Valuable Participant ,
Jul 01, 2018

Copy link to clipboard

Copied

I don't have CP8 anymore, but if my memory is correct, you should be able to change the states (Normal, Rollover and Down) in the Object Style Manager. Create an object style for those buttons and make all the states 'invisible' like you already did for the Normal state. Have a vague memory that it was also possible to deactivate rollover and down states, but cannot remember how, sorry about that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2018 0