How to stop multiple choice quiz slide from auto advancing

Community Beginner ,
Feb 16, 2021 Feb 16, 2021

Copy link to clipboard

Copied

In my Captivate project I have 5 "pretest" multiple choice questions. Then I have drag/drop and fill-in-the-blank questions in the middle. Those questions all work as intended. Now I am creating one multiple choice question slide at the very end of my Captivate project, and it is not working as intended.

 

This is what I did:

I added 1 graded multiple choice slide.

In the "Quiz" tab, I enable: Captions > Correct; Buttons > Back; Buttons > Skip; On Success > Continue; Infinite attempts; Retry message; Failure Messages > None. 

In each multiple choice answer choice, I copied and pasted text from my other questions such that the font and colors match.

 

When I publish my project and test this slide, I select the correct answer choice and click "Submit". The text that says "Correct - click anywhere or press 'y' to continue" does NOT appear. Nothing pops up, and the next slide is shown after ~1 second. I am pretty sure that I have this question set up exactly the same as all my other MC questions; however, I can't get it to stop automatically advancing to the next slide whenever the learner clicks "Submit".

Views

90

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Are you sure you still have the Correct message selected? Because you have a pretty strange setup for that quiz slide. If all messages are deselected you tell Captivate to skip the first step of the Submit Process. 

Why strange: Back button is not very useful on quiz slides. It may work here because there is only one but it is very frustrating for the learner when having such a button, going to a previous question slides and then detect they are blocked. You tell it is a scored quiz slide but you allow the Skip button? 

Another possibility may be that you did delete one or more embedded objects, either on the master slide or on the quiz slide. 

Maybe this post, part of a sequence about default quiz setup can help:

Captivate's Quizzes (2): Submit Process - eLearning (adobe.com)

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

The "Correct" checkbox is selected. I used the same process for this last question as all the earlier MC questions, so I am still confused as to why it auto-advances.

 

If I did a pretest question, then the question would be forced to be grouped with my other pretest questions. If I did a survey question, then there wouldn't be a correct answer for the learner to select. I just want a question that has a correct answer, but the learner has the freedom to skip and go back if they want. I have hidden the "Quiz Results" slide at the end because I do not want the learner to worry about scoring.

 

My second to last question is a drag and drop question. The problem with Captivate auto-advancing starts with this question. Could the fact that a drag-and-drop question is before my last MC question be a problem?

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

LATEST

There is no relation between D&D question and other questions. There must be another reason. 

I asked '...may be that you did delete one or more embedded objects, either on the master slide or on the quiz slide' Is that perhaps the case?

What happens if you delete the question slides and recreate it? Did you keep the field 'Required' set to its default 'Optional....'?

Even though the Results slide is hidden, it still has its functionality. You need to have at least one slide after the results slide.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines