Highlighted

HTML5 isn't autoplaying

New Here ,
May 01, 2013

Copy link to clipboard

Copied

When I publish a file as HTML5, it doesn't autoplay.  It is a white screen with a play button in the middle of it.  How can I create the course file so that it autoplays as with a swf output?

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

HTML5 isn't autoplaying

New Here ,
May 01, 2013

Copy link to clipboard

Copied

When I publish a file as HTML5, it doesn't autoplay.  It is a white screen with a play button in the middle of it.  How can I create the course file so that it autoplays as with a swf output?

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 01, 2013 0
Advisor ,
May 01, 2013

Copy link to clipboard

Copied

Hi there,

Please check this forum thread:

http://forums.adobe.com/message/4587553#4587553#4587553

It seems like a work around.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 01, 2013 0
New Here ,
May 01, 2013

Copy link to clipboard

Copied

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 01, 2013 0
New Here ,
May 03, 2018

Copy link to clipboard

Copied

Just takes me back to the forum home. Looks like someone removed it.

Let me add that my OLD content (made with a previous version of 2017) still autoplays. So it's not the browsers. It's something captivate is doing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 03, 2018 0
Adobe Employee ,
May 04, 2018

Copy link to clipboard

Copied

Hi,

 

This is introduced in the latest update of Captivate 2017. Please check the following link for more information: https://helpx.adobe.com/captivate/kb/captivate-responsive-courses-not-autoplay-browsers.html

 

Regards,

Mayank

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2018 0
New Here ,
May 04, 2018

Copy link to clipboard

Copied

So why even have it as an option in the project settings? Remove it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2018 0
Explorer ,
May 04, 2018

Copy link to clipboard

Copied

Hi!

As I understood, CPM.js is responsible for autoplay.

Is it possible to edit something there to switch autoplay on?

Regards

KV

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2018 0
Adobe Employee ,
May 04, 2018

Copy link to clipboard

Copied

Hi,

Autoplay will work for SWF output hence it is available in the project settings.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2018 0
Explorer ,
May 06, 2018

Copy link to clipboard

Copied

Hi!

Thank you for the answer.

We use HTML5 output.

Is it possible to have somehow the same functionality as before to start learning courses automatically?

Regards

KV

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2018 0
Adobe Community Professional ,
May 07, 2018

Copy link to clipboard

Copied

KV,

Note the comment in the Adobe Help page linked earlier in this thread:

Due to some recent browser updates, all modern web browsers have discontinued auto-playing media in web pages. Similarly, HTML5 and responsive courses created in Captivate will not auto-play. Autoplaying is not honored even after enabling the option Auto Play in Preferences > Project > Start and End.

While SWF videos will continue to auto-play, HTML5 and other responsive courses will not auto-play.

So, I think what the earlier posts in this thread are telling you is that we all need to get used to the idea that HTML5 content is NOT going to autoplay.  Even if it WERE possible to configure this in Captivate, autoplay would ONLY work in some browsers (i.e. only older ones) and not the newer versions.  So gradually we will see all web browsers eventually make it impossible to have auto play.  Captivate is not creating this issue or driving this change.  It's being driven by the web browser manufacturers in the interest of providing a better experience to all web browser users..  We in the development community don't really have much of a choice.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 1
Explorer ,
May 07, 2018

Copy link to clipboard

Copied

Hi!

Thank you for the answer.

Our old courses work well from the previous version of the Captivate 2017 (10.0.0)

with updated version of browsers. We use AdobePrime.

After the Captivate update to 10.0.1 the publish result files changed:

1) project.txt --- only info about the new version

2) SCORM_utilities.js --- a new link to install AdobeFlashPalyer

3) assets\js\CPM.js --- new data

4) assets\js\CPXHRLoader.js --- new data, doesn't influence to autoplay

So, I decided, the file CPM.js influences to autoplay (not only variable, but the whole functionality).

The main question: is it possible to fix this feature somehow and switch on loading functions back?

Regards

KV

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2018 0
Explorer ,
May 09, 2018

Copy link to clipboard

Copied

Hi!

Are there some experts, who found a solution?

Is it possible to fix this bug?

Regards

KV

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2018 0
Most Valuable Participant ,
May 09, 2018

Copy link to clipboard

Copied

Sorry, this is not a bug, this is something decided by webbrowsers like Chrome and browsers on mobile devices.
AutoPlay was already disabled for mobile devices in previous versions of Captivate, for that reason. Since Chrome (and others will probably folllow) decided to ban Autoplay for websites, and cannot distinguish websites from eLearning running in a browser, you could perhaps try to post this request to Google?

Welcome to the non-standardized world of HTML.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2018 0
Explorer ,
May 09, 2018

Copy link to clipboard

Copied

Hi!

thank you for the answer, I watched much videos from your site.

If it is not a bug, why all our courses published from previous version work with autoplay successfully in the updated Chrome?

It seems, the new Captivate blocks the loading of the project. There is a reason to analyse 10000 stings of CPM.js code. Maybe somebody knows about it's functionality.

In my opinion the html-rule to give users a possibility to make a choice autoplay or not is a right idea,

but the captivate users do it inside of the Captivate. It was fine before, and I don't see any troubles between version 10.0.0 and modern browser rules.

Suppose the bug/feature/unknown will be fix in the future.

At the moment we use old version 10.0.0.

Regards

KV

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2018 0
Most Valuable Participant ,
May 09, 2018

Copy link to clipboard

Copied

Totally agree that the developer should decide. For that same reason I dislike the Newbie UI of Captivate where I would be controlled by the application instead of controlling it myself.

BTW I never have videos on my blog, only interactive movies. Another (probably unusual) dislike: passive video is not the most efficient eLearning asset, conclusion based on many years of coaching software (and other) classes for adults. Easy to make, passive video compared with interactive movies...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2018 0
Explorer ,
May 09, 2018

Copy link to clipboard

Copied

Yes, interactive movie is a right word and I agree, the interactivity is a great step from the passive video.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2018 0
Most Valuable Participant ,
May 09, 2018

Copy link to clipboard

Copied

Thanks.

BTW I launched a discussion in the Community, to ask for help about feature requests to improve the static screen for HTML courses where AutoPlay is turned off (still fear this will be default everywhere in the future):

Cope with Autoplay Off

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2018 1
New Here ,
Jun 14, 2018

Copy link to clipboard

Copied

My team currently uses both Captivate and Storyline because we are determining which we will use going forward as our authoring tool.  I've created the same project in both programs and have published them in HTML5.  The Captivate output does not autoplay while the Storyline output does.  I'm using the same browser side by side in two tabs.  If Chrome isn't allowing HTML5 content to autoplay, why does that change only affect Captivate's output and not Storyline's?  It might seem like a small quality of life issue for the end user, but it is a large enough issue to make staying with Captivate a little less appealing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2018 0
Most Valuable Participant ,
Jun 14, 2018

Copy link to clipboard

Copied

Maybe because Storyline's output is not a full HTML output? SL cannot create real responsive projects, does it create HTML projects or are they just playing in a HTML wrapper?  AutoPlay is disabled since quite a while on some mobile devices as well.  Is it not looking weird that Chrome blocks all HTML content from AutoPlay but SL will play? That sounds bit suspicious. How will this be in the future with other browsers?

Look at the whole picture, please! I see many SL users come (back) to Captivate.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2018 0
New Here ,
Jun 14, 2018

Copy link to clipboard

Copied

I’m using Storyline 3 for my production and yes it outputs full HTML5 as well as fully responsive playback on multiple devices. I’m not trying to start an arguemwnt about Captivate and Storyline. I’m simply saying that, as of right now, Storyline 3 or Storyline 360 has autoplaying HTML5 projects while the newest update to Captivate does not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2018 0
Adobe Community Professional ,
Jun 14, 2018

Copy link to clipboard

Copied

I am also using Storyline 360 at a current client.  Yes it does publish to HTML5.  That fact should not be disputed.  However, it DOES NOT publish "fully responsive" HTML5 content.  Its content is SCALABLE HTML5.  There's a big difference between the two and Articulate has been forced to admit (on their own forums) that they've been somewhat overly liberal with the use of the term "responsive" in their marketing blurb for Storyline.

The current version of Captivate disables Autoplay by default.  (Previous versions had it ENABLED by default.)  If you are publishing your current content with Captivate, and your end users will all be using browsers that still support Autoplay of multimedia content, then you should try selecting the AutoPlay option in Captivate to see if that then allows it to work for you.

As for Storyline, even though it might still have AutoPlay enabled, your end users that view the output on browsers where autoplay has been disabled will still have the same issue.  This particular issue isn't going to go away.  The browser manufacturers themselves are driving this, not Adobe.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2018 0
Lilybiri LATEST
Most Valuable Participant ,
Jun 15, 2018

Copy link to clipboard

Copied

@Rod thanks for supporting, you have lot more experience with StoryLine which I dumped in favour of Lectora and Captivate.

To expand on the subject:

It is a common strategy of vendors to omit information, which is understandable and can be accepted....

What I cannot accept, but that is a personal opinion of course, is that vendors abuse the ignorance of buyers to tell 'lies'. That is the case here. To stay with the car metaphor: a vendor who tries to sell that self-parking car as a self-driving car is lying for me. In this case the name 'responsive' is used to indicate a 'rescalable' project which is a lot easier to create and develop. A real responsive project allows the developer to simplify the content and layout of the course to 'respond" if smaller browser resolutions are used like is the case on tablets and smartphones: omission of not stricttly necessary items (looking great on big screens), replacing complicated grahpics by simple icons, videos by images etc. Ask SL if they can develop such a responsive project as is the correct name exisitng since many years for websites? In between the rescalable and fully responsive projects, there is sort of a hybird solution, labeled Flud Boxes in Captivate, where the layout can be canged by the application, unnecessary objects can be dumped for small screens, but the replacement of items is not possible. If you want to see examples and have some more info, look at my blog post, whcih also has links to published example files:

Fluid Boxes Or Breakpoint Views? - Captivate blog

Car metaphor: fuel only based cars, hybrid cars and purely electric cars.

As for the Browser AutoPlay problem: would you believe that a car can convert a dirt road (browser) into a paved road (Autoplay enabled)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2018 0