Highlighted

HTML5 with AutoPlay not working… and "Play " button does not even appear

Explorer ,
Sep 18, 2018

Copy link to clipboard

Copied

There has been a lot of discussions around the autoplay not functioning in videos made by Captivate 2019.

Since then I was playing with swf content and decided this year to move on to html5.

I ran into the same problem but the situation seems worse: on most of my videos I don't even have that play button !

I saw the workaround evoked by Lilybiri but no solution there for me.

There is just a wheel turning endlessly. So all my videos are off and 400 students waiting for these.

Go back to Flash and tell the students to install it, really ?

Absolutely any help wanted.

TIA,

Serge

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Do you have FMR slides in the Sims?

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

HTML5 with AutoPlay not working… and "Play " button does not even appear

Explorer ,
Sep 18, 2018

Copy link to clipboard

Copied

There has been a lot of discussions around the autoplay not functioning in videos made by Captivate 2019.

Since then I was playing with swf content and decided this year to move on to html5.

I ran into the same problem but the situation seems worse: on most of my videos I don't even have that play button !

I saw the workaround evoked by Lilybiri but no solution there for me.

There is just a wheel turning endlessly. So all my videos are off and 400 students waiting for these.

Go back to Flash and tell the students to install it, really ?

Absolutely any help wanted.

TIA,

Serge

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Do you have FMR slides in the Sims?

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 18, 2018

Copy link to clipboard

Copied

Need more information:

  • What version of Captivate were these projects originally published in?
  • Are you publishing to SCORM for an LMS or just a web server?
  • If you are now publishing to HTML5 and these projects were NOT previously HTML5, is your web server or LMS configured to allow JSON files?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 18, 2018

Copy link to clipboard

Copied

- Version 6, then 8 was used for most of them.

- It is Scorm 1.2 on a Moodle 3 LMS server.

For the last question Javascript Object Notation seems activated (I just found it in data formats) but I'll try Moodle forums to understand better the implications of that.

Strangely I just tried 2 videos, 1 failed, 1 succeded but why ? I can't figure out the difference. I continue on that way.

If anyone wants the files I can give them.

Thanks a lot, I really appreciate your help.

Serge

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 19, 2018

Copy link to clipboard

Copied

Each browser has different rules around when it will block autoplay and when it won't.  I appreciate it's confusing, but I recommend you do some Googling on it to better understand the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 19, 2018

Copy link to clipboard

Copied

Absolutely no browser works anyhow for those videos. But it seems to be a Moodle Server issue, as it is functioning on another Moodle server. I'm try to see the errors on ScormCloud but nothing seems relevant between videos working or not working

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 19, 2018

Copy link to clipboard

Copied

Don't be too quick to judge.  You MAY be correct, but the browsers are also now taking into account user behaviours on different domains.  So if these two different Moodle servers are on different domains, the browsers may be treating the situation differently until their algorithms decide otherwise.  You may find that one day the domain that seemed to be 'behaving' suddenly seems to change and act more like the other one.  It's a complicated issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 19, 2018

Copy link to clipboard

Copied

Thank you Rod,

as I go through the process of debugging I see now that the scorm files that have problem are those with a simulation ; the simple video demo files do not have problems in HTML5.

We are in a very different perspective here.

I'll tell if I find any logic explanation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Sep 19, 2018

Copy link to clipboard

Copied

Do you have FMR slides in the Sims?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 19, 2018

Copy link to clipboard

Copied

Yes - and as I googled for this, not knowing the acronym, I saw other threads saying there is a problem between FMR and html5, isn't it?

Thank you for pointing this!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 19, 2018

Copy link to clipboard

Copied

The issue is that FMR would normally be converted to SWF at publish time.  But SWF is incompatible with HTML5.  So your FMR slides need to be replaced with Video Demo so that the result is a small MP4 video at that point.  MP4 is compatible with HTML5.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Lilybiri LATEST
Most Valuable Participant ,
Sep 19, 2018

Copy link to clipboard

Copied

My workflow is to stop the sim when I expect that a motion slide is needed. I then insert a Video Demo slide to resplace the FMR slide. Then I continue inserting more recording sim slides.  It is a cumbersome workflow which I hped would have changed with the most recent release. Please log a feature request, I did that already several times.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Sep 18, 2018

Copy link to clipboard

Copied

Adding to Rod"s suggestions:

Does the server or the LMS support JSON?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...