Highlighted

Image Won't Advance to Next State in HTML5 Preview

New Here ,
Mar 10, 2020

Copy link to clipboard

Copied

Hello,

I am a complete newbie to Captivate. Is there a reason that an advanced action including "Go to Next State" for an image would not work in HTML5? the action also includes the command to "Go to Next Slide," and that part is working.

 

I attempted a game show style activity where each correct answer would increase the score on the scoreboard. I made the images of the scoreboard at each point interval, then loaded them in as states of the original scoreboard. For each correct answer (button), the advanced action is set to make those scoreboard images "Go to Next State" as well as advance to the next question.

 

It worked perfectly in preview, however, when previewing in HTML5 and publishing, it is not functioning. The original scoreboard remains and correct answers will not advance the image to the next state.

 

I am in Captivate19. I'm hoping there is a glaring mistake that my lack of experience can't see and that this is a simple fix.

 

Thanks in advance!

Caryn

 

 

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Image Won't Advance to Next State in HTML5 Preview

New Here ,
Mar 10, 2020

Copy link to clipboard

Copied

Hello,

I am a complete newbie to Captivate. Is there a reason that an advanced action including "Go to Next State" for an image would not work in HTML5? the action also includes the command to "Go to Next Slide," and that part is working.

 

I attempted a game show style activity where each correct answer would increase the score on the scoreboard. I made the images of the scoreboard at each point interval, then loaded them in as states of the original scoreboard. For each correct answer (button), the advanced action is set to make those scoreboard images "Go to Next State" as well as advance to the next question.

 

It worked perfectly in preview, however, when previewing in HTML5 and publishing, it is not functioning. The original scoreboard remains and correct answers will not advance the image to the next state.

 

I am in Captivate19. I'm hoping there is a glaring mistake that my lack of experience can't see and that this is a simple fix.

 

Thanks in advance!

Caryn

 

 

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 10, 2020 0
Most Valuable Participant ,
Mar 10, 2020

Copy link to clipboard

Copied

Captivate's most recent version is 11.5. Can you please check the exact version number under Help, About Captivate?

 

Can you insert a screenshot of the Preview Advanced Action which you use, and tell which event you are using to trigger it?  Need to see the logic You can change state for a multi-state object when you are on another slide with an advanced action, that is not the issue.

Preview project uses a temporary SWF output in a non-responsive project, not useful anymore. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 10, 2020 0
New Here ,
Mar 10, 2020

Copy link to clipboard

Copied

Thank you, Lily.

 

I am using 11.0.0.243. I am waiting on being updated, but I work in a public service entity so there is a wait.

 

Here is an example of a question slide. Any of the three incorrect answers just advance to the next question. The following image are the states showing the point total going up, followed by my advanced action.

 

The purpose was that each correct answer would add points; no loss of points for incorrect answers. If there is a known way to do this simpler, I would take any suggestions!

 

Thank you so much for looking at this.

 

Screenshot Millionaire game.png

 

state view.png

 

advanced action.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 10, 2020 0
Most Valuable Participant ,
Mar 10, 2020

Copy link to clipboard

Copied

Easiest way would be to use default quiz slides, Multichoice questions. Why create custom questions since you are a newbie?  I would never creaet a scoreboard using states, but use a variable which you can insert in any text container, and will update when you increase the score by an action.  

Even if you do not use custom question slides, attach a score to the correct button. If you set it to be reported, it will be automacally included in the quizzing system variables. 

Why make such a complicated setup which could work if you know indeed the advanced/shared actions really well.  Have more than 10 years of experience with all types of use cases, and my blog shows it very well. 

 

My recommendation: use MCQ questions. If you want to show a popup on the quiz slide, read one of my articles (have at least 50 about quizzes and custom questions):

http://blog.lilybiri.com/popups-on-quiz-slides

 

Indeed the version you have is even without the bug patch to 11.0.1.266, and also of course to 11.5.1.499. 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 10, 2020 0
New Here ,
Mar 11, 2020

Copy link to clipboard

Copied

Thanks for the recommendations. 

 

An MCQ will not meet my needs so I will look into learning to use the variables as you suggested.

 

My main question was related to states not showing up in HTML5. I don't understand why they wouldn't. Maybe the problem I am having isn't related.  

 

Thanks again! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2020 0
Lilybiri LATEST
Most Valuable Participant ,
Mar 11, 2020

Copy link to clipboard

Copied

Have too little information to tell you why they do not show, because that is not a normal behavior. I am using multi-state objects all the time and never had that type of problem. But you unnecessarily complicate the setup, even if you want a customm question slide. Insert a variable, no need to have a new score in a new state of an item at all. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2020 0