Highlighted

Installing a previous version of Captivate

New Here ,
Nov 15, 2018

Copy link to clipboard

Copied

With 2019 (v11) just released, that's the only version available to purchase.  We have clients that require us to build in previous versions (2017 / v10) for the current case.

I talked to Adobe support and found out two things:

1. The subscription model only allows the use of the current version.  So now it's 2019, no 2017.

2. They just changed the policy on perpetual licenses, so if you buy a license of 2019, you can no longer call support and request a previous version serial number.

Any one have any insight on this?  It really messes up consulting companies and freelancers as clients we may be building for hold off on upgrades quite often and require using a previous version, and if we don't already have it or add staff, can get them a license to perform the work. 

I know the creative could suite can load previous versions for items like photoshop etc, curious why captivate won't.

This is a little crazy, i'm sitting here needing to spend money with Adobe and they don't have the ability to sell me Captivate 2017.

Thanks for any help,

-jim

Views

191

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Installing a previous version of Captivate

New Here ,
Nov 15, 2018

Copy link to clipboard

Copied

With 2019 (v11) just released, that's the only version available to purchase.  We have clients that require us to build in previous versions (2017 / v10) for the current case.

I talked to Adobe support and found out two things:

1. The subscription model only allows the use of the current version.  So now it's 2019, no 2017.

2. They just changed the policy on perpetual licenses, so if you buy a license of 2019, you can no longer call support and request a previous version serial number.

Any one have any insight on this?  It really messes up consulting companies and freelancers as clients we may be building for hold off on upgrades quite often and require using a previous version, and if we don't already have it or add staff, can get them a license to perform the work. 

I know the creative could suite can load previous versions for items like photoshop etc, curious why captivate won't.

This is a little crazy, i'm sitting here needing to spend money with Adobe and they don't have the ability to sell me Captivate 2017.

Thanks for any help,

-jim

Views

192

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Nov 16, 2018

Copy link to clipboard

Copied

Hello,

I have sent a Private Message to you. Kindly check and reply with the details requested.

Regards,

Deep

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Lilybiri LATEST
Most Valuable Participant ,
Nov 16, 2018

Copy link to clipboard

Copied

I asked the staff to contact you, please answer the Private Message which you got.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...