Highlighted

Interactive video pauses after first overlay

New Here ,
Apr 09, 2019

Copy link to clipboard

Copied

I have one local video on a slide, and two overlay slides with a knowledge check question on each. On success of each question I'm running an advanced action to assign a value to a variable and then continuing. On failure, I have "continue" selected as Last Attempt action. When I preview the course, the video plays and shows the first overlay with the first knowledge check question, but regardless of whether I get the question right or wrong, the screen freezes and doesn't continue. Any suggestions what could cause this? I'm using Captivate 2019. Thanks!

Edited to add: sometimes the overlays don't show at all - the video pauses but nothing happens.

Views

542

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Interactive video pauses after first overlay

New Here ,
Apr 09, 2019

Copy link to clipboard

Copied

I have one local video on a slide, and two overlay slides with a knowledge check question on each. On success of each question I'm running an advanced action to assign a value to a variable and then continuing. On failure, I have "continue" selected as Last Attempt action. When I preview the course, the video plays and shows the first overlay with the first knowledge check question, but regardless of whether I get the question right or wrong, the screen freezes and doesn't continue. Any suggestions what could cause this? I'm using Captivate 2019. Thanks!

Edited to add: sometimes the overlays don't show at all - the video pauses but nothing happens.

Views

543

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Apr 09, 2019

Copy link to clipboard

Copied

How did you set up the Success/Failure actions?

Some more info in:

4 Tips for Interactive Video - Captivate blog

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

On the quiz tab of knowledge check overlay 1, on success I execute a script which assigns a variable with 1 and then continues.

On failure Last Attempt I have continue:

The same thing is done on knowledge check overlay 2, except the success script and variable is named apple1_b.

On the slide with the video I have an On Exit script which checks to see if the variables assigned in the 2 knowledge checks are 0 (failed) or 1 (passed). If they're both 1 then I set a new variable (appleBadge1) with 1, and if either variables' value is 0, the appleBadge1 variable is set to 0 (I'm thinking now that the "show correct" step won't actually work because this is happening on slide exit, but I don't think this is causing the problem).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

You don't know the Preview button apparently, makes it much easier to read scripts.

Advanced Actions Dialog box in Captivate 2017/2019 - Captivate blog

Never use the On Exti event, it is done after the last frame, and your conditional action will pause the play head as well. You are never sure if an action on Exit is executed or not.

Available Events in Adobe Captivate - Captivate blog

Is the Failure message telling the learner to click the slide or press Y?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

Thanks for the Preview button tip. I like that. I'm a storyline user, so captivate is all brand new.

I've removed the On Exit script and assigned it to a button which the learner will have to click to see their results once the video is done. I can't get the timeline to get that far, however.

Yes, the first overlay slide will give a failure or success message saying to click the slide or press y. When I click the slide that message disappears, but nothing else happens. The overlay slide remains, I cannot click submit again or change my answer, and the video does not continue to play.

On success script for overlay slide:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

and sometimes the overlay slide doesn't appear at all - the video pauses but nothing happens

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

Did you upload the published folder to a webserver for testing? I have created several interactive videos, never had that type of issues. Have a look at this blog, where I explained how to set up the video

4 Tips for Interactive Video - Captivate blog

The described video plays from this link:

Custom Play/Pause button

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

No, I've only been previewing HTML5 in the browser. I'll try publishing to see if I get the same issue. Thanks for the help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

I think I've figured out what's causing the issue! I don't know how to fix it, though.

When I view the master slides, they're all 3 seconds long. But the video is 10 seconds. The stopping point is right at 3 seconds. If I move the overlays to happen before 3 seconds elapse the video will keep playing after them (but still stops after 3 seconds total). How do I change the master slide timing to be longer than 3 seconds? The timing panel in master view is blank, and I can't drag the timeline like on filmstrip view.  This is causing issues on other slides which are longer than 3 seconds, too - for example, animations are incomplete because the slide is pausing at 3 seconds.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

Master slides have NO timing at all.  For master slides the Timeline has the unique function to show the stacking order of the layers. But you have to show them for a certain duraton to make them visible. Master slides have no Timing Properties neither. You should read my sequence of psots about Timeline.

This is certainly not the case. You can add a shape button and set it to pause on a master slide, but that pause will not be timed, it will always be at the end of the timeline of each slide, whatever its duration. There is NO way on a master slide to set a pause at 3 seconds.

This is not the origin of your problems, believe me.... I have explored and trained about the timeline quie a lot.

If you have a pausing point at 3 seconds on each slide longer than 3 seconds, and you don't see that pausing point on the slide timeline, the only possible cause can be a shape button ​before those slides which is timed for the rest of the project and has a pausing point at 3 seconds. Check the slides before the interactive video slide to see if you have such a shape button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

Thanks! I do have several items which display for the entire project and I removed or extended the pause on all of them!

For some reason I cannot preview the project in the browser at all now! I just get the below, even after rebooting.

Can't seem to catch a break!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

Clearly a problem. Since you now tell that you have many pausing shape buttons timed for the rest of the project, makes it very difficult to see what the problem is. It is agreat feature, shape buttons, but you need to understand how the timeline is functioning. From your comment on master slides, that seems not really to be the case.  Something cn have been corrupted or you have created another problem. Try hiding slide per slide to find the cluprit.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

Thanks for all your help! I started a new project and copy/pasted the slides over, and I can preview again. Whew! Looks like I have to click Play to make the video continue after each overlay, so at least now I have something to troubleshoot, AND I can preview my edits! Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Lilybiri LATEST
Most Valuable Participant ,
Apr 11, 2019

Copy link to clipboard

Copied

It is not normal that you have to click Play after an overlay slide. There is still a conflict with a pausing point somewhere in the interactive objects timed for the rest of the project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Captivate User Guide
New Group