Highlighted

net:ERR_INVALID_RESPONSE

Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

I have just developed an Andriod app using Adobe Captivate.

 

The Captivate project makes use of "Web objects" to link to video files that are held on a separate server.

 

When I try to access any of these videos I get the following message

 

The web page at .... could not be loaded because..net:ERR_INVALID_RESPONSE 

 

Before you ask...I did not want to include the videos within the app as this would make it too large.

 

Any advice or suggestions would be most welcome. 

I solved the problem myslef.

 

I needed to add a few lines of code to the config.xml - these are...

 

<access origin="*"/>

<allow-intent href="http://*/*"/>

<allow-intent href="https://*/*"/>

<allow-intent href="tel:*"/>

<allow-intent href="sms:*"/>

<allow-intent href="mailto:*"/>

<allow-intent href="geo:*"/>

 

and 

<plugin name="cordova-plugin-whitelist" spec="1.2.0"/>

Views

115

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

net:ERR_INVALID_RESPONSE

Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

I have just developed an Andriod app using Adobe Captivate.

 

The Captivate project makes use of "Web objects" to link to video files that are held on a separate server.

 

When I try to access any of these videos I get the following message

 

The web page at .... could not be loaded because..net:ERR_INVALID_RESPONSE 

 

Before you ask...I did not want to include the videos within the app as this would make it too large.

 

Any advice or suggestions would be most welcome. 

I solved the problem myslef.

 

I needed to add a few lines of code to the config.xml - these are...

 

<access origin="*"/>

<allow-intent href="http://*/*"/>

<allow-intent href="https://*/*"/>

<allow-intent href="tel:*"/>

<allow-intent href="sms:*"/>

<allow-intent href="mailto:*"/>

<allow-intent href="geo:*"/>

 

and 

<plugin name="cordova-plugin-whitelist" spec="1.2.0"/>

Views

116

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 02, 2020 0
Adobe Community Professional ,
Jul 02, 2020

Copy link to clipboard

Copied

Hi,

Can you confirm the exact versions of your software and operating system.

Can you include screenshots of the settings you use?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2020 0
Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

I am using Adobe Captivate 2019 11.5.1.499 running on Windows 10.

 

I am opening the app using Android version 6.0.1 on an Asus Nexus 7 2013.

 

Here's the config.xml code for the app..

 

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns = "http://www.w3.org/ns/widgets"
xmlns:gap = "http://phonegap.com/ns/1.0"
id = "mhsi.library"
version = "1.4">
<name>MHSI-Library</name>

<description>
Captivate E-Learning Course
</description>

<gap:platform name="android" />

<plugin name="cordova-plugin-file" spec="4.3.3" />
<plugin name="cordova-plugin-device" />
<plugin name="cordova-plugin-inappbrowser" />
<plugin name="cordova-plugin-statusbar" />

<icon src="icon.png" />

<preference name="AndroidPersistentFileLocation" value="Internal" />
<preference name="permissions" value="none" />
<preference name="phonegap-version" value="cli-8.0.0" />
<preference name="target-device" value="universal" />
<preference name="fullscreen" value="false" />

<allow-intent href="https://*/*" />

<allow-navigation href="http://*/*" />
<allow-navigation href="https://*/*" />
<allow-navigation href="data:*" />
</widget>

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 0
Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

I solved the problem myslef.

 

I needed to add a few lines of code to the config.xml - these are...

 

<access origin="*"/>

<allow-intent href="http://*/*"/>

<allow-intent href="https://*/*"/>

<allow-intent href="tel:*"/>

<allow-intent href="sms:*"/>

<allow-intent href="mailto:*"/>

<allow-intent href="geo:*"/>

 

and 

<plugin name="cordova-plugin-whitelist" spec="1.2.0"/>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 0