Highlighted

No sound in Preview Project for Adobe Captivate 2017

Explorer ,
Jun 23, 2018

Copy link to clipboard

Copied

Greetings:

I am using Chrome and there seems to be some sort of issue going on with Adobe Captivate and the sound. First, the update in Chrome means that everyone has to initiate the sound for the web--which means projects won't play sound automatically.

My main issue, however, is that the sound on my title slide will not play on the web. I have set it up in Adobe Captivate correctly. It plays in Preview Slide mode. It will play if I Preview Project and then open it in Internet Explorer (which I hate). I do not like that we seem to be moving backward with compatibility here.  I thought we were past the days of having to use a certain type of web browser for content, but apparently not. I use Chrome often, and so does the majority of my clients--and I can and will no longer be able to use Adobe Captivate if this problem isn't fixed. I don't have this issue with Articulate Storyline.

Is anyone else experiencing this problem?

Derek

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

The recent change that was made by the update to Captivate 2017 was designed to get e-learning developers to start preparing NOW for what is going to be forced on them again in October when Chrome version 70 hits town and again turns off support for auto-playing without user intervention.  Although Windows browsers might in some cases still be allowing auto-play the fact is that they will also shortly be following suit.  It's just a matter of time.

I get the fact that there are a lot of Captivate developers right now that might not be agreeing with Adobe or Google Chrome's decision in this area.  I can see both sides of the issue, but the fact is that we (on this forum) have no control over what Adobe decides is the best course of action for their application.  It's not negotiable.

Adobe has quite clearly explained the reasons for their decision here:

Captivate responsive courses will not auto-play on browsers  

I am assuming that in comparing results between Storyline and Captivate 2017 you have tried setting AutoPlay to ON again as shown in the web page link shown above and then republishing to test?  Or have you left AutoPlay set to OFF as is now the default?

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

No sound in Preview Project for Adobe Captivate 2017

Explorer ,
Jun 23, 2018

Copy link to clipboard

Copied

Greetings:

I am using Chrome and there seems to be some sort of issue going on with Adobe Captivate and the sound. First, the update in Chrome means that everyone has to initiate the sound for the web--which means projects won't play sound automatically.

My main issue, however, is that the sound on my title slide will not play on the web. I have set it up in Adobe Captivate correctly. It plays in Preview Slide mode. It will play if I Preview Project and then open it in Internet Explorer (which I hate). I do not like that we seem to be moving backward with compatibility here.  I thought we were past the days of having to use a certain type of web browser for content, but apparently not. I use Chrome often, and so does the majority of my clients--and I can and will no longer be able to use Adobe Captivate if this problem isn't fixed. I don't have this issue with Articulate Storyline.

Is anyone else experiencing this problem?

Derek

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

The recent change that was made by the update to Captivate 2017 was designed to get e-learning developers to start preparing NOW for what is going to be forced on them again in October when Chrome version 70 hits town and again turns off support for auto-playing without user intervention.  Although Windows browsers might in some cases still be allowing auto-play the fact is that they will also shortly be following suit.  It's just a matter of time.

I get the fact that there are a lot of Captivate developers right now that might not be agreeing with Adobe or Google Chrome's decision in this area.  I can see both sides of the issue, but the fact is that we (on this forum) have no control over what Adobe decides is the best course of action for their application.  It's not negotiable.

Adobe has quite clearly explained the reasons for their decision here:

Captivate responsive courses will not auto-play on browsers  

I am assuming that in comparing results between Storyline and Captivate 2017 you have tried setting AutoPlay to ON again as shown in the web page link shown above and then republishing to test?  Or have you left AutoPlay set to OFF as is now the default?

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 23, 2018 0
Most Valuable Participant ,
Jun 24, 2018

Copy link to clipboard

Copied

Several long discussions are around about Crhome's decision to prevent AutoPlay in its desktop browser. Since this is apparently a trend in recent browsers, Captivate 10.0.1.285 disables AutoPlay for HTML output. If you used Preview Slide in a non-responsive project (which was the case, because AutoPlay was already disabled for responsive projects) you are not previewing, because it is labeled 'Play Slide'. The other preview methods, with exception of Preview HTML in Browser (and in SCORM Cloud) all use SWF temporary file, they will not give you a good preview.

That SL is not having the problem may be due to the fact that they really use SWF in a HTML wrapper, not full HTML output.

Here is one of the threads, if you use Search function, you(ll find a lot more:

Discussion - eLearning

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2018 0
Explorer ,
Jun 24, 2018

Copy link to clipboard

Copied

I appreciate your response. Here is a screencast of the problem: Adobe Captivate.mp4 - Google Drive

This seems to be a uniquely Adobe issue for the following the reasons:

  • As you mentioned, the issue seems to happen in Chrome. However, once I have enabled Chrome to play music there is still an issue. Further, even after I publish and load the file from my desktop the issue persists.
  • I have a project that uses the same intro music in Articulate and had zero issues with it playing or operating it in Chrome.
  • Lastly, it's not an SWF wrapped in an HTML player, unless Adobe publishes that way--which I know they don't.

What I find odd is that I contacted support about the issue and they were unable to replicate this and had no idea what I was talking about. Seeing how there are multiple threads about the topic, it's a bit concerning.

Thank you,

Derek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2018 0
Most Valuable Participant ,
Jun 24, 2018

Copy link to clipboard

Copied

I was talking about Articulate, when suggesting a HTML wrapper. Captivate publishes full HTML output, like a website. That is the reason why the disabled AutoPlay in Chrome is affecting Captivate output. If that is not the case with Articulate output, that seems weird. It is certainly not an Adobe only issue, since it is dictated by the HMTL browser jungle. If you use SWF output, everything will be fine, but that is short-sighted of course.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2018 0
Adobe Community Professional ,
Jun 24, 2018

Copy link to clipboard

Copied

Storyine has also had issues with this:

Audio not working for HTML5 output in Chrome using Storyline 360 - Articulate Storyline Discussions ...

They have released a fix but this is a temporary reprieve as everyone knows Chrome 70 will again lower the boom on this problem:

Chrome Audio Fix in SL360 - Articulate Storyline Discussions - E-Learning Heroes

As Lilybiri says, the browser landscape has become a jungle again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2018 0
Explorer ,
Jun 25, 2018

Copy link to clipboard

Copied

Yes, well I spoke with an engineer at Adobe and he has said that it is an auto-play issue with the browser. However, as I said it doesn't happen in Storyline. I'm not publishing the Storyline file as an SWF, and yet it works.

My process is simple for both Articulate and Adobe Captivate. I publish it for web and then host it using Amazon S3 via CloudBerry. I then take the Index (Chrome HTML Document)  file for Captivate and the story (Chrome HTML Document) for Storyline and get the URL code to embed on my site.

Also, to test the SWF you described I just disabled flash from being allowed on my Chrome settings and the Storyline file played fine--so I don't think the problem has anything to do with SWF. Further, as I mentioned this issue doesn't happen in Storyline published content. So, at this point, I'm not sure what to say. I definitely don't think the answer should be marked correct, but if you can explain it to me simply, considering the evidence I have mentioned, then please try again, because I'd really to understand the answers you both have provided.

Derek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 0
Most Valuable Participant ,
Jun 25, 2018

Copy link to clipboard

Copied

I will step back because my explanation seems not to be understood. SWF was mentioned because your project will work perfectly. Reason: Flash player was a standard over all browsers. That is not the case for HTML, each browser has its own rules. Rod confirmed that SL's HTML output suffers from the same problems. If the stoplitght is red, all cars have to stop whatever the brand. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 0
Explorer ,
Jun 25, 2018

Copy link to clipboard

Copied

I understand your analogy, but what I am telling you is that the stoplight is red and yet SL is able to get through the light. I'm not trying to be rude, but I have an  M.S. in Instructional Design & Educational Technology and I'm trying to explain that what Rod has described and what you have described is not the correct solution to this problem. I know that you are both volunteers for the community, but your answers are incorrect, based on my experience.

When I get off work today I can make a video demonstrating both, or you can just take my word for it. Either way, this thread is not going anywhere. The problem is with Adobe's output--but I am sure this not something that Adobe wants to hear.

Just as the last point, I am also an Adobe Campus Leader, so I'm not some casual user. If the issue is affecting me in this way I would say it should be a giant red flag for Adobe. Anyway, I have to get back to the job that actually pays me.

Derek 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 0
Adobe Community Professional ,
Jun 25, 2018

Copy link to clipboard

Copied

The recent change that was made by the update to Captivate 2017 was designed to get e-learning developers to start preparing NOW for what is going to be forced on them again in October when Chrome version 70 hits town and again turns off support for auto-playing without user intervention.  Although Windows browsers might in some cases still be allowing auto-play the fact is that they will also shortly be following suit.  It's just a matter of time.

I get the fact that there are a lot of Captivate developers right now that might not be agreeing with Adobe or Google Chrome's decision in this area.  I can see both sides of the issue, but the fact is that we (on this forum) have no control over what Adobe decides is the best course of action for their application.  It's not negotiable.

Adobe has quite clearly explained the reasons for their decision here:

Captivate responsive courses will not auto-play on browsers  

I am assuming that in comparing results between Storyline and Captivate 2017 you have tried setting AutoPlay to ON again as shown in the web page link shown above and then republishing to test?  Or have you left AutoPlay set to OFF as is now the default?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2018 0
Explorer ,
Jul 01, 2018

Copy link to clipboard

Copied

That's the fix I was looking for. Thank you.

Derek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2018 0
RodWard LATEST
Adobe Community Professional ,
Jul 01, 2018

Copy link to clipboard

Copied

That fix will work for SWF output but you will find that HTML5 output is unaffected by that setting now and will still show the play button on the first slide.  That's Adobe's way of saying: "Get used to it."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2018 0