Highlighted

Object on Quiz Slide Missing in Advanced Actions

Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

Sorry, I just posted a question a little bit ago But I came across another hiccup.

I want to add custom feedback for my quiz questions when in review mode. It is all only 1 feedback message, regardless of whether the user got the question right or wrong.

My plan was to "Show" the message on an "On Enter" event. But the object with the feedback does not show up in Advanced Actions. I tested with other objects on the slide, and none of them appear.

captivatehelp-missingobject.JPG

Is it because it's a question pool? A multiple choice slide?

I'm not quite sure how to proceed.

Thanks for your help!

I figured out the problem was because the slide was in a question pool. I copy/pasted it into the main timeline and the smartshape appears in the advanced actions dropdown as intended.

The client requested a randomized assortment of questions out of 10, so this is not entirely ideal, but maybe I can argue with them.

I wonder if this should be labeled as a bug report?

Views

122

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Object on Quiz Slide Missing in Advanced Actions

Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

Sorry, I just posted a question a little bit ago But I came across another hiccup.

I want to add custom feedback for my quiz questions when in review mode. It is all only 1 feedback message, regardless of whether the user got the question right or wrong.

My plan was to "Show" the message on an "On Enter" event. But the object with the feedback does not show up in Advanced Actions. I tested with other objects on the slide, and none of them appear.

captivatehelp-missingobject.JPG

Is it because it's a question pool? A multiple choice slide?

I'm not quite sure how to proceed.

Thanks for your help!

I figured out the problem was because the slide was in a question pool. I copy/pasted it into the main timeline and the smartshape appears in the advanced actions dropdown as intended.

The client requested a randomized assortment of questions out of 10, so this is not entirely ideal, but maybe I can argue with them.

I wonder if this should be labeled as a bug report?

Views

123

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 19, 2018 0
Most Valuable Participant ,
Dec 19, 2018

Copy link to clipboard

Copied

Not sure I understand well. Most objects on a quiz slide are embedded, have no individual timeline, no name.

With actions you can only control non-embedded objects. If you want to show a custom feedback, you need to create it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

Thanks Lilybiri,

The "q1feedback" in the screenshot is a smartshape with text that I added on top of the typical quiz slide. It's set to not be visible. But the shape doesn't appear in the advanced actions panel dropdown (nor the shared actions dropdown, when I tried that), even though it was created by me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Most Valuable Participant ,
Dec 19, 2018

Copy link to clipboard

Copied

You cannot have any custom object on top of quiz objects. Where is that shape?

It is strange that it doesn't show up: are you sure not to have used the same name several times?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

Here's a screenshot where you can see some of the slide, the rest hidden for privacy. I named a smartshape "testshape" and a text caption "testtext" and when I type "test" in the dropdown, neither appear.

captivatehelp-missingobject2.JPG

Is there perhaps another way of adding custom feedback to the Review mode?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Most Valuable Participant ,
Dec 19, 2018

Copy link to clipboard

Copied

I am worried, fear some corruption, hence my question about the names. The only times I had problems like this was when a name was used more than once for different objects, actions, variables, decisions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

I figured out the problem was because the slide was in a question pool. I copy/pasted it into the main timeline and the smartshape appears in the advanced actions dropdown as intended.

The client requested a randomized assortment of questions out of 10, so this is not entirely ideal, but maybe I can argue with them.

I wonder if this should be labeled as a bug report?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Most Valuable Participant ,
Dec 19, 2018

Copy link to clipboard

Copied

That was very important, missing information. How could I know this? Quiz slides in a question pool can be manipulated but it is a lot more difficult.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

My original post said, "Is it because it's in a question pool?"

There was no missing information.

But thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Most Valuable Participant ,
Dec 19, 2018

Copy link to clipboard

Copied

Have missed that sentence, I was screening the screenshot. Sorry about that.

I have a workaround, just created a small file and works for me: combination of actions in the file and in the question pool slides.. Will try to write a blog post, will be tomorrow. Something like 'conquer the question pools'.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

That would be cool! I look forward to seeing that!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0
Lilybiri LATEST
Most Valuable Participant ,
Dec 19, 2018

Copy link to clipboard

Copied

I see the thread is marked  'Answered' so I shoudln't bother about offering a a workaround.

To me it is not a bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2018 0