PNG showing up with black background

Explorer ,
Mar 26, 2009 Mar 26, 2009

Copy link to clipboard

Copied

All of a sudden my png images with transparent backgrounds are only showing up with black backgrounds in Captivate. I thought it was the photoshop at first but when I tried to pull old png images in that showed up fine before, the black background showed up. ANy ideas? Hopefully I am explaining this clearly.
TOPICS
Advanced, Editing

Views

267.8K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 26, 2009 Mar 26, 2009

Copy link to clipboard

Copied

Hi there

Have you tried editing the image properties and choosing a color to be rendered as transparent?

Cheers... Rick

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 26, 2009 Mar 26, 2009

Copy link to clipboard

Copied

Hi Rick,

Yes, I have done that before but you know how Captivate puts that fuzzy stuff around the edges. I never used to have to do that because I already set my png images as transparent background from creation. Now when I bring it into Captivate, Captivate is auto-adding the black background.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 26, 2009 Mar 26, 2009

Copy link to clipboard

Copied

Hi Rick,

Yes, I have done that before but you know how Captivate puts that fuzzy stuff around the edges. I never used to have to do that because I already set my png images as transparent background from creation. Now when I bring it into Captivate, Captivate is auto-adding the black background.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 27, 2009 Mar 27, 2009

Copy link to clipboard

Copied

Hi there!

I have the same problem. If you use the transparent functionality in the options all black areas of the picture are transparent. Not the outline area only. That won't help at all!

Regards
Markus

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 27, 2009 Mar 27, 2009

Copy link to clipboard

Copied

Hi all

Please report this to Adobe as a bug using the link below.

Click here to view the Wish Form/Bug Reporting Form

Cheers... Rick

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 01, 2017 Jun 01, 2017

Copy link to clipboard

Copied

Even am facing the same problem...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Jun 02, 2017 Jun 02, 2017

Copy link to clipboard

Copied

Only PNG24/32 supports Transparency, not PNG8.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 30, 2009 Mar 30, 2009

Copy link to clipboard

Copied

I am having the same problem only it's a white background. What the =
heck? Why do my transparent gifs that I made in Fireworks appear with a =
background in Captivate? Surely Captivate supports transparency. And =
if not .. then why the heck NOT?

I can't believe I never ran into this before.... :(


--=20
Nancy Gill
Adobe Community Expert
Author: Dreamweaver 8 e-book for the DMX Zone
Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
Technical Editor: Dreamweaver CS3: The Missing Manual,
DMX 2004: The Complete Reference, DMX 2004: A Beginner's Guide
Mastering Macromedia Contribute
Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web =
Development

"rokenn3rd" <webforumsuser@macromedia.com> wrote in message =
news:gqh866$kng$1@forums.macromedia.com...
> All of a sudden my png images with transparent backgrounds are only =
showing up=20
> with black backgrounds in Captivate. I thought it was the photoshop =
at first=20
> but when I tried to pull old png images in that showed up fine before, =
the=20
> black background showed up. ANy ideas? Hopefully I am explaining =
this clearly.
>

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 30, 2009 Mar 30, 2009

Copy link to clipboard

Copied

Oh .. I see .. I can set white to be the transparent color and now it =
works .. but the type that goes with the button now looks like crap .. =
and the white within the picture also now is the background color .. =
which I didn't want. May as well remake them to all be .jpgs with the =
background color around them. This is disappointing. =20

Nancy

"Nancy" <nancy@webwish.com> wrote in message =
news:gqr7u9$8i6$1@forums.macromedia.com...
I am having the same problem only it's a white background. What the =
heck? Why do my transparent gifs that I made in Fireworks appear with a =
background in Captivate? Surely Captivate supports transparency. And =
if not .. then why the heck NOT?

I can't believe I never ran into this before.... :(


--=20
Nancy Gill
Adobe Community Expert
Author: Dreamweaver 8 e-book for the DMX Zone
Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
Technical Editor: Dreamweaver CS3: The Missing Manual,
DMX 2004: The Complete Reference, DMX 2004: A Beginner's Guide
Mastering Macromedia Contribute
Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web =
Development

"rokenn3rd" <webforumsuser@macromedia.com> wrote in message =
news:gqh866$kng$1@forums.macromedia.com...
> All of a sudden my png images with transparent backgrounds are only =
showing up=20
> with black backgrounds in Captivate. I thought it was the photoshop =
at first=20
> but when I tried to pull old png images in that showed up fine before, =
the=20
> black background showed up. ANy ideas? Hopefully I am explaining =
this clearly.
>

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 30, 2009 Mar 30, 2009

Copy link to clipboard

Copied

Well, I wouldn't be frustrated if this was just not an ability that Captivate had. Thing is, I have had my png's with transparent backgrounds show up properly before. SO I am not understanding why they are not right now. I have not changed any settings, at least not that I know of.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 01, 2009 Apr 01, 2009

Copy link to clipboard

Copied

I think I figured it out. It seems as if Captivate doesn't handle png's over a certain resolution or size so well. For example, if my resolution in Captivate is set to 640 by 480, then I shouldn't try to bring in a png file that is 1200 x 800 or something like that. I use my graphics editor and bring it down to a manageable (ie, less than 640) size and then the transparent background automatically shows up. Not sure if that is the total issue but that seems to have solved my problem so far.

Robert

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2009 May 04, 2009

Copy link to clipboard

Copied

My problem is that the PNG does not appear at all. I can see it in the editor but when i preview the file, its not there.  So, I went ahead and used the jpg version of the same graphic and in Captivate, selected transparent background. I chose "white" and it worked.  the jpg appears with a transparent background!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2012 Feb 24, 2012

Copy link to clipboard

Copied

I was having the same problem today (with a 5KB file). I ended up using PS to re-save the .PNG in .GIF format instead. I still had to switch on the background transparency in Captivate. But it turned out relatively well. (Relative to the .JPG that I tried it with---the anti-aliasing with that file format was terrible.)

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2017 Feb 02, 2017

Copy link to clipboard

Copied

Scaling down the image worked for me
Thanks rokenn3rd

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2009 Jun 29, 2009

Copy link to clipboard

Copied

In my experience, Captivate 3 seems to interpret the transparency in an image as black if the file size is large.  It seems to happen in the resizing compression.  There are two ways I have found to overcome this:

1.       The most effective is to reduce the file size to less than 100kb.  For most Captivate projects this still offers a good quality resolution in PNG format.

2.       Using PhotoShop, lock the transparency then save the file again.  If the save was previously interlaced then choose the opposite (none) this time – reverse if interlaced previously.  Then reimport the file.  This is not always effective but for some quirky reason, sometimes it works.  It will not work with very large files but seems to work with stubborn smaller PNG files, where Captivate is interpreting transparency as black.

I hope this is of assistance to you.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2009 Jul 07, 2009

Copy link to clipboard

Copied

The solution I've found is to just ensure that the image you're importing is smaller than the slide size. If Captivate has to resize or crop your image it (for some reason) interprets transparent space as black. Just resize the image to have a width and height less than that of the slide before importing and all should be well.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 11, 2010 Aug 11, 2010

Copy link to clipboard

Copied

I know this is an old thread, but I just came across this problem and found a different solution that I thought I would share just in case it helps someone else.

I used the same custom png button with a transparent background (made in fireworks) for more than 50 projects with no problem.  Suddenly, the black background (with a white border) that others mentioned appeared on the 56th project but only after it was published.  It all appeared fine in the workspace.  None of the solutions above would work.

my solution:  I just merged the image button into the background and then placed a transparent button over it to create the action that I needed.  Hope that helps someone in the future!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2011 Jun 14, 2011

Copy link to clipboard

Copied

I found solution where I was having the same problem on browsers.

Problem at my end:

I was creating a transparent png's with image editor for web but in internet browsers it was showing a black background instead of transparent background.

Solution as per:

I find problem in my css file. Please check 'img' class in css modify or delete. it will remove the background.


Cheers!

Arsalan

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2011 Aug 25, 2011

Copy link to clipboard

Copied

I am using Captivate 5. My .png files were not transparent in the web browser exports. The problem was in the properties of the image. Uncheck "Allow Smoothing" and the gradient transparencies all work. This also resolved an issue with transparent text captions that were placed on layers above the .png showing color flashes during transitions.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2011 Nov 07, 2011

Copy link to clipboard

Copied

Make sure you have an empty layer below the cropped image before you save as a .png. Turn off the visibility of the layer below before you output. Do not use the "Save for web and devices feature, make sure you use File/Save as...

I'm assuming you're creating the image in PS.

Steve

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2014 Jun 09, 2014

Copy link to clipboard

Copied

Solved:

1. Open in Photoshop

2. Image > Mode > RGB / CMYK

3. Save

Seems that Indexed Colors were causing the problem on my end.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Jun 09, 2014 Jun 09, 2014

Copy link to clipboard

Copied

OMG who is still using Indexed Colors nowadays? They are only 8-bit. I abandoned them over 15years ago. Sorry, for the exclamation but you should have seen the question marks in my eyes!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2014 Jun 09, 2014

Copy link to clipboard

Copied


I still use them extensively if I don't need the color depth. Not so much for Captivate but definitely in HTML pages.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

Try double klicking on your "background" layer in your layers palette, to make it into a layer, layer 0 by default. You shouldn't have any proplems after that.

Hope it helps!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines