Highlighted

Quiz Submit button is working only on correctly answered questions

New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

Hello; I've created a lesson with a 10 random question post-test slides.  They are pulling from a 15 question pool.  The questions' submit buttons worked off and on.  So I created a 2nd question pool with dummy questions.  Through this, I've realized that when the answer is correct, the Submit button works and proceeds to the next question.  If it is answered incorrectly, it doesn't move on to the next question and the viewer has to click the Play button in the skin.

The hover state appears and the cursor changes to a hand in both correct and incorrectly answered questions.

Lastly, I have no idea what this means: I created an 11th question, not random, just a regular multiple choice question.  When I previewed it in html mode, the submit button worked, even with the wrong answer.  The other random questions Submit buttons are working only for correct answers.

Does anyone know why this is happening and how to fix it?  I updated today and it is still doing it.

Thanks

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

What is the number of attempts that you have allowed on each of these questions?  If you have allowed multiple attempts then the action for On Last Attempt will only occur when the learner has no more attempts on the question left.  If you have set the question to Infinite Attempts then there can never be a last UNSUCCESSFUL attempt and that means your user would be stuck on the question until they answer it correctly.

So how many attempts does the learner have?

Views

89

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Quiz Submit button is working only on correctly answered questions

New Here ,
Jul 25, 2019

Copy link to clipboard

Copied

Hello; I've created a lesson with a 10 random question post-test slides.  They are pulling from a 15 question pool.  The questions' submit buttons worked off and on.  So I created a 2nd question pool with dummy questions.  Through this, I've realized that when the answer is correct, the Submit button works and proceeds to the next question.  If it is answered incorrectly, it doesn't move on to the next question and the viewer has to click the Play button in the skin.

The hover state appears and the cursor changes to a hand in both correct and incorrectly answered questions.

Lastly, I have no idea what this means: I created an 11th question, not random, just a regular multiple choice question.  When I previewed it in html mode, the submit button worked, even with the wrong answer.  The other random questions Submit buttons are working only for correct answers.

Does anyone know why this is happening and how to fix it?  I updated today and it is still doing it.

Thanks

Adobe Community Professional
Correct answer by RodWard | Adobe Community Professional

What is the number of attempts that you have allowed on each of these questions?  If you have allowed multiple attempts then the action for On Last Attempt will only occur when the learner has no more attempts on the question left.  If you have set the question to Infinite Attempts then there can never be a last UNSUCCESSFUL attempt and that means your user would be stuck on the question until they answer it correctly.

So how many attempts does the learner have?

Views

90

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 25, 2019 0
Most Valuable Participant ,
Jul 26, 2019

Copy link to clipboard

Copied

Can you teel if you have deleted any of the embedded object on the quizzing master slides? Did you use the default Submit button? Did you tweak the Suvmit process?

Please tell also which exact version you are using (Help, About Captivate).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 26, 2019 0
New Here ,
Jul 26, 2019

Copy link to clipboard

Copied

It's Captivate 10.0.1.285.  I did use the default Submit button and didn't delete any embedded objects.  Per Rod's response, I did have Infinite Attempts.

Thank you both very much.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 26, 2019 0
Lilybiri LATEST
Most Valuable Participant ,
Jul 26, 2019

Copy link to clipboard

Copied

You didn't have a Failure event in that case.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 26, 2019 0
Adobe Community Professional ,
Jul 26, 2019

Copy link to clipboard

Copied

What is the number of attempts that you have allowed on each of these questions?  If you have allowed multiple attempts then the action for On Last Attempt will only occur when the learner has no more attempts on the question left.  If you have set the question to Infinite Attempts then there can never be a last UNSUCCESSFUL attempt and that means your user would be stuck on the question until they answer it correctly.

So how many attempts does the learner have?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 26, 2019 0