Highlighted

"Play audio" action not working properly since Chrome update

Explorer ,
May 15, 2018

Copy link to clipboard

Copied

Hey there,

I am experiencing an issue with the "play audio" action in advanced actions. Using version 9.0.1.320.

I am finding that when I use this action, conditional or standard, tied to a shape button or click box it does not work when previewing HTML5 at all. I have tried it with and without autoplay selected. I am also finding that it is inconsistently working when published in HTML as well. Other co-workers have helped me in testing with the same results.

It was discovered after I completed a course last week and my mgr was reviewing it. I had several activities with feedback and she was not getting the audio for the feedback at all, but I could hear the feedback when I tested it. Then we heard about the Chrome update and realized that may have something to do with it. I updated Chrome and cleared my cache and now I am also seeing the same results with no audio.

Anyone else experiencing this?

Views

294

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

"Play audio" action not working properly since Chrome update

Explorer ,
May 15, 2018

Copy link to clipboard

Copied

Hey there,

I am experiencing an issue with the "play audio" action in advanced actions. Using version 9.0.1.320.

I am finding that when I use this action, conditional or standard, tied to a shape button or click box it does not work when previewing HTML5 at all. I have tried it with and without autoplay selected. I am also finding that it is inconsistently working when published in HTML as well. Other co-workers have helped me in testing with the same results.

It was discovered after I completed a course last week and my mgr was reviewing it. I had several activities with feedback and she was not getting the audio for the feedback at all, but I could hear the feedback when I tested it. Then we heard about the Chrome update and realized that may have something to do with it. I updated Chrome and cleared my cache and now I am also seeing the same results with no audio.

Anyone else experiencing this?

Views

295

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 15, 2018 0
Adobe Community Professional ,
May 15, 2018

Copy link to clipboard

Copied

The reason for this is that the most recent update to Chrome addresses a concern that many users had about multimedia automatically playing when visiting certain websites. In most cases, this was video or audio advertising that was very obtrusive. The solution that Google and other browser makers have implemented was to disallow multimedia from playing. I've also noticed that several of my older publicly available courses are now not playing the audio from the first slide.

The solution, in this case, is to republish your project with Autoplay turned off. This way users will be presented with a blank slide and a large play button. This gives your users the ability to opt-in to playing your eLearning project. It does mean an extra step for your end users but it should allow all multimedia to run properly.

2018-05-15_10-57-37.png

You can make this intro slide a little more interesting by performing some customization. Check out this video tutorial to see what is possible:

Adobe Captivate - Get Rid of Blank Project Startup - YouTube

Some additional information is available here:

Captivate responsive courses will not auto-play on browsers

Paul Wilson, CTDP | https://captivateteacher.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 1
Most Valuable Participant ,
May 15, 2018

Copy link to clipboard

Copied

You must have missed some discussions. Chrome has imitated the browsers for mobile devices: took out the AutoPlay for all HTML pages, and sees no difference between normal webpages and eLearning pages. The present solution could be to use another browser until they decide to do the same. Lot of noise about that, I started a discussion but discussions are not very popular:

How to cope with Autoplay turned off? - eLearning

You are on CP9, but have to know that the most recent version of CP2017 did turn off AutoPlay as well, not only for responsive projects but also for HTML output for non-responsive projects. To replace the ugly white screen with the default black play icon, I offered some suggestions in this blog post:

Poster Image - AutoPlay - Captivate blog

Someone found that blog as well, as you can see....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 1
Community Beginner ,
May 15, 2018

Copy link to clipboard

Copied

Lilybiri... that answered my unasked question... why did my current project stop autoplaying! Seems strange that the AutoPlay option is still available, but I'm guessing that's for swf output. Capture3.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
Most Valuable Participant ,
May 15, 2018

Copy link to clipboard

Copied

Indeed, for SWF output, as long as it lasts, it is still possible to have AutoPlay and Preloader (works only in SWF as well). But for HTML output you'll have to cope with AutoPlay disabled. To be able to upload a poster image (was also possible for SWF, did that mostly because I hate somethingplaying automatically when getting to a web page) you have to uncheck AutoPlay.  For an easier workflow I proposed some feature requests in the discussion mentioned above. If you could help to log those requests?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
Community Beginner ,
May 15, 2018

Copy link to clipboard

Copied

Done.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
Explorer ,
May 15, 2018

Copy link to clipboard

Copied

Lilybiri and Paul,

I actually have read all of the thread posts out there about this Chrome update and Captivate including your "how to cope" and feature requests. I am aware of what is happening and why, but I am experiencing other issues that I stated in my post and wondering if they are also tied to this Chrome update. I'm not sure if you both misread my post maybe, but I mentioned that I tried publishing with and without autoplay in Captivate.

In my post I was wondering if anyone is experiencing other audio issues (like mine with the "play audio" action) in Captivate ASIDE from the autoplay issue on first slide.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
Most Valuable Participant ,
May 15, 2018

Copy link to clipboard

Copied

Sorry, my last answer was to Dar29.

I reread your question. Your version is bit outdated, can you please upgrade to 9.0.2.437. Not sure that will solve the problem.

Are you talking about a responsive or a non-responsive project? For a non-responsive project the only Preview method that is using a temporary HTML output is Preview HTML ib Browser (F11). All Preview methods for a responsive project use HTML output. But you also talk about a published version, is it uploaded to a webserver or a LMS for testing?

Did you try with another browser to check if it is linked to Chrome or not? The mentioning of Chrome did confuse me, I thought indeed that the much talked about new Chrome version with AutoPlay turned off was the culprit. Reason why I want to know if it is happening only in Chrome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
Explorer ,
May 15, 2018

Copy link to clipboard

Copied

It is an non-responsive project and I have been previewing HTML5 in browser only. I do not wish to upgrade to 9.0.2.437 for a couple of reasons. My co-worker however does have that version and is experiencing the same issues when helping me test.

The course works fine in IE. Chrome is the only browser that I have noticed it in which is why I did mention the Chrome update. I am convinced it is tied because I did not have the issues until I updated my version of Chrome.

I am testing from "preview HTML in browser" where it consistently fails as well as published files on my desktop which are inconsistently failing. Not going to push it to the LMS until the issues are resolved.

It would be very coincidental if this didn't have something to with the Chrome update. Just wondering if anyone else is experiencing other issues that may be tied to this Chrome update.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0