Highlighted

Return to Final Exam Questions

New Here ,
Oct 09, 2020

Copy link to clipboard

Copied

Hello,

 

I have a course with a custom TOC which is available during the final exam. If a learner leaves mid FE to visit any of the slides before it, when they return to the FE they get stuck and cannot progress to the next questions.

 

I know it is probably not recommended to allow learners to leave during a final exam, but its a possibility that they might go looking for answers.

 

How would I allow them to return to the question from where they left off in the final exam?

 

Or if this is not possible, how would I be able to reset the final exam whenever they return to it?

 

I guess the other option would be to disable the custom TOC while the FE is in progress. I have already tried this by setting up AA On Enter for each of the questions. This did not work for some reason and the buttons in my custom TOC were still active once the first question appeared, but then were disabled after clicking the home icon to return to the start - very strange. 

 

I do not have a preference on keeping the TOC open or disabled while the FE is in progress - so whatever is quickest solution is what I will likely go for! 

 

Thanks in advance,

 

Reuben

Views

83

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Return to Final Exam Questions

New Here ,
Oct 09, 2020

Copy link to clipboard

Copied

Hello,

 

I have a course with a custom TOC which is available during the final exam. If a learner leaves mid FE to visit any of the slides before it, when they return to the FE they get stuck and cannot progress to the next questions.

 

I know it is probably not recommended to allow learners to leave during a final exam, but its a possibility that they might go looking for answers.

 

How would I allow them to return to the question from where they left off in the final exam?

 

Or if this is not possible, how would I be able to reset the final exam whenever they return to it?

 

I guess the other option would be to disable the custom TOC while the FE is in progress. I have already tried this by setting up AA On Enter for each of the questions. This did not work for some reason and the buttons in my custom TOC were still active once the first question appeared, but then were disabled after clicking the home icon to return to the start - very strange. 

 

I do not have a preference on keeping the TOC open or disabled while the FE is in progress - so whatever is quickest solution is what I will likely go for! 

 

Thanks in advance,

 

Reuben

Views

84

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 09, 2020 0
Adobe Community Professional ,
Oct 09, 2020

Copy link to clipboard

Copied

The quickest and easiest solution based on your criteria is to add Back and Skip buttons to all your question slides. Open your Preferences window and select the options for Back and Skip and it should automatically place these buttons based on your Master slide layout on all your question slides.

2020-10-09_17-00-07.png

 

Paul Wilson, CTDP | https://captivateteacher.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2020 0
Most Valuable Participant ,
Oct 09, 2020

Copy link to clipboard

Copied

I never allow navigation during quiz slides, if you want the learner to answer the questions and have the possibility to multiple attempts on question level. You idea to hide the TOC during the quiz is probably the best solution. That is also the reason that the Hide playbar  option is provided in Quiz Preferences. That rule applies always. Which means that learner will be frustrated if you add skip and back buttons, because once they leave a question slide to find the answer in content slides, they will never be able to answer that question during the present attempt on quiz level.

 

Design of quiz slides is that answers are blocked and attempts on question level are considered to be exhausted if the question slide is left. There are two exceptions:

  • If you use the remediation feature, but that is not fitting for your use case.
  • If you turn on Submit All. That will allow free navigation through slides as long as you remain in the Quiz scope. That last requirement is not as strict anymore in the most recent versions of Captivate as it used to be in the past. You didn't mention the version you are using.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2020 0
New Here ,
Oct 12, 2020

Copy link to clipboard

Copied

Hello,

 

Paul - I have tried adding the back button and that's no really suitable for what I want to achieve as it doesn't solve the issue of not being able to re-submit answers after leaving questions slides.

 

Lily - I agree that the other options you suggest are not fitting for my case too. 

 

I think I will have to go with the disable menu option, however like I said I couldn't get this working when I tried before. I have a custom TOC and the two shartshape buttons I want to disable (1 hamburger icon, 1 home icon). These buttons are set to appear for the rest of the project and always on top - perhaps this overides my advanced actions to disable them on enter for all of my questions? I'm not sure why else the disable action wouldn't be working as intended, perhaps you may have an idea?

 

FYI - I am using the latest version of Captivate 2019. 

 

Thanks,

 

Reuben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Most Valuable Participant ,
Oct 12, 2020

Copy link to clipboard

Copied

Disabling should work, sorry to insist that something else is wrong. I would really hide that TOC on quiz slides as I explained before. Look at it from the learner's viewpoint: seeing a menu that doesn't allow you to be used is at least frustrating, isn't it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
New Here ,
Oct 12, 2020

Copy link to clipboard

Copied

Hey,

 

Disabling doesn't work for me and this is ideally what I want to do rather than having to re-position all of my question cotent to fill blank space left by the menu. I have tried the following AA to trigger On Enter for all my questions, but no good.

 

Screenshot 2020-10-12 at 13.45.27.png

 

Any suggestions? Or is it simply not posible to disable smartshape buttons that are selected to display for 'rest of project' and 'object on top'? 

 

Let me know what you find.

 

Thanks,

 

Reuben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Adobe Community Professional ,
Oct 12, 2020

Copy link to clipboard

Copied

In addition, you may wish to use the hide action for these objects or object groups as well. Disabling only make them not function, whereas hiding the objects will make them completely unavailable to your students. If you are allowing backward movement you would need to "show" and "enable" them if they return to slides where they should be visible. 

Paul Wilson, CTDP | https://captivateteacher.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Most Valuable Participant ,
Oct 12, 2020

Copy link to clipboard

Copied

I have just double-checked in one of my projects. I inserted two shape button, timed for the rest of the project, always on top, created an advanced action to disable them both.Everything worked as expected. I was almost 100% sure, but nevertheless. There is no reason why disabling wouldn't work for shape buttons timed for the rest of the project, on top.

Something else must be awry. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
New Here ,
Oct 12, 2020

Copy link to clipboard

Copied

Thanks Paul,

 

Not quite the solution I'm looking for but I appreciate you taking the time to comment.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
New Here ,
Oct 12, 2020

Copy link to clipboard

Copied

Lily,

 

It's good to know this is possible, thanks for testing. There must be something else going on in my project that stops it working for me. I will do some more testing on my side and hopefully I can figure it out 😕

 

Otherwise, I will go with the hidden solution and just have to take some extra time in moving slide objects around to fit the blank space. 

 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
Most Valuable Participant ,
Oct 12, 2020

Copy link to clipboard

Copied

If those are default quiz slides, which are using the quizzing master slides, you wouldn't even need to fill the blank space. Did you edit the master slides also those dedicated to quiz slides?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
New Here ,
Oct 13, 2020

Copy link to clipboard

Copied

Sorry to dodge the question, but the blank space is the least of my concerns.

 

I have repeatedly tried to disable my custom toc menu buttons (hamburger & home) On Enter on each question in my pool, but this does not work. They are still enabled on entering a final exam question slide, but then become disabled if I navigate anywhere else in the course using those buttons. 

 

A correction on my initial post, these buttons are actually images, not smartshapes - although I can't see why that would make any difference.

 

These buttons that appear always in project and on top have their own set of AA's with variables which are designed to show/hide custom toc menu items. I can only think that these AA's (show always, on top) are overriding my new AA's to disable the menu buttons during the FE. Because of the complexity, I think I would need someone to take a look at my file.

 

The last resort is the hide menu suggestion. However, when testing this, something weird happened too. Despite the home button no longer being visable in the menu, when I click in the area where it is supposed to be, it skips to the next question. It does so repeatedly!

 

Ultimately, I need a solution that prevents learners from getting stuck mid final exam if they leave it in the same session and I'm running out of ideas. Please help. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0
Adobe Community Professional ,
Oct 13, 2020

Copy link to clipboard

Copied

Have you considered switching this assessment to Submit All? This way, students can move about the course freely and only submit all the answers to the questions once they've answered all of them. All your questions will remain unlocked until the student is ready. Try turning this behaviour on and test it out to see if you like the results.2020-10-13_8-43-38.png

 

P.S. Here's a tutorial I did if you don't like submit all appearing on all your question slides: https://youtu.be/16YdlQRAU4g

 

Paul Wilson, CTDP | https://captivateteacher.com
In this Adobe Captivate video tutorial, I got a message from Anjalli Pawar about disabling the Submit All on the majority of slides. Not a complicated soluti...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0
Most Valuable Participant ,
Oct 13, 2020

Copy link to clipboard

Copied

I give up... already made the suggestion for Submit All before, and if everything has to be repeated. What a waste of time... At least I do read everything before posting an answer to avoid that type of cluttering of a thread. Sorry for the rant.

See one of my first answers:

"Design of quiz slides is that answers are blocked and attempts on question level are considered to be exhausted if the quesiton slide is left. There are two exceptions:

  • If you use the remediation feature, but that is not fitting for your use case.
  • If you turn on Submit All. That will allow free navigation through slides as long as you remain in the Quiz scope. That last requirement is not as strict anymore in the most recent versions of Captivate as it used to be in the past. You didn't mention the version you are using.'

What you tell about 'images' remaining active (I checked with shapes) sometimes happened in the past. In that case you need to use two commands

  • Show, followed by Enable
  • Disable, followed by Hide

As I told this seemed not to be necessary anymore for me. Worth to try before deciding that the project has corrupted. If this solves the problem, fine.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0
Adobe Community Professional ,
Oct 13, 2020

Copy link to clipboard

Copied

I did see that you mentioned Submit All, but you also had many other items in that post to unpack. I thought the original poster might have missed it, so I expanded on its benefits and even provided a further resource that might benefit them. Perhaps if you were more kind and respectful towards others trying to help, these threads would be less cluttered and more users would be inclined to try and help others.

Paul Wilson, CTDP | https://captivateteacher.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0
reuben. LATEST
New Here ,
Oct 13, 2020

Copy link to clipboard

Copied

Thanks for the reminder Paul about Submit All. I do not currently see this fitting for my requirements, but it is good to know that this option is available should I need it. 

 

Lily, I echo Paul's statement about showing kindness and respect towards others. It is clear as day in the Community Guidelines and there is even a reminder when going to post a reply, so there's no excuse for that type of response.

 

I do not know why you show so much frustration when I have only tried what you suggested in trying to disable and/or hide my custom toc menu buttons. The conversation had already moved on from the original suggestions to remediate and submit all as they are not fit for purpose for me.

 

I have now tried the use of two commands as suggested and still there is the issue of the final exam jumping to the next question when the empty area where the home icon usually displays is clicked. I even tried the old fashioned method of placing a transparent shape over the clickable area the first question is still skipped when clicking in this area on the slide. I suspect this is because of the display on top settings.

 

The chance of users clicking in this area when there is no button on display is low - however I don't want to take any chances so need a solution. Otherwise, there could be something wrong with my file. It would be good to know how I would go about requesting someone to take a look at my file if possible.

 

Regards,

 

Reuben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2020 0