Skin not showing in published training

Community Beginner ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

I tried adding a skin that will show a playbar at the bottom of the screen, but it does not work. There are only buttons to mute the video or to close the tab.

 

My project was created from a PowerPoint presentation. Each of my slides consists of 99% inserted video, with the last 1% of playtime dedicated to the underlying PowerPoint slide. How can I get a playbar at the bottom of the screen so that the user/learner may scrub through the video forward and backward?

Views

220

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Most Valuable Participant , Feb 10, 2021 Feb 10, 2021
That is the reason why the navigation possibilities are greyed out. Pretest slides need all to be in sequence at the start of the project. Once the pretest is finished the learner should never go back to it. For that reason Captivate prevents all navigation. You can only override by using custom navigation. I hope you did read what I wrote in my first answer about the progress bar being for the whole project, never per slide.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Did you add the videos as Event Videos or Slide Videos?

 

From your description it sounds like they are Event videos and this would mean the video timelines are not synchronized with the main timeline of the project.  If you want to have the Skin playbar able to Pause or Play the videos, they need to be inserted as slide videos.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

They are inserted as Slide Videos

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

OK.  Then have you selected the option to have a playbar yet?

 

Go to Project > Skin Editor > Show playbar control.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

Yes, I have "Show Playback Control" and "Playbar Overlay" both checked.

 

However, at the bottom there are many checkboxes that are greyed out. "Progress Bar" is one of them. This might be the problem. Is there any way to be able to unlock those grey checkboxes?

Img for Forum.PNG

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

Navigation is prevented in these circumstances:

  • You have Pretest Slides
  • You have activated Branch aware

 

Is one of those the case?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

I DO have several Pretest Multiple Choice Slides.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

That is the reason why the navigation possibilities are greyed out. Pretest slides need all to be in sequence at the start of the project. Once the pretest is finished the learner should never go back to it. For that reason Captivate prevents all navigation. You can only override by using custom navigation.

I hope you did read what I wrote in my first answer about the progress bar being for the whole project, never per slide.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

Thank you for your explanation/help. As workaround I added shapes to go foward or backward and checked "Use as Button". Under "On Success" I chose either "Go to Previous Slide" or "Go to Next Slide". 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

That is what I meant by custom navigation. BTW remember that you can have a shape button on the master slide(s). That can be very useful, because such a button will have its pausing point always at the end of each slide, based on the master slide, whatever its duration.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 10, 2021 Feb 10, 2021

Copy link to clipboard

Copied

Even if you had a playbar including the progress bar, and you inserted the videos as slide video (which can be controlled by Captivate as is not the case for event video) that progress bar would be for the full project, including all slides. That is not what you want I suspect.

If you insert event video, you get an individual control panel for each video, but that doesn't include a progress bar.

EventControl.PNG

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

So even if I do not have pretest questions or branch aware it is impossible to have a playbar for each individual video on each slide?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

For an individual playbar per slide you need JS or something similar. There is a suggestion in this thread:

https://community.adobe.com/t5/captivate/need-some-javascript-help/m-p/11852111#M288733

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines