Highlighted

skipping knowledge checks vs regular slides

Contributor ,
Aug 27, 2018

Copy link to clipboard

Copied

I am running into something weird.

I am creating a lesson where the user will select the group to which they belong, one of ten groups. This will set a variable with a value of the group id.

I have some slides and some knowledge-checks that unique to each group.

I have some advanced actions running on enter  that checks the group of the user, if the slide is not meant for the user's group, captivate is issued the command to go to the next slide.

When going through regular content slides, when a user comes to a section of slide not meant for them, the content area is blank for a fraction of a second and you can see the playbar advancing rapidly through those slides. Once the user hits a slide they are supposed to see, content shows up and everything works great, as expected.

BUT once I add in knowledge-check slides things go wonky.

The scripts and navigation still work fine, a user will rapidly progress through the slides until they reach a slide they are supposed to see. What is different it that the users get a quick flash (one frame?) of of each of the knowledge-check slide contents as they are moving rapidly through the slides they are supposed to skip.

Has anyone experienced this and come up with a solution?

I have tried to add some javascript to change the CSS to hide they question elements, but my CSS changes seem to get overridden by the Captivate player.

Thanks!

Views

247

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

skipping knowledge checks vs regular slides

Contributor ,
Aug 27, 2018

Copy link to clipboard

Copied

I am running into something weird.

I am creating a lesson where the user will select the group to which they belong, one of ten groups. This will set a variable with a value of the group id.

I have some slides and some knowledge-checks that unique to each group.

I have some advanced actions running on enter  that checks the group of the user, if the slide is not meant for the user's group, captivate is issued the command to go to the next slide.

When going through regular content slides, when a user comes to a section of slide not meant for them, the content area is blank for a fraction of a second and you can see the playbar advancing rapidly through those slides. Once the user hits a slide they are supposed to see, content shows up and everything works great, as expected.

BUT once I add in knowledge-check slides things go wonky.

The scripts and navigation still work fine, a user will rapidly progress through the slides until they reach a slide they are supposed to see. What is different it that the users get a quick flash (one frame?) of of each of the knowledge-check slide contents as they are moving rapidly through the slides they are supposed to skip.

Has anyone experienced this and come up with a solution?

I have tried to add some javascript to change the CSS to hide they question elements, but my CSS changes seem to get overridden by the Captivate player.

Thanks!

Views

248

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 27, 2018 0
Advocate ,
Aug 27, 2018

Copy link to clipboard

Copied

How are you getting to the other slides? What sequence of actions?

I typically use "Jump to Slide X" actions which bypass all the other stuff and just hit the slide number that I indicate.

I would not expect to see a brief glimpse of anything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2018 0
Contributor ,
Aug 27, 2018

Copy link to clipboard

Copied

The player progresses linearly through every slide.

The action on each on entry is basic: if userGroup does not equal 2 then next slide.

I am trying to use this method, because it is so much faster to develop rather than keeping track of all that branching for 10 different groups. It becomes overwhelming when you have some slides that all groups need to see, some slides only some groups need to see, and some slides that are unique to each group. If something is not working with my method, all you have to do is check the action on the slide that is showing/hiding incorrectly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2018 0
Contributor ,
Aug 27, 2018

Copy link to clipboard

Copied

Here is a video of whats going on:

And here is a screen shot of the slides in the project:

Screen Shot 2018-08-27 at 3.17.59 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2018 0
Advocate ,
Aug 27, 2018

Copy link to clipboard

Copied

Hmm...

I think I would have to understand a little more of the flow to suggest something different for the branching aspect.

What if the knowledge check slides had a blank shape over the top for the first few frames that disappeared if you were to land on that slide but is there long enough to just appear blank when travelling past?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2018 0
Most Valuable Participant ,
Aug 27, 2018

Copy link to clipboard

Copied

I will leave you to StagPrime, but my experience tells me that you can often avoid a lot of problems by rearraging the slide sequence. The flickering can be reduced by adding short Fade in transitions to the objects (not to the slide, slide transitions are not valid for HTML outputà.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2018 0
Most Valuable Participant ,
Aug 30, 2018

Copy link to clipboard

Copied

@StagPrime Custom objects on a question/KC slide are always under the embedded objects of that slide in the z-order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 30, 2018 0
Explorer ,
Aug 28, 2018

Copy link to clipboard

Copied

Hi Chris,

Suggestions:

Consider testing a regular Question Slide to see if you get the same results of flickering. Uncheck the reporting of answers located under the Quiz tab. The question should not report anything to the LMS for scoring.  You can hide the Quiz Results page because as you know it is generated when a Question Slide is used.  

Not sure if the progress bar will be a part of your finished project, but I would uncheck it in the Skin Editor so that it does not appear with the other functions on the playbar.  Users may use it to skip ahead and that could cause other issues.

 

Thanks 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2018 0
Most Valuable Participant ,
Aug 28, 2018

Copy link to clipboard

Copied

KC slides and quiz slides use exactly the same master slides, wonder why they would behave differently? Because KC slides are reset automatically when leaving them?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2018 0
Contributor ,
Aug 29, 2018

Copy link to clipboard

Copied

Veem -

Nope, replacing the KC slide with a normal quiz slide produces the same results.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2018 0
Explorer ,
Aug 29, 2018

Copy link to clipboard

Copied

Hi Chris,

Don't give up.  I know it can be rather frustrating.  The answer is out there.  If something seems to be a fix, I will let you know. 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2018 0
Engaged ,
Aug 31, 2018

Copy link to clipboard

Copied

I think there something going on with your advanced actions - they are triggering when you enter the slide.  Could you post a shot of your advanced actions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2018 0
Contributor ,
Sep 04, 2018

Copy link to clipboard

Copied

The advanced actions are very simple. Not sure what could be wrong, but here they are!

Screen Shot 2018-09-04 at 8.45.20 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
Lilybiri LATEST
Most Valuable Participant ,
Sep 04, 2018

Copy link to clipboard

Copied

Please, especially when posting a conditional action, use the Preview screen, so that all decisions and the ELSE parts are visible. The Preview button is the first button in the op right control panel (arrow). All functionality of the Advanced Actions dialog box are explained in:

Advanced Actions Dialog box in Captivate 2017 - Captivate blog

You show that the shared action is used, what did you define as parameter, the variable cmtest?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0