Highlighted

Smart Shape won't come to the front of text entry box

Community Beginner ,
Dec 13, 2018

Copy link to clipboard

Copied

Good afternoon,

Working on a course with text entry boxes and using a Smart Shape as a feedback caption that's supposed to come up on top of the text entry box. However, even though it's on the appropriate place on the timeline, the text entry boxes keep coming up on top of the Smart Shape. I've also tried using a Text Caption and get the same result. Any ideas what could be causing this? Pics are below. I'm using Captivate 10/2017 and the Smart Shape shown below is at the top in the timeline. It previews correctly in Captivate, but in HTML5 preview and output shows how you see it below. Thanks in advance for any help!

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Text Entry Box will always be at the top of the stack in HTML output, probably because it needs to have the focus. Changing the layer stack order in the Timeline will not change that. It is similar to the priority of embedded quiz objects on a question slide: they always are on top of the stack.

I suppose JS could change the z-index, but I never found a workaround for HTML output in Captivate itself. For SWF output lot of workarounds were possilble (I put the shape on a short slide before the present slide, timed for the rest of the project and it did show on top of quizzing objects or TEB's).

Views

243

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Smart Shape won't come to the front of text entry box

Community Beginner ,
Dec 13, 2018

Copy link to clipboard

Copied

Good afternoon,

Working on a course with text entry boxes and using a Smart Shape as a feedback caption that's supposed to come up on top of the text entry box. However, even though it's on the appropriate place on the timeline, the text entry boxes keep coming up on top of the Smart Shape. I've also tried using a Text Caption and get the same result. Any ideas what could be causing this? Pics are below. I'm using Captivate 10/2017 and the Smart Shape shown below is at the top in the timeline. It previews correctly in Captivate, but in HTML5 preview and output shows how you see it below. Thanks in advance for any help!

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Text Entry Box will always be at the top of the stack in HTML output, probably because it needs to have the focus. Changing the layer stack order in the Timeline will not change that. It is similar to the priority of embedded quiz objects on a question slide: they always are on top of the stack.

I suppose JS could change the z-index, but I never found a workaround for HTML output in Captivate itself. For SWF output lot of workarounds were possilble (I put the shape on a short slide before the present slide, timed for the rest of the project and it did show on top of quizzing objects or TEB's).

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Enthusiast ,
Dec 13, 2018

Copy link to clipboard

Copied

Based on your design I would think that you have a hidden smart shape or text box that you show based on the text box and an action you created.

Text boxes have their own success / failure / hint as part of the object but that is not what you are talking about.

As I recall, when you create output in flash their was no Z order implied in the compiled file. But that is not the case in html5. So what happening is that when the slide renders in html5 it is placing the text entry box at the highest level in the html5 Z order (stacking order by default) so it will always be on top. You may have to move the hidden object or your response to a different location on the slide.

If any others have info on Z stacking order in how Captivate will render html5, would be appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 15, 2018

Copy link to clipboard

Copied

Can you include a screenshot of your timeline, it might hold a clue there as well

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Dec 15, 2018

Copy link to clipboard

Copied

Text Entry Box will always be at the top of the stack in HTML output, probably because it needs to have the focus. Changing the layer stack order in the Timeline will not change that. It is similar to the priority of embedded quiz objects on a question slide: they always are on top of the stack.

I suppose JS could change the z-index, but I never found a workaround for HTML output in Captivate itself. For SWF output lot of workarounds were possilble (I put the shape on a short slide before the present slide, timed for the rest of the project and it did show on top of quizzing objects or TEB's).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 17, 2018

Copy link to clipboard

Copied

Thanks! I thought so, but was hoping there was another way.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 22, 2020

Copy link to clipboard

Copied

Hello, I just found out about this problem. Since you answered this two years ago, I was wondering if the latest versions of Captivate feature a setting to override the z-index order of the teb.

 

I have a teb which on success I want a modal to pop up in the middle of the screen. I struggled for a good hour trying to figure out why the modal kept appearing behind it. It wasn't until I gave up and did some research that I landed on this thread.

 

If there is still no native way to change the teb's z-index, do you have any idea how I can accomplish what I'm trying to do? The only thing I can think of is to write and Advance Action that shows the modal and also hides the teb on success. Then when I click on the close button in the modal I can reveal the teb again. I'm not sure if this works, or it's an elegant solution but I'm kind of desperate.

 

Thanx

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Sep 22, 2020

Copy link to clipboard

Copied

No since the TEB always gets the focus, it needs to be on top. That is still logically the case in 11.5 version.

 

I do not really understand the word 'modal' being not a native English speaker and having issues with 'slang' words. I only know it in the musical world, not the sense you are talking about.

 

If this is a popup, I may have a workaround but need to double-check.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advocate ,
Sep 22, 2020

Copy link to clipboard

Copied

Whenever I run into this situation, I simply hide the TEB when I show any object which overlaps.

 

When the overlapping object is hidden, I show the TEB again.

I think you're right to think it.

It works just fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...