Swf compilation Failed.

New Here ,
Dec 06, 2012

Copy link to clipboard

Copied

How do I get rid of this error!!!! I have read through your discussion thread for hours and see tons of people with this issue. I see no explanation of how to resolve it. What good is this program if I can't use it?

I have re-installed Captivate, Updated Java and Flash. I tried to even create a new project with only pages created from your templates and no outside info and I still get "Please verify if any of the actionscript is used as user variable name."

Some one said to remove the JAVA_TOOL_OPTIONS environment variable. I have no idea what that is or where I would remove it from. non of the other suggestions to fix this issue have worked.

Views

1.5K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 06, 2012

Copy link to clipboard

Copied

Hi esilver35,

     SWF compilation can come for following reasons:

1) If you use action script keywords in Captibvate project variables.

Resolution: Make sure you don't use action script keywords.

2) If you have invisible characters present in text fields.

Resolution: Don't Copy/Paste text from some other application to Captivate text fields like Project information etc. Type with key board. Create a blank project and publish, if you still get SWF compilation issue then your 64 bit JVM might be corrupted.

3) if your installation is 64 bit Captivate, 64 bit JVM might be corrupted.

  • Add  Use32BitJVMForPublish = 1  in AdobeCaptivate.ini  file
  • Close and Re-launch Captivate.
  • Re-publish the project

Captivate ini file is present at “C:\Program Files\Adobe\Adobe Captivate 6 x64” location

You can send me a mail at sankaram at adobe dot com if it still doesn't resolve the issue.

Thanks,

Sankaram.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 07, 2012

Copy link to clipboard

Copied

JVM was corrupted. Thank you so much for the quick response and detailed resolution to my issue. Files are all previewing and publishing fine now.


Thanks,
Ethan

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 11, 2013

Copy link to clipboard

Copied

What folder is the .ini file located in?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Feb 11, 2013

Copy link to clipboard

Copied

In the installation folder of Captivate, in this case it is the 64-bit version.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 11, 2013

Copy link to clipboard

Copied

Thanks for your quick response; however, I'm still lost.  Here's where I am: C:\Program Files\Adobe\AdobeCaptivate 6 x64

and there are TONS of folders so I'm not sure which "folder within the folder" the .ini file is located.  I've searched several but am not able to find a .ini file.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Feb 11, 2013

Copy link to clipboard

Copied

It is not in a subfolder there, it is in that main folder for me. Maybe you have to tweak the settings, because some system files may be hidden. Try to sort on file type, and look for the ini-files, AdobeCaptivate is the first file in that type

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 11, 2013

Copy link to clipboard

Copied

It worked!!!!!  Took a while for my IT Dept to get the permissions right so I could see the .ini file but this did the trick!

Thanks for your help Lilybiri!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Mar 19, 2013

Copy link to clipboard

Copied

Hi Sankaram,

I have followed these three steps, and have even reinstalled Java, yet still have the error.

What other advice do you have?

Thanks,

Rick Wiedeman

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Feb 06, 2021

Copy link to clipboard

Copied

Good day Mr Sankaram,

I have followed your steps, edited the .ini file

 

Nothing works.

 

The error persists. now whatdo i do?

 

Regards,

Daniel

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 06, 2021

Copy link to clipboard

Copied

This is an extremely old discussion. I'm not sure what you are trying to do. Still, as of December 31, 2020, SWF is no longer supported by Adobe. It would be best if you did not publish any eLearning with SWF selected in your publish settings or attempting to publish with SWF elements embedded in your course as Flash player has been disabled from all computers. Use the HTML5 Tracker found in the Project dropdown menu of Captivate 2019 to identify any SWF elements in your course and remove them or replace them with something that doesn't rely on SWF. When you attempt to publish your course, be sure to deselect the SWF option when publishing, so you only publish with HTML5.

Paul Wilson, CTDP

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more