Tab and Shift-Tab in Captivate 2019

New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Hello. I'm struggling with a problem with keyboard accessibility. I'm publishing the project as html5. There are several smartforms used as buttons that I can focus with the tab key on my slide. When i'm on the last smartform the shift-tab should bring me to the smartform before last. But focus jumps out of the slide to focus buttons in the browser (in my case it's Firefox or Chrome).

This last smartform is faded out two seconds bofore the slide ends. Can this be the cause for this strange behaviour?

Views

136

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 22, 2021 Mar 22, 2021
That is the only setting of that type. Your issue may be that you are using Shift + Tab and not just the Tab key. You may need to provide another way for the learner to reach the next slide, e.g. a Next button for that purpose.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

It should be simple to test whether that is the issue.  Just remove the fade out and retest.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Thank for the quick response.

I tested it when the smartform is shown until the end of the slide, but there is no difference. When on the last smartform of the slide the shift-tab activates a button in the browser window, the tab key will jump to the first object in the tab order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Then it's certainly a bug in Captivate!?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Not sure if it is a bug in Captivate or just something wrong with your setup.

 

What do you mean by a 'smartform'?  Are you referring to a Text-Entry Box object in Captivate?

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

@RodWard  In non-English versions 'form' stands for Shape.  When they translate this is what appears.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Lilybiri is right. It is a form (I've got the german version of Captivate and didn't know the english name). In my case there are several rectangles, that are used as buttons.

In the settings I checked something like 'keybord tabulator restricted to slide elements' in 'File' - 'Project-informations' - 'Category - Project - Settings for Publishing' (I think that should restrict the tab-Key to the slide). Perhaps there's a similar setting for the shift-tab-Key, that I didn't found yet?

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

That is the only setting of that type.

Your issue may be that you are using Shift + Tab and not just the Tab key.

You may need to provide another way for the learner to reach the next slide, e.g. a Next button for that purpose.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines