Highlighted

Text Entry box not pausing timeline in HTML5. Captivate 2019

New Here ,
Oct 15, 2020

Copy link to clipboard

Copied

I am using captivate 2019. In the project I have a text entry box with 1 attempt. Correct action is set to jump to the next slide.

 

On failure it is set to conitnue. Then some other things happen on the timeline and another text entry box appears. This sescond text entry box is not pausing the timeline. When I preview in HTML5 it just plays through the timeline. When I click preview project from this slide it works as expected. When I publish using html 5 as a scorm zip file and load to our LMS it does not work.

 

Are there any known issues?

 

 

Views

100

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Text Entry box not pausing timeline in HTML5. Captivate 2019

New Here ,
Oct 15, 2020

Copy link to clipboard

Copied

I am using captivate 2019. In the project I have a text entry box with 1 attempt. Correct action is set to jump to the next slide.

 

On failure it is set to conitnue. Then some other things happen on the timeline and another text entry box appears. This sescond text entry box is not pausing the timeline. When I preview in HTML5 it just plays through the timeline. When I click preview project from this slide it works as expected. When I publish using html 5 as a scorm zip file and load to our LMS it does not work.

 

Are there any known issues?

 

 

Views

101

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 15, 2020 0
Most Valuable Participant ,
Oct 15, 2020

Copy link to clipboard

Copied

Can you post a screenshot of the Timeline panel please?

And log the full version number, which you find under Help, About Captivate. There have been 5 releases under the common name CP2019.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
New Here ,
Oct 16, 2020

Copy link to clipboard

Copied

Looks like it is Captivate 11.5.1.499

 

First click box works just fine, the second one does not pause and just goes right through the timeline.

 

Captivate Timeline.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0
New Here ,
Oct 16, 2020

Copy link to clipboard

Copied

Captviate 2019 11.5.1.199

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0
Most Valuable Participant ,
Oct 16, 2020

Copy link to clipboard

Copied

Today a patch was released, we are at version 11.5.5.

Timeline is not complete, what is above Text_Caption_1765?

Can you insert the system variable cpInfoCurrentFrame? Run the slide with HTML in Browser (F11) and check the frame number where the slide pauses with the first TEB.

Since you use the Last Attempt action, it means that you validated the TEB. Is that also the case for the second TEB?

I just did set up a similar slide for testing, and everything worked as expected. Last Attempt for the first validated TEB was set to Continue, and the slide paused at the pausing point of the second TEB. I see that you decreased the inactive part a lot, but that shouldn't be a problem normally.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0
New Here ,
Oct 19, 2020

Copy link to clipboard

Copied

I made sure we had the most current version of Captivate (2019 11.5.5.5.33) installed and created a new file just to start from scratch to remove any other issues that may be contributing.

 

The screen shot below shows the timeline. The first text entry box displays and pauses as expected. (Frame 46) I get it wrong and it plays through the timeline. It briefly pauses on the second text entry box (Frame 97)

It then plays to the end of the slide.

 

Text Entry Box.png

Text Entry GIF.gif

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 19, 2020 0
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

How about just inserting a dummy button next to the slide, off on the side, then position the button's pause location where you want it on the timeline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Most Valuable Participant ,
Oct 19, 2020

Copy link to clipboard

Copied

@Anton - Blank Page  That will not solve the TEB problem, which has more meaning than just to pause the slide.

 

@chrisb98549147  Can I see the setup of the second TEB? I told that I double-checked the situation and everything works as expected for me in the same version. However I would never push the pausing point of a TEB to the end of the slide, please move it at least 0.1sec to the left.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 19, 2020 0
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

@Lilybiri I have extended the timeline out and it still is not pausing. I have moved the pause point in the TEB as well as created more time after the pause and tried various things with the timeline , it does not seem to change anything.

Here are the options for the 2nd TEB.

 

Text Entry Box Options.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
Most Valuable Participant ,
Oct 20, 2020

Copy link to clipboard

Copied

Giving up. I cannot reproduce your problem at all, with exactly the same settings.

Can you reproduce this in a new project? I start to suspect that slide or the project is corrupted. Those are tough problems when there is no way to mimick them myself.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

The second example I started from a new project. The subsuquenst screen shots were created in a new project where all the same issues occur.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

@Lilybiri I have removed the failure caption on the first text entry box. I suspect the issue has to do with the timing of the caption and the pause on the 2nd TEB.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
Most Valuable Participant ,
Oct 20, 2020

Copy link to clipboard

Copied

Normally feedback messages are independent from what happens on the slide. I did watch your video, where you clearly show that the play head moves to the last frame of the slide.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

I removed the failiure caption and it works as expected. I think I will just have to adjust the timelines to get them to work accordignly.

 

This is a major blow. We have several files that are setup this way (previously using flash output and worked fine) We are now preparing our files for HTML5 output so I guess we will juts jave to adjust everyting manually.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0
Lilybiri LATEST
Most Valuable Participant ,
Oct 20, 2020

Copy link to clipboard

Copied

Was this a file which you had to update for HTML output? 

In older versions captions were used for feedback messages, but since quite a number of versions shapes are used. My testing was with shapes. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2020 0